[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

Sideloading fp1-kk444-CH-0.1.zip works, that’s all I can say for now (with your recovery). Maybe a screenshot is easier. Thanks for showing that 4.4.4 is possible.

1 Like

Would you suggest switching from CM to the new build?

Will you publish your sources so we can use it for an updated cm build as well?

1 Like

[Recovery] I like the ClockworkMod Recovery much better than the standard Android recovery. Can we keep that one or are there possible licensing strings attached? I guess the ROMs won’t mind which one we use, but CMR is much easier to use and navigate (up, down and enter work like expected), so I guess it’s also better for “normal” users. It also allows quick full backups.

1 Like

Or if you have a TB backup you can simply restore it from a backup and it works flawlessly :slight_smile: but you have to restore your widgets (I didn’t find a way to restore them with TB yet!)

I have some problems running OpenCamera and Barcode Scanner, they crash and are unable to open the camera device, I’ll investigate further

Bye! :smile:

For me restoring widgets with TB works.
I restore the App datas of the Widget-Apps & the Launcher, the I restore “Homescreen Widgets” and the I restart the phone.

Thanks, maybe it depends on the sequence of restoring, because I restore the same things but I don’t have the widgets on the screen, only the app icons and the contacts…

Hi allz
Step by step installation of stock rom android 4.4.4 for FP1 & FP1U is required for common users like me. because i do not understand how to flash or upgrade my FP1U (repartitioned). Thanks

To be honest, then this unofficial ROM that is still very much under development probably isn’t for you quite yet. Wait a bit longer for the version to become more stable (so you don’t end up flashing a new version every couple of days), or wait for an official update (though there is no guarantee that there will be one). If you do want to play around with it read this thread and the thread over at XDA - together with the pages linked from there you pretty much have a step-by-step guide. Before you start please note:

So if you go down this route know that there may be help, but you should assume that you’re pretty much on your own if/when something doesn’t work.

Also, from the XDA thread:


Hence the emphasis on play above - don’t depend on a device with a custom ROM. Only use it if you can afford to lose that phone and the data on it.

That being said, here’s some points to get you going:

  • I urge you to read the entire topic at XDA, and this topic here to understand what is and isn’t working in the ROM.
  • Make a backup of all the data on the device. Note that the backup & restore app isn’t sufficient - it doesn’t back up everything. The forum has tips on proper backups, search around a bit. Titanium backup is usually recommended.
  • Post number 6 over at XDA has instructions for flashing (as does a link from a post by DUBWiSE about a week ago in this thread). Just use the latest files referenced in the original post of the XDA thread instead of whatever file is mentioned in the guide, if differences exist, as there has been a rapid succession of newer versions).
  • Instructions for installing adb can be found all over the net (e.g. here if you’re using windows), but beware of downloads from untrusted sources.
  • Also, please be aware of the recovery procedures as outlined on the XDA wiki here, and make sure you understand them so you can rescue yourself if something goes wrong.

Best of luck, and if you find any bugs that haven’t been reported in the XDA thread or here, please report them!


My fault :wink: or better… XPrivacy functioning very well :stuck_out_tongue: I blocked too much /proc access so they were unable to open the camera device properly.
Bye! :smile:

haven’t looked into it, but this install guide for CM 11 should work alright for stock rom as well I’d guess. Just switch rom and just to be sure recovery.


Yep, I can also report back that the camera worked with both ROMs. I forgot to report that here. I guess it’s better to remove XPrivacy for testing (just don’t install the 2nd part) because 4.4.4 brings it’s own system … I don’t think’s it’s better, but for testing :wink:

Just about ready installing this great piece of work. Had to retry flashing 3 times and to wipe the data partition (has been encrypted before).
Everything seems to work fine right now, and: snappy!

Have a bit of trouble with the location of my osmand maps / can’t access sdcard, but that’s another story I am afraid.

0.4 released. Head over to XDA and give it a try.



You can’t access SD card from where?


Hi Allz… I installed Stock ROM 4.4.4 in light of instruction posted at XDA forum in my FP1(U) via CWM. The phone working great but sometime the upper slide does not work and I have to restart my phone. I don’t know why? May be expert can solve this. I also tried video recording / photo and work fine. I installed Google Play Store on the same method described in XDA forum. Thanks to all who created this nice stuff. Phone restart faster than its original rom. I did not check my phone thoroughly but I hope it will work fine. Thanks to all brothers

Only from osmand. I will explore, don’t bother yet. Maybe I typed in the wrong location. Will try the new Rom tonight, great work, no errors yet for me

Osmand works as designed, had to open the access to the storage using sdfix.
Testing 4.4.4 now

So far I found the following problems with latest 0.4 on FP1 (first edition):

  1. Stock camera: The maximum resolution setting is 3 MP resulting in pictures with a resolution of 2048x1536 (4:3). But Open Camera from fdroid gives full 8 MP (3264x2448).
    With both apps there seem to be some issues with the focus (both auto and manual), especially in low light conditions. Sometimes it is impossible to focus at all. The focus on 4.2.2 works much better.

  2. Display sleep timeout: Whatever timeout is set the screen goes off after about 10 seconds. This does not happen immediately after boot, it just happens after some time after boot. Activating “Stay awake” under developer options prevents the screen from going off though.

  3. After some time long pressing the middle button to show recent apps stops working.

  4. After some time the screen locking stops working. Neither pressing the power button nor the display sleep time out results in a locked screen. This is independent from the chosen lock setting.


Confirm#2 and#3, and #4. No application history for me either

Additionally, status bar/messages not expandable.

Still on 4.4.2 I confirm 1) and 3) from @ralf_xda post, I also add that for me 3) is a bit different: it seems the home button gets the event of a long press but there is a 3-4 seconds delay before showing the list of active apps (like a 3-4 seconds freeze).
I add two (I think) useful information:

  1. Bluetooth LE WORKS! :slight_smile: I tried with a prototype device at work and it connects to the device, pairs normally and receives data (can’t say more due to NDAs :wink: ); moreover I can’t see the device name in the list of devices, but eventually I don’t see it as blocking so much…
  2. battery consumption is very optimized, especially in standby I get about 2-3% fall in 8-9 hours (in Peace Of Mind mode) while on 4.2.2 the consumption was about 8-10%; this morning I had still 15% charge after a 2 days and 13 hours run of normal use, while previously I hardly reached more than 2 days!
    Bye! :slight_smile:

0.5 released that

  • fixes the first camera issue (resolution selection incomplete)
  • enables SELinux