[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

@chrmhoffmann: I find it really awesome that you are taking your time to show us a possible future for updated Android on the FP1!
Some months ago it seemed a very sad and dying topic, but now I am highly encoured to follow your progress (even without having the possibility to help)!!
Keep on - I (we) like it!! Cheers, Robert

P.S.: Does it mean you bought a FP1 or got one from FP to test your builds?

1 Like

Both - the one I bought died. I am guessing something wrong with the USB plug.


But it was no official “sponsoring” from FP (which I would highly appreciate)?

And in one sentence, how you would now rate the future-proofness of the FP1 after your recent succes to port 4.4.2.? Are you optimistic (from the software-point of view)?

Great that you are in the FP-boat!

Yes, it was somehow official sponsoring. They sent me an FP1U unit - after my own one broke down.

I have troubles fixing the remaining instabilities. But I have some hope… After 4.4.x it will be really difficult as there is definitly no MTK support at all for this chipset AFAIK.



But IMHO 4.4.x would be a very nice end-state for this phone.


I just want to share the current Android History Plot from Wikipedia, to which I added the FP1+FP2 release dates (approx.)
Without any comments from my side for the moment …
Cheers, Robert


Any chance you are going to open source your build files along with build instructions?


0.7 released…

Changelog fp1-kk444-CH-0.7:

  • National roaming should be fixed (at least as good as CM). If you still have issue with national roaming, send me your mmc/mmn data.
  • Try original FP1 lens parameters for fm50af lens
  • Attempt to fix the problem where sometimes the scrollbar and recents screen stopped working.

Full CTS result for version 0.7:



On 4.4.4-0.5 I confirm all the previous @ralf_xda 4 issues.
I also add Xposed framework gives me a compatibility alert so I didn’t install it yet (on 4.4.2 it worked quite well).
I’ll try 0.7 ASAP :smile:

Thank you very much @chrmhoffmann for your great work!

+DjDas how did it go with 0.7?

1 Like

Didn’t flash yet, but it seems the problem with the screen timeout and sometimes with the status bar not expanding to see the notifications is linked with the missing lock screen.
I didn’t understand yet why the lock screen ceases to appear (I use only sliding for unlocking but I tried also with pattern), but when I turn on the phone and it doesn’t appear it seems the screen timeout is the same as if it was still on the lock screen (few seconds); then, after this using the device a bit (browsing the web or reading the email), the timeout restores at the one configured (as if the screen was “unlocked”).
I can’t provide logcats nor a reproducible use case, but I want to try 0.7 before further investigations :smile:
Thank you very much, bye!

I am on v7 and the only issue so far is the camera, it only shows 6,2 Mp max. Lockscreen timeout seems fixed. Xposed is ok with the zip-file by Quallenauge.
Great work!!! Thanks a lot

Ohh nice, I really need to check this out.
Hopefully I can find some time next week to install this on my FP1.

1 Like

@chrmhoffmann: it seems the lock screen issue is fixed! :slight_smile: and as I supposed even the screen off timeout issue disappeared, so I think they were linked together :smile:
Thank you very much!

The default camera app is a bit misleading. For some reason, the MTK guys have used “Preview size” (also in other translations) for something called pref_camera_picturesize_ratio_title that defines the picture ratio (16:3, 4:3).

This means you have to go to the camera settings->Preview Size and change it to “Standard (4:3)” and then you can see the 8MP in the “Picture size” menu.

Or just use another camera app.



0.8 is up. It fixes the problem that the google location services did not run. And thus location was not working very well (apart from GPS).



Everything runs well, thank’s a lot for your excellent work. - great-

1 Like


You said, xposed works for you with the fix from Quallenauge. I tried the same but can’t get xposed to work. How exactly did you do it?

I got the xposed installer from here: http://repo.xposed.info/module/de.robv.android.xposed.installer
I installed the apk. Then I downloaded the latest zip from Quallenauge in the xda-thread. Reboot to recovery, apply zip.

But xposed still does not work. It looks like this:

I used the version 2.6.1 (de.robv.android.xposed.installer_v32_de4f0d.apk ). Then rebooted into recovery , wiped cache and dalvik-cache, then installed the latest zip from Quallenauge.
Maybe it’s important that I first installed the version 05 from chrmhoffmann, then open-gapps-arm-4.4-nano-20151118.zip, booted, installed de.robv.android.xposed.installer_v32_de4f0d.apk, rebooted into recovery and then flashed the latest zip from Quallenauge.
Then I booted into recovery, wiped cache and dalvik-cache, installed version 08, then then open-gapps-arm-4.4-nano-20151118.zip again, then the zip from Quallenauge.
I do not really know but everything works now this way. I guess you have to try out…
Good luck…

1 Like