English

UBPorts 16.04 updates + feature tests

ubuntu
Tags: #<Tag:0x00007f9ff8cf0220>

#81

No, I didn’t because apparently you could use that, “except on the Fairphone 2 where this method does not work”.

But this info seems to be over a year old now, perhaps I could give that a shot anyway.

Edit (as root, sudo was the same):

ubuntu-device-flash --server=http://system-image.ubports.com touch \ --device=FP2 --channel=ubports-touch/16.04/stable --bootstrap --wipe
2018/12/01 23:59:16 Expecting the device to be in the bootloader... waiting
2018/12/01 23:59:16 Device is |FP2|
2018/12/01 23:59:16 Flashing version 3 from ubports-touch/16.04/stable channel and server http://system-image.ubports.com to device FP2
68.99 MB / 68.99 MB [=====================================] 100.00 % 12.71 MB/s 
378.89 MB / 378.89 MB [===================================] 100.00 % 17.86 MB/s 
Can't boot recovery image

… same for the devel channel … and fastboot itself works, so what’s wrong here?
In Fastboot mode, to boot a recovery (or any) image, the image would have to be signed (how to do this is known). Since I don’t know where ubuntu-device-flash downloaded the files to, I can’t have a look.

There are images for boot, recovery and splash at http://cdimage.ubports.com/devices/, file date is June 30, 2018.
The recovery image there is not signed, so it can’t be booted with fastboot as is. Edit: I signed it, and fastboot can boot it … makes no difference, though.

I suspect the stuff that ubuntu-device-flash downloads is from http://system-image.ubports.com/pool/, but it looks too cryptic there for me.


#82

Indeed the ubuntu-device-flash never worked for FP2.

For install help, you can always go to telegram, they have a dedicated group for helping new people to install UT :slight_smile:


#83

I used the ubuntu-device-flash only for downgrade purposes. I wasn’t aware, that it doesn’t work for install. I apologize.

Maybe you should reconsider to put your findings about installer to ubports forum, or file an issue, if there is not already one filled in for your kind of troubles. Or the most badass thing would be to go for the bughunt by yourself, debug the installer and make an pull request with fixes. :slight_smile:

Have fun.


#84

BTW, I think ubuntu-device-flash is only available on Ubuntu. I had to struggle with a couple of things as I’m on opensuse and several hints/scripts/etc. only work on Ubuntu (easily).

Trying to fix the installer is something I found not too easy. Maybe that’s because I’m basically only familiar with strongly typed languages and not JavaScript. But then I guess a lot comes down to conventions in the ecosystem that I’m just not aware of.
I would like to see and participate in some kind of installer hackathon, though.


#85

If the installer would work like intended, I guess it would be super-convenient.
But it very obviously doesn’t work reliably yet, and so you can easily get stuck, because they don’t give you an alternative way to install (at least on the Fairphone 2, otherwise ubuntu-device-flash looks promising).

Not everybody is a developer able to patch the installer source code and build it from source, but there are experienced users out there.
They could just list the steps the installer is trying to do, and then let the users figure out manually what exactly fails why on their devices and how to prevent/ work around it … and with the feedback from this, the installer would improve in no time.
It seems either that would be technically impossible for some reason, or it’s too easy :slight_smile: .

I couldn’t install it on my Ubuntu in the Windows Subsystem for Linux, which is newer than 16.04 … so perhaps it’s even limited to older Ubuntu because Canonical themselves don’t do Ubuntu Touch anymore?

I could install and run it on Linux Mint 18.1, which is based on Ubuntu 16.04.


#86

There’s actually a recent topic in the UBports forum about giving the installer some love (i.e. improvements) at https://forums.ubports.com/topic/2049/send-some-ubports-installer-love-week-5


#87

The ubuntu-device-flash appears to be an golang application, which can be compiled on many platforms. The compilation of an golang project should be as easy as install golang, use go get command to fetch-build-install. I tried only on ubuntu. Thus the compile process is a little tricky now.


#88

I switched back to Fairphone Open some hours later since my device was rebooting randomly. I will wait for this system to be reliable before considering adopting it for good.


#89

The OTA-6 update for Ubuntu Touch is now released, and will be made available to all users progressively through the next five days.
With it you can expect some significant improvements to the Morph Browser, the OnePlus One, and several other fixes.
Find out more at: https://ubports.com/blog/ubports-blog-1/post/ubuntu-touch-ota-6-release-186

A big thank you for all contributors!

#UBports #UbuntuTouch #OTA6 #Shiny #Release