English

TWRP (with Tipatch) Backup-Restore Including Internal storage fails error 255

Tags: #<Tag:0x00007f05da2811a8>

One month ago I created a complete twrp-backup (I’m on FPOS) on my sd-card including data (internal storage) by using Tipatch.

Now today I did something brave: I tried to restore my backup 3 times.
It looked like that:

Everytime it ends up with an error:

"extract TarFork() process ended with ERROR 255

The end of the recovery.log looks like:
edit: first lines of log were wrong:
Here are the right ones:

   > 11305384 bytes)

==> extracting: //data/app/org.mozilla.firefox-1/oat/arm/base.art (file size
532480 bytes)
==> extracting: //data/app/org.mozilla.firefox-1/base.apk (file size 53586257
bytes)
tar_extract_file(): failed to extract
//data/app/org.mozilla.firefox-1/base.apk !!!
I:Unable to extract tar archive ‘/external_sd/TWRP/BACKUPS/e503c01f/2019-03-03–
14-50-18_fp2_sibon-userdebug_7.1.2_18.10.0_sibon-280/data.ext4.win002’
Error during restore process.
I:Error extracting ‘/external_sd/TWRP/BACKUPS/e503c01f/2019-03-03–14-50-
18_fp2_sibon-userdebug_7.1.2_18.10.0_sibon-280/data.ext4.win002’ in thread ID 0
I:Error extracting split archive.
Error during restore process.
extractTarFork() process ended with ERROR: 255
I:Set page: ‘action_complete’
I:TWFunc::Set_Brightness: Setting brightness control to 255
I:operation_end - status=1
I:Set overlay: ‘’
I:TWFunc::Set_Brightness: Setting brightness control to 5
I:TWFunc::Set_Brightness: Setting brightness control to 0
I:TWFunc::Set_Brightness: Setting brightness control to 255
I:Set overlay: ‘’
I:Set page: ‘clear_vars’
I:Set page: ‘restore_select’
I:Set page: 'restore’Truncating string cache entries.
I:Set page: ‘main’
I:Set page: ‘clear_vars’
I:Set page: ‘main2’
I:Set page: ‘advanced’
I:Set page: ‘copylog’
I:Set page: ‘action_page’
I:operation_start: ‘Copy Log’
I:Copying file /tmp/recovery.log to /external_sd/recovery.log

Here is the complete log: edit: the file before was wrong.
Edit: here is the right file:20_20recovery.pdf (2.5 MB)

When booting the system a very long “Change is in your hands”.
Then a wizard starts like using the phone for the first time. My previous apps are there but some of them crash (like Threema). My personal data seem to be lost. Edit: Now I got an corrupted FPOS 7.xx

My recovery failed!!!

I don’t know anything about Dalvik Cache etc. But I did a few TWRP backups and restores successfully before without problems but all with an unpatched TWRP aka without the internal storage.

Do I have to wipe something before I restore my backup including internal storage?
Or do I have to do something else in order to perform my restore successfully?

Could anybody help me?:sob:

I’m confused, your logs suggest you’re creating a new backup on the external SD card (and failing). Are you sure these are the logs from the restore operation?

Edit after uploading the right log-file:
Now I am sure!
But if you are right maybe my full backup including internal storage was not successfull and that would be the reason why I can’t restore that backup…

Do I have to assume that my personal data are lost or is there any hope?

If somebody confirms that my data are lost I don’t have to wait any longer and so I would try a complete wipe and a clean install now.

Btw. I backed up my contacts and userdata of my most important apps before. They are on my sd-card…

I deleted the wrong file from my post and uploaded the right file.
So the “confusion” should be solved now, mea culpa!:wink:

Can anybody help me finding out whether the data of my internal storage are lost?
And
if I have to do my TWRP restore including internal storage in a different way to succeed?

If you hit your favourite search engine with the error message (better without the space between extract and Tar), the message comes up across devices and with official TWRP, too.

There seems to be no single cause, the error message seems generic (sort of “Oops! Something went wrong!”).

There’s any number of hints you could try, but it looks like you want to get your phone up and running quickly, so perhaps …

… would be the way to go.

By the way: TWRP can do screenshots, same button combo as in Android :wink: . The save location TWRP chose for them is given in the terminal output.

1 Like

Thanks @AnotherElk for your good answer into my despair.

Which could be the 3 best ones?

If your TWRP backup file is really corrupt you might not be able to restore it using TWRP. But if your internal storage was not encrypted you might find and extract your personal data manually from the TWRP backup.
More information you might find e.g. here: https://android.stackexchange.com/questions/171202/extracting-data-from-a-twrp-backup
(my favorite solution mentioned there is Just extract it with winrar to a folder on desktop and that’s it.)

Ok, thank you for clarifying and for the screenshot-hint!

Ok, I did it. It was anyway neccessary because amaze crashed regularly and others too. Thanks for your encouragement!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.