TWRP for Fairphone 3

TWRP for the Fairphone 3 is official, instructions are here … Fairphone 3.

Be aware that TWRP doesn’t backup the Internal Storage, you would have to make a backup of it via other means (e.g. via USB when TWRP is booted) … What is EXCLUDED from a TWRP backup?.

Just boot TWRP with fastboot like you did already …

A/B devices like the Fairphone 3 have no recovery partition, so installing TWRP will alter the boot partition instead, to different effects with different OSes.
Fairphone OS for instance will not OTA update anymore after that.
/e/ for another example will just overwrite the boot partition with its own one (including its own recovery) with the respective next update.

If you choose to keep your bootloader unlocked to be able to fastboot boot TWRP when desired, this has security implications … How to lock the bootloader when the process is over? - #3 by AnotherElk.

Otherwise the process is pretty simple:

  • Make sure to keep the install file(s) for the installed OS version (for a restore in case the OS partitions can’t be restored successfully with TWRP, better safe than sorry).
  • Make a copy of the whole Internal Storage (because).
  • Make a TWRP backup of your partitions, most importantly the data partition.

Thanks to take time to answer me.

Yes I do, sorry it wasn’t a link.

It’s the first part of my message, I tried different things the whole weekend but nothing worked : TWRP don’t work on my phone yet, so I explained my problem first (with the error message in TWRP) and then ask you how is it working for you.

First thanks for your long answer, I did it one time but after I get a message telling me that my phone is corrupt and will not boot (message with the red warning sign ~ the same as the yellow one wich tell you that bootloader is unlocked, but it wasn’t written that it will shutdown after 30 sec and I tried to press the power button but nothing occured) and yeah it never booted, I got stuck with that message, it was not possible to boot on system or on recovery, so I flashed all my phone with /e/OS files to get it working.

Yes I have read that I should not do fastboot FLASH recovery twrp.img but as it is explained on TWRP website as official way to do, I didn’t know that Install Recovery Ramdisk option was the same … (yes I’m a noob)

So just for me to understand, you, when you backup your phone, you just :

  • (your bootloader is already unlocked) you keep it unlocked ?
  • Make sure to keep the install file(s) for the installed OS version
  • Make a copy of the whole Internal Storage
  • Restart on bootloader mode
  • Type fastboot boot twrp.img then press enter
  • Select keep read only on the first screen ?
  • Then backup
  • Reboot system without doing anything else ?

I’ll have to look into that.
Alternatively there is also an installer-ZIP available for an alternative method of installation.
That said, as @AnotherElk already explained, it is generally not advised to install TWRP on A/B devices such as the FP3, as it modifies the boot image.

I also have an error when I try to use the fix but I noticed that I don’t need that fix. I have no bootloop without it. I use TWRP with /e/ and Magisk. With Magisk the bootloader must remain unlocked but Magisk has a module that keeps TWRP installed after an OTA update on the A/B device.

1 Like

ANY modification to the system, such as installing TWRP or Magisk, or modifying files on other partitions will require the bootloader to remain unlocked.

@bege sorry for not replying to your other post earlier, I have very little time ATM.
The charging thing sounds like it might be a general TWRP issue and not device-specific.
The SD_ext is for use with adopted storage IIRC.

1 Like

Having assessed the security implications for my personal situation.


TWRP supports MTP, so I already copy the TWRP backup to my computer via USB at that point.
Otherwise … yes.

If you need more information about my TWRP fail/error/bug? I can send you a picture or a video next time I will try it.
Thanks for all the job done and thanks again for all the work you will do !

I just want to backup my phone, without fear of losing everything because of a bug or a mistake (like I already do ~ no, not everything, I saved my internal storage and do adb backup all previously)

@bege I don’t know Magisk, I just used only TWRP on my two previous smartphones (ASUS PF2 and PF2), it worked well, it’s why I wanted to do so on my FP3, I tried my all weekend but it didn’t work.

@AnotherElk ok, I will retry this (I only did it once, the others time I pressed the "Fix Recovery Bootloop”) but not tomorow, I will not have enough time if it fail, but I will keep you informed. Thanks anyway !

Did you still have the message with the yellow warning sign witch tell you that bootloader is unlocked ? Or the adb reboot "dm-verity enforcing" command disable it ?

If I recall correctly, this command disables a red message where you have to press the power button to continue booting, else the phone would reboot after 30 seconds.
With an unlocked bootloader I guess you’ll have to live with the yellow message where booting continues automatically after 5 seconds.

Ok, that was my question, thanks !

I tried it last weekend and … It worked … I don’t really know why but I have been able, with your help, to backup my phone. It was the first time that TWRP asked for my unlocking code so maybe it helped to work, I don’t know what I did wrong the first time.

I also try something interesting but it worked only one time on twice (so TRY IT AT YOUR OWN RISKS) : when I unlocked my bootloader (fastboot cmd → press vol dwn → press power) right after my phone restarted, I removed the battery, left the phone for a few seconds without it and restarted (with battery plugged) and then my bootloader was unlocked and I didn’t lost any data.
I retried this process to lock it again but it didn’t worked, it bricked my phone … (maybe you need the right timing to unplug the battery … or not)

So thanks anyway, now I have all I need for my new FP3 !


I just want to leave a heartfelt “Thank you” to @_tmp for still maintaining the archive of images Index of /stock/ . It makes updating as root so much easier.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

A user in the /e/OS forum encountered this old TWRP issue … MTP not prividing change timestamps · Issue #1065 · TeamWin/Team-Win-Recovery-Project · GitHub

I can confirm the issue on my Fairphone 3 with the current TWRP 3.6.2_9-0-FP3. It’s not ideal for backup purposes.

@k4y0z: As TWRP’s terminal can see the timestamps just fine … can something be done about this? Or could this be a fault on the computer side?

Hi guys,

I need your help. My FP3 stuck in fastboot mode. There is no way to start recovery mode. Device State is unlocked, has no OS and is in fastboot mode. Following steps I’d executed:

  • Connect Phone to USB
  • Tested reachability with fastboot devices and got back serial no.
  • Reboot with fastboot reboot
  • Check current-slot, result:
    Bildschirmfoto 2022-10-01 um 20.53.21
  • set active slot a, result:
    Bildschirmfoto 2022-10-01 um 20.54.40
  • Flashing boot with twrp, result:
    Bildschirmfoto 2022-10-01 um 20.57.14
  • restarting with fastboot reboot recovery
    But the Phone started into fastboot mode

I tried a lot. Erase both slots before, used different twrp versions and Lineage recovery, restart my mac, restart the phone without usb connection. But nothing wont help, phone starts only in fastboot mode.
If I tried to boot recovery from remote, I got this:
Bildschirmfoto 2022-10-01 um 21.16.26

What can I do now?

TWRP instructions:

“WARNING: If you accidently flash TWRP to your device using fastboot instead of temporarily booting the image, you will need to download the latest factory image for your device and reflash the boot image.”

Latest available factory image is given here:



yes, that works. Thx!


Seems like latest TWRP 3.7.0_9 is not able to handle latest OS update 0021.0. I followed my usual procedure to flash TWRP and Magisk. Unfortunately, after booting into TWRP, I only see cryptic filenames in the selection, so I can’t flash… Maybe it’s not a TWRP problem, but does anyone have the same problem and know a solution?

I got that effect when I went from /e/OS based on Android 11 to /e/OS based on Android 12. It looks like something changed with the encryption and TWRP can’t handle it yet.

I don’t know whether that’s something that would be done with a “normal” update within the same Android version. Perhaps it’s not the same issue even if it looks the same.

Anyway … TWRP can use a micro SD card set to be used as external/portable storage (always!) or you could try whether TWRP can use a USB Stick via a USB OTG adapter.

1 Like

Thank you very much, @AnotherElk! At least, that took me one step further. I have copied the necessary TWRP and Magisk files onto an SD card and I can see and choose them within TWRP. But when trying to flash them, TWRP 3.7.0_9 reports multiple Failed to mount '/system_root' errors. Apparently there were more serious changes with this OS update from 0019.2 to 0021.0.

Edit: OMG, this led to an bootloop into recovery again and again… I am not able to start the phone anymore… Any help appreciated!

Edit 2: I managed to revive the phone again by redoing the OS update to 0021.0. :sweat_smile: