TWRP for Fairphone 3

The description here says that TWRP must not be installed but temporarily booted in order to keep OTA updates working. The TWRP website describes how to install TWRP permanently. Does permanent installation still make OTA updates impossible or has that changed with

Do I understand it correct that if TWRP shall be installed permanently it must be installed into both slots? If so, how do I make sure to install into the correct slot?

Welcome to the community forum.

TWRP installation breaking Fairphone OS OTA updates can’t be fixed with a new TWRP version, it’s not TWRP’s fault.
Installing TWRP on the Fairphone 3 alters the boot partition (because A/B device). The Fairphone OS OTA updater checks for altered partitions and doesn’t update when it finds one.

Other OSes may handle that differently. /e/, for instance, just restores its own boot image with every update, so OTA updates work, but will delete TWRP.


Thank you for the welcome and for the answer.

I come from a Samsung Galaxy S5 Plus (SM-G901F), LineageOS for microG 16 and just bought a used Fairphone 3 with Android 10 and want to install /e/.

I am used to regularly backup system and data partition what saved me a lot of shock and time. Does that mean that I need for every backup and every restore a computer and boot TWRP with fastboot?
If so, is there any other way to do partition backup and recovery more easily?

For using TWRP, yes.

If you’re bound to backing up and restoring without a computer connection, /e/ is working on including Seedvault, but that’s a different sort of backup …


That TWRP backups become such an uncomfortable thing with FP3 is a pity. Sometimes all attempts to restore system an app settings don’t help to get a corrupt installation running again, only restoring complete partitions solved the problem. Well, that’s how it is.
Seedvault seems to be a promising approach for data backups, but as you say it is a different kind of backup, no partition backup.

If I regularly want to backup partitions with TWRP and boot TWRP with fastboot I need an unlocked bootloader. So it doesn’t make sense to always unlock and lock the bootloader - and loose all data every time.
If the bootloader remains unlocked, is there a way to get rid of the warning screen every time I boot the phone?
Could this be accomplished by /e/?
As /e/ OTA updates overwrite the TWRP recovery, couldn’t /e/ provide a ROM with TWRP instead of the normal recovery for users who need it?


@k4y0z Thank you for this recovery!

Unfortunately it does not get the current date and time from the phone. If I backup a partition the date in the name of the folder always is 1970-01-01. On my old Samsung Galaxy S3 (GT-I9300) and Samsung Galaxy S5 Plus (SM-G901F) TWRP takes the current time and date.

(The same issue is with /e/OS if there is no SIM card inserted:

With Fairphone OS time and date is correct also without SIM card.)

Can you make TWRP to get the correct time and date from the phone?

The time is working correctly for me.
You can try deleting the offset-files /data/vendor/time/ats_* and reboot the ROM so it can set them up correctly.
If your ROM doesn’t set them up properly, TWRP won’t be able to display the correct time and date.

Did you test without SIM card?

To test I did this:

  • factory reset
  • format data
  • install standard Fairphone OS
  • no SIM card
  • set time and date (manually, time and time zone from network disabled)
  • boot TWRP (date is 1970-01-01)
  • install TWRP (date is 1970-01-01)
  • reboot system (date is today)
  • reboot to TWRP, delete /data/vendor/time/ats_*
  • reboot to system, set time and date as above
  • reboot to TWRP (date is 1970-01-01)
  • reboot system (date is today)

Yes, no SIM card inserted.
Please try mounting /persist and also deleting /persist/time/ats_* (as well as /data/vendor/time/ats_*)
Then boot the OS and set up the time.

1 Like

Why must I do this after a fresh installation of the standard Fairphone OS?
Will this be the solution also for LineageOS and /e/OS? TWRP had the same issue with those systems.

I’m not sure exactly why the OS aren’t properly creating/updating the files in persist.
When data is encrypted, the files in /data cannot be accessed when TWRP is setting the time, since that happens before decryption takes place.
I don’t think there is much that can be done from the TWRP-side (as you said yourself it works fine on other devices)

1 Like

I just want to offer what I do as a workaround … I change the date in the name of the backup folder created by TWRP to the correct date as soon as the backup is finished.
(And then I just want to duck and sneak away before things get thrown at me :slight_smile: .)

1 Like

Sure, but I find it uncomfortable, and any file that has been created by installing a zip-file (e.g. NanoDroid) had the wrong creation date. But the suggested fix from @k4y0z solved the problem if Fairphone OS is installed. I didn’t have the time yet to install /e/OS to see whether the fix works for TWRP then - and maybe fix the same/similar issue of /e/OS mentioned here TWRP for Fairphone 3

Does anyone have partition images for A00066?

This issue has been fixed for /e/OS so far that after deleting the mentioned files date and time is correct now in TWRP.

@k4y0z I noticed that the displayed battery load does not increase when the charger is connected. The + behind the percentage shows up but the number remains constant. Only after rebooting into system the current load can be seen.

What is SD_ext in backup tab? It always is 0MB here.

Hello, I tried to follow instructions on to install it on my FP3 but it don’t work, when I use the “Fix Recovery Bootloop” option I get this error :
cd /tmp/repackorig/ && /sbin/magiskboot expatch kernel [a long hexadecimal number here] process ended with Error 1. Error patching kernel.

I just did fastboot boot twrp.img → ok → then Install Recovery Ramdisk → ok then Fix Recovery Bootloop → failed
And I tried many times, with FP OS, with /e/OS … without Fix Recovery Bootloop … nothing worked

Can you help me ?

I would like to be able to make a full backup of my phone, I have read a lot of threads and I’m not sure it is possible (some says, it’s ok, backup works fine with TWRP, some other says TWRP is incompatible with FP3) so how does it really work ?

Your link does not show any instructions so I wonder if you read Fairphone 3

I haven’t done any backups/changes for years but there are also instructions for back via ClockworkMod and I used Titanium Backup - I don’t know if they are still viable options >??

CWM is an old recovery not much used anymore, and isn’t compatible with the FP3.
Titanium backup backs up apps and their data and not whole partitions like TWRP.

@qsdfghjkl TWRP backups should work, there is no reason for which they wouldn’t on the FP3 AFAIK.

1 Like