FP3 Software update: 8901-4.A.0021.0

It seems to have resolved itself without adding a new APN this time :+1:


Anyone using Termux (or identical apps) for letting scripts run on the phone? Seems to be broken after the update.

By the way, with this new update the selfie camera of my FP3 (standard camera module) works again in applications like Nikita’s GCam mod :smile:

1 Like

Can you describe the problems in more detail?
I am using termux (and tasker) for quite a bunch of things, and cannot confirm any problems with that update.

1 Like

I am using Tasker without root and this work-around to start adb-wifi on (re)boot of my device:

It worked marvelous before the update, but not thereafter. I thought there might be an issue with termux, but I tested somewhat and find, there is an issue with adb-debugging over wifi. The phone simply does not pair with the wifi. If you have any suggestions, I’d be thankful for sharing.

I just have seen, you’re from Germany like me, we could switch to German, if you like.

This is specifically a Tasker issue is it, not a general can’t connect ADB via Wi-Fi ?


1 Like

I tend to agree this more belongs in the Tasker/Termux section.

But to try helping a bit:

I am using about the same. Fun fact: I came across that one only after (!) the february update, and then mangled it into my T&T environment.

And it does work nicely - or at least seems so, telling from the few reboots since The enabling part is now embedded inside other stuff here, and thus modified for the purpose. But the pairing part I use is still as originally given.

For the versions I am using: Basically it’s all “current stock” Termux & Tasker here (i.e. NOT currently running any betas), only augmented with the latest Tasker Settings (v1.5.0.)

1 Like

I solved it. The termux-packages got out-dated around the same point in time the update came. After changing the termux-repository and after updating the packages in termux, I re-installed the package “android-tools”, and that’s that.

Thanks for help.


Nope. Not a specific tasker issue. I could not connect to ADB via WiFi, because of an issue with termux.

1 Like

I always manually update my FP3 using fastboot without any problems, but the time between an update being available through my provider (doesn’t work on rooted) and the download links being posted anywhere on the Fairphone website is getting longer and longer… any chance that this could be accelerated a bit? :wink: It’s not a huge bother but the notification is kind of annoying…

Hi and welcome to the forum

As this is primarily a user forum, you may like to ask support@fairphone.com directly for a more detailed and quicker response.


Sorry about that, we were hunting down a potential bug in the latest package and it took longer than expected. The file is up now, we’ll do our best to publish it much sooner next time.


Thanks a lot and thank you especially for even explaining the delay! Awesome support!

@wjg57 & @fabian.schicker, regarding TWRP:

Have you found a solution in the meantime? I can boot into TWRP, but I only get cryptic file names when I select files, so I can’t get any further. My whole setup relies on root availability. If there is no solution, which would be a great pity, I am considering using Lineage OS, but of course I am reluctant to move.

I did not find a solution up till now (but I haven’t searched too hard, either).
The latest version of TWRP for the FP3 was released in 2020 (for Android 9); newer versions by the same maintainers are only available for other HW (I remember raising a n issue for TWRP, but no reaction up to now and I can’t even find the issue anymore ;-/).
Not having root means not being able to backup all the data on the phone, so the barrier for a move to another flavor of Android is rather high (no way back, no way to get at current data).

I don’t think this is correct. The latest version is from August 8th, 2022:


Please see

Yes, that’s true. :frowning:

Hello together,
Unfortunately, I have also installed the update and am facing the same problem.
I’m not sure if it’s really because of TWRP or if Magisk can’t cope with the new layout… I created a new (rooted) boot.img with Magisk, copied it to my PC and then generated the MD5 and SHA256 hashes and put the file directly to “\FP3-8901.4.A.0021.0-gms-0b368514-user-fastbootimage\images\boot.img”. Together with the new hashes, I could then directly execute the update script from the zip file again. However, after the script ran without errors, the phone hangs in a boot loop…
As soon as I replace the boot.img created by Magisk with the original one and re-run the script, the phone starts normally. (But of course still without root)

Hi & @wjg57

As this topic is about the standard update and use, of the 0021.0, created by a Fairphone employee, you may be better off starting a new topic relating to the TWRP implementation as this, I imagine, is none of their concern.


Yes, I agree.

@wjg57 & @fabian.schicker & @Kirby, please follow up here:


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.