English

"Try again in X seconds" when turning on FP

Tags: #<Tag:0x00007f05de1b4320>

When I turn my FP on and enter my pin number, and when I draw the secret drawing connecting the dots, why does the FP not respond ans ask to try again in X seconds?
It is really annoying. Sometimes I have to wait for 25 seconds so the screen turns off again, so I even have to press the upper button again to turn on the screen before entering the pin number or the secret drawing.

Maybe you have set a maximum number of wrong patterns and a wait time after that number was reached?

I changed the category from Software to Help. It is about a specific problem and not Fairphone software in general.

To me it also sounds like you are trying to enter the wrong pattern.

I have the same issue (since 1.8). When the phone boots and asks for a pin, the screen is already locked. It seems like the pin input taps get interpreted by the lockscreen as well, causing the lockscreen to see too many invalid pattern attempts. As a result, the screen locks for a certain amount of time before you can try again.
It is certainly enoying, but since I don’t have to reboot my phone often, I can live with it :slight_smile:

Maybe you should both do the Touchscreen Test if the screen registers faild trials without you touching the screen.

1 Like

I have the same thing. I’m pretty sure it’s a lockscreen software issue. Doesn’t come across as hardware/touchscreen related.

2 Likes

So it is still an issue in the beta version of 1.8.x?

The phone doesn’t act as if there was a wrong pattern drawn (red dots) or wrong pin. It only says to wait. I have the 1.8 version (I think).

I will try to reproduce this (I am too on 1.8).

What is your setup? You have a SIM lock plus a lock pattern for your phone?

1 Like

I have done the touchscreen test, nothing seems to be wrong with the screen.
I have a sim lock for when I turn on the phone, and a lock pattern for when I wake the phone up when it’s turned on but not in use.

1 Like

Yes, SIM lock plus lock pattern. I am on the withdrawn 1.8 btw (which otherwise works fairly well), not part of the beta program.

I’m with Jerry on the software issue. I am touching the screen, after all I’m trying to input my pin…

2 Likes

I don’t know the difference between withdrawn and beta 1.8. I updated to 1.8 in december (with difficulties).
I am not necessarily touching the screen when it tells me to wait. It doesn’t even take what I’m touching (be it pin numbers or pattern) until the countdown is over.

Here is what I did: I set a lock pattern additionally to my SIM lock PIN. Steps I followed:

  1. I rebooted.
  2. I have to insert my SIM PIN.
  3. I have to draw the lock pattern.

Conclusion: I cannot reproduce the issue.

Question to all of you: Are you using Google Apps? I am not…

PS.: @Scarlett After the troubles with 1.8 (Update postponed), Fairphone started a beta test group, where @Jerry participated, I believe (versions 1.8.1-1.8.4). The next official release will be 1.8.5.

Yes, I installed Google apps as offered when using the phone for the first time, then deleted it when the phone was set up. I regularly use Gmail and Google search.
I am very likely not in the beta test group.

@Scarlett, @srosiers, @Jerry did this start happening today for all of you?

Yes, using Google Apps. Also using Xposed / Xprivacy, but the issue was there before I installed those.

No, it started months ago. Can’t remember if it was always the case or only after upgrading to 1.8 though.
I also have to say the countdown can vary from 3 seconds to 25 seconds. Sometimes (rarely) the issue doesn’t occur.

Ok so then my guess is it’s a Google thing. Maybe Google installed some “software update” without letting you know (I don’t know but I assume they do that) and it caused this behavior.

Well, maybe not necessarily a Google thing…

My guess is, that some service starts at boot and lets the touches from entering the SIM PIN go through to the lock pattern. Though please note: Only wrong patterns longer than 3 dots get counted. It seems hard to imagine that you enter a wrong pattern for 5 times, when attempting to insert the SIM PIN.

Anyways, to disable the auto-run at boot for apps, you could use one of these:

Disclaimer: I have not tried any of them, so I have no experience with them!
Edit: I am using Autostarts from F-Droid and everything works fine.

or Autostarts (F-Droid)

I use this one to disable some Apps from running at start up and it works great.

1 Like