Text messages not sent 'phone number formatted incorrectly' - issue with UK providers

Have had my FP2 for almost 2 years, but suddenly can’t send text messages as it says ‘phone number formatted incorrectly’ every time. I’ve not changed SIM, carrier, messaging app or anything else, so I can’t understand why it’s suddenly stopped working?! I can receive texts fine, just can’t reply.

I can’t find it right now but I believe someone once wrote they had this happening because of spaces in the phone numbers.

I’ve checked that and there are no spaces. But also, this applies to all
messages to all numbers and started overnight, when no problems before.

Did you change anything else besides SIM, carrier or messaging app? Like did you install any other app?
You could try clearing the cache of the contacts and messaging apps in Settings > Apps and you could try #dic:safemode to see if it works there.

Found two things … related or not …

https://forum.fairphone.com/t/sending-sms-with-contact-from-contacts-does-not-work-german-localization/89?u=anotherelk&source_topic_id=36219
1 Like

I’m stumped. Nothing else has changed (no new apps) and I’ve tried the suggestions above. The contacts don’t have spaces in the numbers, and if I type it in manually it just recognises it as a contact and defaults to that. Dialling the 4636 number results in the following message ‘Connection problem or invalid MMI code’.

The forum software misquotes this, you would have to go to the linked post to see it correctly: You actually have to dial *#*#4636#*#* for the test menu.
But I don’t know whether that helps with the number format, you tried the relevant manual part already.

I’m having exactly the same problem. It started a few days ago. Sometimes the message does go eventually, but other times it just doesn’t go. Sometimes I’m replying to a text, sometimes starting from scratch, but it isn’t consistent. I wish I knew what to do. the suggestions above are a bit complicated for me.

I have had the same problem today. Doesn’t seem to work with any of my contacts so not just a case of one number being wrong. I tried the *#*#4636#*#* trick but it seems to hang up immediately rather than going to test menu. I’m not being much help here but sounds like it’s affected lots of people recently…

Still an issue for me too - inconsistent, sometimes they go, sometimes they don’t. It’s driving me mad! I can’t understand the results of the 4636 menu, it’s too technical for me. I can’t understand why the format of the numbers would suddenly need to be different.

Ok, i’ve managed to get to the test menu as AnotherElk described…it seemed to try and ring it before but should just appear as soon as you type the last *. In ‘Phone Info’, right at the bottom the ‘SMSC’ part is blank. If i press update then ‘update error’ appears in the text box. If i delete ‘update error’ and press refresh it brings up “+44[my number]”,145. If I try and send messages they just sit on ‘sending’ forever but I don’t get the formatted incorrectly error anymore…not sure if this is progress?
Thanks to whoever edited my last post to include the asterisks by the way :slight_smile:

Ok, your own number most certainly is not the SMSC. The “,145” part is not unusual, even if I don’t know what that does, I have that, too.

The SMSC is the “SMS Center” of your provider, and you can ask your provider to tell it to you. With well known providers you could maybe even google it.

If you can still receive SMS you could alternatively ask your provider to resend the initial config SMS. Perhaps that would do some fixing to the settings, too.

1 Like

Same problem here.

My FP2’s microphone and charge point stopped working, so have just received a new module, inserted it, all good. Started to receive texts and tried to reply to one and got the same error folks are getting here.

What to do? I’m confused by the tech speak above…

is there any way that we can ask the company what;s going on? There are lots of people working there, is there a number or email address that we can call and ask? All I can find is the troubleshooting, but that’s no help to an ignoramus like me. I just want to ask someone. Lots of other organisations have an online messaging service available to members. Why not Fairphone?

I don’t understand most of what’s been offered so far.

https://support.fairphone.com/hc/en-us

“Or call us: Monday to Friday 9:30 - 17:30 at +31 (0)20-788 4400.”

1 Like

Thanks; I’ll have to try those.

If anyone is with the Phone Co-op I rang them this morning and it sounds like the problem is with their network. Not resolved yet but they are working on it - if you ring them and give your number they’ll keep you updated when it’s fixed. I assume this will apply to most UK people with a fairphone.

3 Likes

Hmm, strange as I have two SIMs in my phone (PlusNet and Talk Mobile) and the problem occurs with both of them, so I assumed it wasn’t a network problem. And it’s intermittent which is also odd.

I did a little “creeping” and checked the IP addresses of everybody who posted here (as a Moderator I can do that) and indeed you are all from the UK, so even if it’s not just a Co-Op issue it seems to be a UK issue.

1 Like

So hopefully it can be resolved by the provider, but if not, we are getting nowhere it seems.

I found this discussion from 3 years ago …

I take away 3 things from this …

  1. Android parses phone numbers in a certain way and blocks numbers that don’t fit to a certain set of rules.

  2. Make sure there’s no “(0)” in your numbers as “+44 (0)…” for UK numbers (or “+49 (0)…” for German numbers, I’m reluctant to think of this as a UK only thing) might not work.

  3. As there is an Android component at play here, this can of course be updated and changed, so an update could have changed or still could change the behaviour of the number parsing.
    If the problem is not caused by your provider, please tell us what exactly it says in Settings - About phone - Build number, so we can see which OS you are using, how up-to-date it is and conclude from that what stock message App is running.

The really strange parts that don’t add up at all (if the problem is not caused by the provider) are …

… with me counting Android updates as anything else …


A Google search suggests we are not talking about a Fairphone problem here, people get this error on every flavour of Android phone across the board.

Sony in such a case suggests checking whether messaging works in safe mode.
Here’s how to boot in safe mode, but use this with caution because you might lose some stuff along the way

2 Likes