Testing F-Droid privileged (before including it in FP Open)

You can flash F-Droid directly to Fairphone Open (or any ROM) using this official, gpg-signed OTA ZIP file:

We’d love to have people try that out and report how its working for them. That’ll make it easier to get F-Droid built into Fairphone Open, since we can work out any kinks before the gerrit merge request gets merged. This OTA ZIP is working well for us where we have tested it.


@eighthave I moved your post from here as I think it deserves it’s own topic.

I’m flashing it right now. Any specific things we should test?

PS, what I tested so far:

  • Flashing went fine :slight_smile:
  • Disabling “unknown sources” no longer affects F-Droid! :thumbsup:
  • Trying to uninstall (some) system apps - like phone - (still) crashes F-Droid.
1 Like

I haven’t tried out flashing the ota zip but I did for my own build of FP Open the exact same change as @cdesai and it works without any problems (at least since half a year). What could be done in addition is to include the automatic download of the source. This is done by adding

<­remote name=“fdroid” fetch=“https://gitlab.com/fdroid/”/>
<­project path=“packages/apps/FDroidPrivilegedExtension” name=“privileged-extension.git” remote=“fdroid” revision=“refs/tags/0.2.5”/>

to .repo/manifests/default.xml . This is also proposed in the project’s README, with the exception that I take the newest version (not 0.2 but 0.2.5).

thanks :slight_smile: One thing to test is the automatic updating. That means
enabling it in the F-Droid preferences. Then just check to make sure
that updates are happening automatically, and you’re being properly
notified that they happened.

1 Like

Yes, that works too.
Took me a while as I first had to downgrade an app and for some reason that was only possible after clearing F-Droids cache, but then it worked as expected. The second I ticked “automatically install updates” it started downloading, then installing and then I got the notification “App Successfully installed”.

PS: Someone should probably test this on #software:android-6 as that’s closer to future FP Open releases than the current FP Open.

I flashed the extension some weeks ago because moving the apk with /system/app mover didn’t work for me. Since then I didn’t have any troubles. Nice work.

1 Like

I just downloaded the .ota file, and was now trying to flash it, but I can’t locate it in TWRP.

It feels like I am blind, but could someone tell me the path to the download?

Probably Internal Storage -> Downloads

Nope… No Downloads folder there…
I am on LineageOS btw… Sorry, forgot to say

Me too. Are you sure you are looking at the Internal Storage and not at the SD Card? There should be a button in the bottom left corner of the file picker to change what you are browsing.

Yeah, I guess we need to document this better still. the OTA is downloaded to /data/data/org.fdroid.fdroid, the data folder for F-Droid itself.

Just a short feedback regarding this:
Running F-Droid with privileged extension since some weeks now and it works fine.

FP Open 17.09.3, XPosed + XPrivacy, AFWall+, device currently not encrypted but I want to encrypt it again in the next days/weeks.

Updates will be installed fully automatically. I get a notification when a new version of an app was installed, together with an additional XPrivacy notification, that a app has changed.

Regarding documentation:
I can say that it was hard for me to find the OTA Zip to download it. Maybe I’m just blind.
When you take a look at the F-Droid page and search for privileged extension you will get to this page:

Another page is this one:

But on these pages I always just find the download button, which will download an APK but not the .zip to flash the priv.-extension via recovery (TWRP). Finally someone in a XMPP MUC told me a direct download link to the OTA Zip file.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.