Swiss Map Mobile (and other Swiss apps) on FP Open

Hello! Does anyone use the swisstopo app Swiss Map Mobile on FP Open? I have installed xposed and microG but the app still can’t locate me (while others can). More details in the post below. Any help or sharing of experience would be very much appreciated!

I have installed xposed and microG (with the Mozilla and Openbmap backends) on my Fairphone Open OS. I’m having trouble with one app that uses GPS, while others work fine.
OsMAnd localises me well - it did before I installed xposed and microG, too, but it was slower and less precise then. Just now, I used Here GPS Location, which didn’t work at first, but after installing and using SatStat it works fine.
The other (most important app) is Swiss Map Mobile, from the Swiss federal administration. It cannot locate me at all though it is supposed to use GPS.

I haven’t understood what backends do. I installed two (Mozilla and Openbmap) and “configured” them in microG, but haven’t done anything else. Could that be the problem? Also, Openbmap keeps on suggesting that I download an offline catalogue - what is that for? Should I install more backends?

I haven’t configured any address lookup backends either - there again, I don’t understand what they do.

And I’ve been reading Unified NLP on Fairphone 2 Open OS and wondering whether not understanding what patches are - and of course not having installed any - is part of the problem.

Any advice? Thanks a lot!

I don’t use Swiss Map Mobile, but I have a problem similar to yours with the CFF/SBB app. My GPS works fine (I also think that Satstat helps) with OsmAnd and on Google maps on my browser, but I cannot use localisation on the CFF/SBB app. I am wondering if they use another way to provide localisation that isn’t compatible with FP2 open OS’s GPS.

Salut Chrisse!
I use the CFF app too but I’d never used its localisation service. When I tried to use it tonight - probably for the first time since I installed microG - it crashed. I uninstalled and reinstalled it; just now localisation worked smoothly. Have you tried reinstalling it?
Bon week-end!

Btw: Do you use MeteoSuisse? I also reinstalled it tonight; without microG it always crashed on startup. Now it seems to work but MicroG Services Framework stopped when I launched it (I got a message saying “Unfortunately, microG Services Framework Proxy has stopped”). Isn’t that weird?

Backends are used in order to get a good GPS position more quickly.
Background: Due to technical reasons, a “cold start” for GPS may take quite a long time, if your GPS receiver has no idea where you are. Therefore, your phone will first try to figure out a “coarse” location. It takes hints by looking e.g. what wifi networks are in range and which cellular IDs your phone’s modem currently receives. Mozilla and openbmap both are databases that map wifi networks and Cell IDs to actual locations, so by using those databases your phone can estimate a coarse position, feed that coarse position to your GPS receiver, which will gladly take that information and calculate a precise position much more quickly

These backends can either be used offline or online. Online usage means, you try to contact the backend servers directly when you need the information, i.e. when you’re on the road. That, obviously, needs a mobile data connecion.
Offline usage means you can download the database to your phone when you’re at home, so you don’t need an internet on the road for doing the actual lookups.

If you’re using an OS with google apps, google does all these things for you. If you don’t, but instead use microG, you can select a backend of your own choice.

1 Like

I did try to uninstall and reinstall, but now that I know that it works on your phone, I decided to give it another go. I actually use CFF Mobile Preview (the new app), so I decided to download the other app (Mobile CFF), thinking that it may be the one you use. Funny thing: the localisation on Mobile CFF works just fine, but the one on Mobile CFF preview still doesn’t work. [quote=“Linda_CH, post:144, topic:17348, full:true”]
Btw: Do you use MeteoSuisse? I also reinstalled it tonight; without microG it always crashed on startup. Now it seems to work but MicroG Services Framework stopped when I launched it (I got a message saying “Unfortunately, microG Services Framework Proxy has stopped”). Isn’t that weird?
I do not use MeteoSuisse. I have downloaded it to give it a try, but I can’t even open the app (“MeteoSuisse stopped…”).

Thanks for your explanations!
I’ve tried to download offline databases for openbmap but it doesn’t seem to work: a bubble pops up to say it’s downloading them but when I go back to the offline databases list, there still is none, and I can’t find the files (neither in Downloads nor in Openbmap files). Is there a trick to make that work?

That’s right - I’ve never tried using the new app. Glad the old one works for you now, too!

That’s what happened on my phone before I installed xposed and microG. Since I installed them, and reinstalled the app, the app works but makes microG framework crash. Which bothers me too, of course…

Seems like openbmap changed their name and servers (or something like that, see Their new name is “”. There’s also a app by that name in f-droid, haven’t yet tried it though.

What I use is “µg UnifiedNlp (no GAPPS)” from f-droid. I configured it to use the Mozilla database. Seems to work for me :slight_smile:

An update on Swiss proprietary apps:

The current version of Swiss Map Mobile does not seem to work on Fairphone Open OS. I asked for support from Swisstopo but they will not offer any for a “non-official” version - i.e. an apk which didn’t come from Google Play. I had already paid to buy a licence to access the maps offline; all they offered was a reimbursement. I will spend some time looking for alternative map viewers (the online version recommended by Swisstopo is of little use when you are in the mountains and don’t have any cell coverage).

The current version of MeteoSwiss works fine.

The new SBB app worked at some point, but I never liked it. I have been using transportr (see How to get (almost) all trains and buses in Europe with Transportr (FOSS public transport app)) for a few days and think it is a good solution.

The Rega app doesn’t seem to work without Google services, which is a problem. Does anyone use similar apps (meant to call rescue services in case of an emergency, e.g. in the mountains, even when you do not have enough coverage to place a call)?

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.