GPS doesn´t work on FP Open OS

Good point. SatStat “claim” it’s just a diagnostic tool (besides the ability ro refresh A-GPS), but I too make the observation that opening SatStat gets you a fix faster. It may be just the Placebo effect of the time flying by while watching as SatStat finds more and more Satelites, but I don’t think so.

Thank you both for the tip! I guess that I just have to be more patient… I don’t use the GPS that often, so it’s hard to determine how and when it works or not. The only thing that doesn’t work at all is the localisation for the app I use for local transports ( ; I use version 0.2.16). Could it be because they use another type of localisation? I can still use other functions of the app, so it’s not that big a deal, but it would make life easier if it worked!

There are still lots of odd behaviour that I observe even in SatStat: I sometimes get a fix almost instantly, but the error is 20Km or more although a whole bunch of satellites have turned blue - what means it uses them for the fix. Time to fix is zero, but it does not display any bearing or speed. Then all of a sudden the error drops to an acceptable distance of a few meters and I get readings for bearing and speed. Once this has happened both SatStat and OsmAnd will quicky provide an accurate fix - even when turned off and on again. It looks to me as if the system has problems with getting a fix when you have moved to a new location with GPS not in use while moving. The behaviour almost looks like the GPS is still “sitting” on the old position data. When it then suddenly gets new data from the new position it discards them as invalid because the position error is too high. Then it stays in this unfortunate state until it gets “convinced” that the new position is actually valid. Outdated AGPS data should not be the cause, because I am observing this effect even when I try to get a fix after I have just driven a few miles without GPS in use.
Very strange :worried:

I get that too, but it only lasts a few seconds, so I wouldn’t think much of it.

Same here. Also satellites already turn blue - usually after 0 seconds - before there are 4 of them, as though 1 satellite was enough for a fix. On the FP1 they only 4 or more could turn blue at once, which made sense.

I’m not sure I ever experienced this, but what I sometimes experience is that the GPS fix is lost for no apparent reason, but some apps still show GPS as fixed, but don’t update the position. It sometimes takes up to about half a minute to get the fix back. Again it seems like switching to SatStat gets the fix back faster. I then switch to SatStat and turn in to landscape mode and back to get a clear screen - before it still shows the satellites from the last fix.

But all in all I’m very happy with GPS performance. Rare occasions where I have to wait up to 30 seconds to get a fix (back) are not so bad. :slight_smile:

I just checked this morning with SatStat and my FP2 thinks it is still at my dentists (where I took the last fix when leaving the surgery). This was over 24h ago. In map view it shows the location as “stale location” and the error shown on the GPS display is equivalent to the line of sight distance between my home and the dentist (about 18Km). So I think we do have a bug either related to how the last fix is stored or how the GPS system drops fixes because of the large error here.

Otherwise I fully agree with this - I am very very happy with using my FP2 for navigation:

6 posts were merged into an existing topic: Swiss Map Mobile on FP Open

A post was merged into an existing topic: FP2 GPS not working

Hello everyone!
I have a problem with the gps… Until yesterday I had the stock os and everything was fine. Yesterday I installed the open os and now Google Maps (yes I in,stalled the openGapps) can’t find my gps really well… It still find me but with more or less 30 meters of diameter! Not really precise then… Is it just my problem or there is a way to fix it?
I hope you can help me!

Check the #gpsguide for some general tips (disregard EPO, which is just relevant for the FP1).

As you said it is just for FP 1…I do have an FP 2.
The problem is that I actually never get the fix on the GPS. It is just the position based on the Wi-Fi and data signal.
Is this a "common " problem after the update of the FP open os or is it strange? Could be a hardware problem?

Did you try the workarounds suggested in this thread? (e.g. setting intermediate position to 1)

If your GPS worked in the FPOS I don’t think that it is a hardware issue.

Yes, I tried and still no fix. However it started to give me problems few days after the update. At the very beginning everything was working fine…

I usually use FasterGPS to set my location and to enable intermediate pos., and get a fix within 2 minutes (without these changes I also have issues in Open OS). With this app you can also tweak some more GPS related settings.
Maybe this can help you as well.

Thanks for the advise… I tried but it did not help… I’ll try to do a factory reset and see if in that case will start work again

How do I get back to the stock os by the way? So I can check if GPS will start working again with stock… Otherwise should be hardware issue…

Easiest way is to use the Fairphone Updater app. For more info, see:

1 Like

I do have the same problem. I got no fixes. Did most of the tips above, satstat shows me satelites, but i got no fix or osmand always tells me cant find your location. On the normal OS with google gps works fine and i never got problems with it. I’m really disappointed about this one and i will switch back to google if this isnt fixed.

Hello there,

Just for the record, I’ve tried most of the above but still can’t make the GPS to work, always got “position unknown” under OSMand~…

I have a Fairphone 2 since last December running Open OS 16.12.0

Have you tried the tips from the #gpsguide?

Hi there,

I did read your guide indeed, thank you.

I’ve installed fasterGPS and used it to set INTERMEDIATE_POS to 1, defined NTP servers…

Did a test yesterday as I was on a little drive for 15 minutes or so. Turn on SatSat in my car, it saw up to 10/19 satellites, I was getting new fix every seconds, could see my speed, coords, altitude… with an error between 3 and 5 meters most of the time. When I stopped I opened OSMand but it still couldn’t locate me.

Regarding this test and this current thread, GPS seems to work but there’s definitely something rotten in the state of Open OS.
Even sitting in my living room SatSat manages sometimes to connect to 2 or 3 sats (never get a fix though).

And that’s actually something else which I don’t get. Sitting at home I have cell network and WiFi, so system should be able to locate me using these informations. Isn’t that weird?

Happy with my Fairphone 2 and the Open OS anyway, living without Google Apps or store so far. Previous phone was still an old iPhone 3GS so it’s a huge improvement ;o)
Hope we’ll have an OS update soon which addresses this issue.