GPS doesn´t work on FP Open OS

Hello everyone!
I have a problem with the gps… Until yesterday I had the stock os and everything was fine. Yesterday I installed the open os and now Google Maps (yes I in,stalled the openGapps) can’t find my gps really well… It still find me but with more or less 30 meters of diameter! Not really precise then… Is it just my problem or there is a way to fix it?
I hope you can help me!

Check the #gpsguide for some general tips (disregard EPO, which is just relevant for the FP1).

As you said it is just for FP 1…I do have an FP 2.
The problem is that I actually never get the fix on the GPS. It is just the position based on the Wi-Fi and data signal.
Is this a "common " problem after the update of the FP open os or is it strange? Could be a hardware problem?

Did you try the workarounds suggested in this thread? (e.g. setting intermediate position to 1)

If your GPS worked in the FPOS I don’t think that it is a hardware issue.

Yes, I tried and still no fix. However it started to give me problems few days after the update. At the very beginning everything was working fine…

I usually use FasterGPS to set my location and to enable intermediate pos., and get a fix within 2 minutes (without these changes I also have issues in Open OS). With this app you can also tweak some more GPS related settings.
Maybe this can help you as well.

Thanks for the advise… I tried but it did not help… I’ll try to do a factory reset and see if in that case will start work again

How do I get back to the stock os by the way? So I can check if GPS will start working again with stock… Otherwise should be hardware issue…

Easiest way is to use the Fairphone Updater app. For more info, see:

1 Like

I do have the same problem. I got no fixes. Did most of the tips above, satstat shows me satelites, but i got no fix or osmand always tells me cant find your location. On the normal OS with google gps works fine and i never got problems with it. I’m really disappointed about this one and i will switch back to google if this isnt fixed.

Hello there,

Just for the record, I’ve tried most of the above but still can’t make the GPS to work, always got “position unknown” under OSMand~…

I have a Fairphone 2 since last December running Open OS 16.12.0

Have you tried the tips from the #gpsguide?

Hi there,

I did read your guide indeed, thank you.

I’ve installed fasterGPS and used it to set INTERMEDIATE_POS to 1, defined NTP servers…

Did a test yesterday as I was on a little drive for 15 minutes or so. Turn on SatSat in my car, it saw up to 10/19 satellites, I was getting new fix every seconds, could see my speed, coords, altitude… with an error between 3 and 5 meters most of the time. When I stopped I opened OSMand but it still couldn’t locate me.

Regarding this test and this current thread, GPS seems to work but there’s definitely something rotten in the state of Open OS.
Even sitting in my living room SatSat manages sometimes to connect to 2 or 3 sats (never get a fix though).

And that’s actually something else which I don’t get. Sitting at home I have cell network and WiFi, so system should be able to locate me using these informations. Isn’t that weird?

Happy with my Fairphone 2 and the Open OS anyway, living without Google Apps or store so far. Previous phone was still an old iPhone 3GS so it’s a huge improvement ;o)
Hope we’ll have an OS update soon which addresses this issue.


To me it sounds like you have an issue with OSMand. You should try clearing it’s cache or reinstalling it.

It’s normal that in your living room you won’t be able to connect to enough satellites to get a GPS fix. You could be located via NLP, but that doesn’t come preinstalled with Open OS. You should get microg UnifiedNLP from F-Droid along with some backends.


“Getting a fix” is not just about signal strength - thats what you see in SatStat, but it depends on many other factors. If the satellites you receive are sitting too close together you cannot get a fix because the phase difference between the individual signals is too small (have a look at the radar style graphic in SatStat). And although you get a signal from a satellite it might have travelled through different paths (reflections from buildings etc.) what causes the signal becoming inaccurate and unusable because of interference or pulse-repetition.


Thank you very much for all these precisions.

I read about microg but thought FPOOS was coming with one. Gonna look deeper into that. Thanks again.

It’s alive! Alive!!

Installed microg UnifiedNlp ( no gapps), rebooted, installed Mozilla and Nominatim backends then Waze located me then OSMand too.

Great, thanks forme helping the noob, maybe i should read more carefuly next time. ;o)

I’ll try to use OSMand only now. Never used waze in my life and would be happy to keep it that way. :-p




I can’t make the GPS work properly on my new Fairphone 2 nether, but work like a charm on the regular OS.

I tried both open Gapps and microG :
Like glouton, it work with microG and the Firefox UnifiedNlp, but it’s only by the wifi detection and it’s not precise at all, the real GPS steel not working.

I read here that some people can make work the GPS with FPOOS normaly, and somewhere else (or here, i can’t find it again) that the GPS stop working after a update…

Can someone with a working GPS tel us witch version of Fairphone Open he’s using?

I’m on 16.12, but GPS has also worked very well on all previous OS versions.

Try the #gpsguide, it usually helps.

same here, also on 16.12 now, and GPS has worked on this and also every previous version for me.

1 Like