GPS doesn´t work on FP Open OS

So you did this because your GPS did not work?

Sounds like a hell lot of effort. I guess it would have been way easier to try some of the many workarounds posted above, like patching the GPS.conf, or installing a tool like “Faster GPS”.

Personally I would not recommend to use an older software version, you will miss out the latest security fixes. Not a good idea unless you know how to circumvent the security breaches that this causes …

Maybe you’ve overdone it a bit. But your reaction confirmed exactly why I stopped updating in April on 1.2.8. Too anxsious ? No, because I lost my complete display module few hours later. FP replaced it seemlessly. But they maybe didn’t understand either what was happening.

You’ll need at least one backend. If you only want to use one you should probably choose the Apple backend since it’s the biggest database, so it will work the best. But it’s recommended to use backends for online and offline use and for wifi and cell data, so you get a location with or without an internet connection.

What I did:

  • install all backends
  • download databases for offline backends on the computer and import them
  • disable all backends except for one to see if it works for me
  • repeat for every backend
  • enable all backends that work, disable all that don’t
  • if a backend is updated I update the database and check its functionality again.

Thank you for your reply…
Nevertheless it seems to me surprising to have to use “workarounds” or a complementary application to solve a difficulty due to the update of the OS …
I expect and hope Fairphone solve this problem in a future update …

1 Like

Well, i don’t know why it doesn’t work for you, for me it works without problems, without the need for workarounds. So it may be specific to your settings or you location.

The app basically just optimizes the gps.conf to your location, so your device first tries to look up satellites for your area.

Hello again
I have no doubt that this app has an interest but “Scalded cat fears hot water” …
Indeed, why the GPS works perfectly with OS 16.06.0 OPEN and does not work with OS 16.07.1 OPEN ? … I think that’s the right question …
You will understand that I do not want to risk as Fairphone will not guarantee me that this bug is fixed!

Well, I really doubt this because this is a software bug and I can pretty much prove it. I have managed to get fast fixes with SatStat, within approx 1min. However, remaining errors are visible in alogcat. Furthermore, if any other app tries to get a fix on its own, it fails. Fail means, that it takes 12-15 minutes if you have “luck”. The Situation differs remarkably if SatStat was run right before opening any app. However, re-switching between applications will lead to a loss of GPS-fix! I keep re-establishing even the exact same position, rather than “moving” on from a known fix.

This is a software-bug, and telling it is not is just ignorance!

Maybe something to try: I have enabled GPS fix and status notification in SatStat, because I was missing the little satellite-dish icon I am so used to from CynogenMod. Ok, that wobbly teardrop does not look so great, but I think one positive side effect of involving SatStat could be that I have no GPS problems at all.

Hello everyone :slight_smile:

Thanks to all your contributions, I finally got my location working with GPS and cellular network :grinning: I’ll make a little summary of what I did. Hope this might help non-experienced users (of course check that your location setting is turn on in the parameters…).

My phone :
Fairphone 2 with open source OS (16.07.1).

My Problem:
Could not have my localisation in OsmAnd either with GPS nor cellular Network.

What You could try:

  • Get developers options ON and root access enable
  • Download FasterGPS to change two things :
    1. Change INTERMEDIATE_POS=0 to INTERMEDIATE_POS=1 in advanced parameters of the app (which is in the file /system/etc/gps.conf)
    2. Set my continent and my country for NTP server
  • Reboot
  • Download Satstat and open it
  • Take a walk OUTSIDE on the street (at least 5 minutes)
  • Ask AGPS data with Satstat
  • Satstat showed me that I was connected to several satellites
  • Open OSMand, and GPS worked ! (Not cellular network)
    For cellular network
  • Download µg UnifiedNlp (no GAPPS) and MozillaNlpBackend
  • Reboot
  • Open UnifiedNlp
  • Check the box “Mozilla location service” in “Configure location backends”
  • Reboot
  • Localisation with cellular network worked with Osmand. I did not try with an other app yet.

Frankly, I’m not very familiar yet with all this technical stuff. So my answer might be incomplete. Moreover, you might not have to do all the steps…

PS : I first downloaded LocalGsmNlpBackend and downloaded mozilla database (and it worked for cellular network). But localisation with the wifi did not work… So I switched to MozillaNlpBackend, which seems to handle both. So I guess you can directly download MozillaNlpBackend. Also I rebooted my device so many times :joy:


I had the same problem since I installed fairphone Open OS like 4 month ago. It works for me now… so big thanks @blutch !

@blutch and @romainvieme: does it work constantly and without flaws? I followed the steps and it worked, but when I tried some hours later, it took almost 10 minutes before working.
I have tried installing other location services as well (GSM location Service and Apple wifi, both selected along with MozillaNIpBackend). I thought that it went better, but not all the time.
I find that OSMand takes a lot of time to find my location, but Google maps on Firefox finds it much quicker. I have tried another app (local transports), but it cannot find my location.
So, my question is: does someone managed to have location working every time (event if you deactivate and reactivate it), and if so, any idea what I could try?

In OSMand did you enable “continuous background mode”? Otherwise it will start from the beginning every time you close the app or lock the screen. That’s the only reason I can think of why it takes longer in OSMand.

Yes. Sometimes it takes a while (few minutes), but usually it’s very fast.

It’s all in the #gpsguide. Just ignore EPO.

I notice that for whatever reason SatStat gets the first fix much faster than OsmAnd. So I always start SatStat and let it run until I get a stable fix (error less than 100m). This usually only takes about 2 minutes maximum. After this first fix OsmAnd gets it’s fix almost immediately and keeps tracking my position happily.

1 Like

Good point. SatStat “claim” it’s just a diagnostic tool (besides the ability ro refresh A-GPS), but I too make the observation that opening SatStat gets you a fix faster. It may be just the Placebo effect of the time flying by while watching as SatStat finds more and more Satelites, but I don’t think so.

Thank you both for the tip! I guess that I just have to be more patient… I don’t use the GPS that often, so it’s hard to determine how and when it works or not. The only thing that doesn’t work at all is the localisation for the app I use for local transports ( ; I use version 0.2.16). Could it be because they use another type of localisation? I can still use other functions of the app, so it’s not that big a deal, but it would make life easier if it worked!

There are still lots of odd behaviour that I observe even in SatStat: I sometimes get a fix almost instantly, but the error is 20Km or more although a whole bunch of satellites have turned blue - what means it uses them for the fix. Time to fix is zero, but it does not display any bearing or speed. Then all of a sudden the error drops to an acceptable distance of a few meters and I get readings for bearing and speed. Once this has happened both SatStat and OsmAnd will quicky provide an accurate fix - even when turned off and on again. It looks to me as if the system has problems with getting a fix when you have moved to a new location with GPS not in use while moving. The behaviour almost looks like the GPS is still “sitting” on the old position data. When it then suddenly gets new data from the new position it discards them as invalid because the position error is too high. Then it stays in this unfortunate state until it gets “convinced” that the new position is actually valid. Outdated AGPS data should not be the cause, because I am observing this effect even when I try to get a fix after I have just driven a few miles without GPS in use.
Very strange :worried:

I get that too, but it only lasts a few seconds, so I wouldn’t think much of it.

Same here. Also satellites already turn blue - usually after 0 seconds - before there are 4 of them, as though 1 satellite was enough for a fix. On the FP1 they only 4 or more could turn blue at once, which made sense.

I’m not sure I ever experienced this, but what I sometimes experience is that the GPS fix is lost for no apparent reason, but some apps still show GPS as fixed, but don’t update the position. It sometimes takes up to about half a minute to get the fix back. Again it seems like switching to SatStat gets the fix back faster. I then switch to SatStat and turn in to landscape mode and back to get a clear screen - before it still shows the satellites from the last fix.

But all in all I’m very happy with GPS performance. Rare occasions where I have to wait up to 30 seconds to get a fix (back) are not so bad. :slight_smile:

I just checked this morning with SatStat and my FP2 thinks it is still at my dentists (where I took the last fix when leaving the surgery). This was over 24h ago. In map view it shows the location as “stale location” and the error shown on the GPS display is equivalent to the line of sight distance between my home and the dentist (about 18Km). So I think we do have a bug either related to how the last fix is stored or how the GPS system drops fixes because of the large error here.

Otherwise I fully agree with this - I am very very happy with using my FP2 for navigation:

6 posts were merged into an existing topic: Swiss Map Mobile on FP Open

A post was merged into an existing topic: FP2 GPS not working