GPS doesn´t work on FP Open OS

The 10 minute waiting time until you get a fix is probably a clue that your AGPS data is not properly updating. AGPS (Assisted GPS) data contain the ephemeris data that tell the GPS system where the satellites are. When AGPS is not available the system tries to get the ephemeris data from the satellites themselves - they are constantly transmitting it, but it takes time (usually about 10-20 min.) until all data are downloaded because the bandwidth is small.
I do not know SatStat very well, but GPS Status shows you the age of the AGPS data.

1 Like

Just to check if there is any workaround for this problem ? I have a plain-install of FP Open OS (no GAPPS, XPosed etc. installed) and GPS does not work at all. SatStat is showing no satellites. The only thing that happens is that the location notification icon pops up (but no satellite / GPS icon) when an app like OsmAnd starts.

Today, while checking a logcat, I realized the following lines repeating
E/LocSvc_launcher( 9474): E/main:351]: Error opening /etc/izat.conf No such file or directory

As LocSvc_launcher already sounds suspicious, I checked google and yes, this looks like it has something to do with the location provider.
I checked the FPOS from (“returning to the gms version”), there is a izat.conf included. So I tried this one on my phone. As gps did already work, I’m not sure whether it helps much or at all, but it might be that GPS works a bit better and more stable while switching apps.

1 Like

You are exactly the man to try what lklaus wrote!

Bug or not, for a lot of us this makes the difference between a usable Fairphone Open OS and a useless one.

When I realized this “bug” exists, I had to restore my previously installed but rooted Fairphone OS. :cry:

What I want is an OS with root access, TWRP, XPosed and Gravity Box, some Google Services and working Apps.

It would be great if Fairphone would handle this as a bug as it is an annoyance for a lot of people.


Hey ! I’m new here (got my phone fews days back). GPS was working perfectly with stock ROM. But since i’ve installed the OpenOS 16.07 (no gapps or anything else), it simply does not work. Yesterday, I could see 6 or 7 sat in satstat, but no location. After “fixing” the gps.conf with the INTERMEDIATE_POS to 1, I simply do not get any sat. I let the phone for nearly 1 hour on a table outside and it never saw a single sat. I’ll check what FasterGPS gives, but it looks like the issue is still here… That’s a bit sad, knowing that I’ve switched phone (from old samsung i9000) to get decent GPS and be able to contribute to OSM.

I cannot confirm this problem: Just went outside with 16.07 and got a whole bunch of satellites and a fix both on SatStat and OsmAnd.
Did you try turning location on and off ?

Yes I tried that. I tried to reboot the phone, changed application, …

Hi, it’s been three weeks since I received my FP2, which I immediately flashed to Open OS. I’ve had several small glitches (reflash the userdata alone to create a gap for encryption headers, TWRP do not ask to open the encrypted partition, graphic glitches at boot…), and a major one: the GPS.

In my use case I have very few apps from the play store, mainly Waze and Pokemon GO which require location. Xposed and Xprivacy are installed.

Things I tried:

  • with openGAPPS pico, waze and some other map related software crashes (soft reboot of userspace), pokemon go have random crashes (black screen, no led).
  • with microg (gmscore, unifiednlp backends, etc but no play store signature spoofing), waze and other map software works, pokemon go doesn’t cannot acquire location.
  • with microg (same but WITH signature spoofing via xposed module) waze and other map software crashes (soft reboot of userspace), pokemon go works (not tested for long though).
  • with nothing, waze and cie works, but pokemon go doesn’t.

Two recurring errors seems relevant:
“Asset path ‘/system/framework/’ does not exist or contains no resources”
“java.lang.IllegalArgumentException: provider doesn’t exist: fused”

It’s definitely something wrong with the FP Open OS fused since everything works on the FP OS

How did you fix gps.conf - editing or copying? Please check the privileges after fixing gps.conf. They should be “-rw-r–r--” and user/group=root/root.

I changed gps.conf using vi from command line, so permission should not have changed. My guess is that I screwed the file; vi on the phone is not very user friendly :slight_smile:

I tried using FasterGPS last night, and it did help… a bit. Now I can have a location in SatStat or Osmand~, even if nearly no sat are available (4). But currently, the error is ~9km, so it’s basically useless and I can’t seem to be able to get something better.

I switched back to Fairphone OS 1.5.1, but at the moment, GPS is still slow to get a fix. Maybe that’s because I’ve only tested from the balcony… But my older phone was able to get a fix from there… Maybe this is something else.

After several tries, I could not get a single fix using a fresh reinstall of Fairphone OS 1.5.1. I did get something once, but strangely, only SatStat could use it: OSMand or Pokemon Go could not get a location.
I’ve waited nearly 1hour in a park outside and SatStat did report ‘3/18’ at most. I tried to switch location on/off, reboot the phone, … No luck. So I’m not sure that my initial problem comes from OpenOS.
I will try to reflash using fastboot.

On OpenOS (without GApps) you additionally have to install microG location provider and at least one location backend (gsm,wifi,…). Then the satellites can be found faster and it’s necessary for highest accuracy.

Did anyone complaining about this issue in this thread managed to fix it? If not I have to send it back to NL. It is as sad as ridiculous how this is handled like a minor issue of neglectable few by the forum mods… :pensive:

Last 2 days ago I started FP Open OS and only switched on GPS by settings. App is Osmand. No way! Today thanks to this forum I used SatStat from F-Droid. And now it works with tremendeous precision and a bunch of SATs. Is this only because my office is on top , 5th floor?

I use FP Open OS without microG… and I get a GPS signal. It takes about 5-10 Mins. I looked at microG on F-Droid - which provider should I use?

could you explain steps 3,4,5
what and where is the "Terminal Emulator"
Sorry but every body is not a specialist

It is an app that is preinstalled.

Just go to All Apps, there you’ll find it.
4 & 5 is just commands you type in the command line.

If your aim is to modify the gps.conf, it may be easier for you to open Amaze, and edit the file with Amaze editor (click on the file in Amaze, open with Amaze text editor).

Thank you for your help…
I try an other solution which seems efficient…
1-Updater OPEN 16.07.1 to OS 1.5.1
2-Updater OS 1.5.1. to OS 1.4.1
3-Updater OS 1.4.1 to OPEN 16.06…0
It’s do-it yourself but I’very happy with that and I’ll stop all the OS open updates…
the GPS is OK with OPEN 16.06.0 (like before)