Stuck in Team Win Recovery Project after Android update

Hi, you wrote that “Normally, once you are in TWRP’s main menu, you can just connect your phone via USB to your PC, and Internal Storage would be available so you could copy files over”, I have tried connecting them via USB over and over but nothing happens. If I understood you correctly the phone should show up like normal when I connect them? Any idea why this does not happen and what I can do?

I don’t usually need that feature, so your comment prompted me to try after a long time … and it didn’t work for me either, but it clearly did in the past. So …

I’m using Windows 10 Pro 1903.
For testing purposes over time I apparently installed different USB/MTP/ADB driver packages like “Minimal ADB and Fastboot” (I think there are even different incarnations with the same name), “Universal ADB Driver” and possibly more, and I either forgot to uninstall them again, or they didn’t uninstall cleanly, or whatever.

To get MTP running again, I did the following …

  • Disconnected the phone from the computer.
  • In Control Panel - Programs and Features:
    Uninstalled everything with “MTP” or “ADB” in its name.
  • Rebooted Windows.
  • In Control Panel - Device Manager:
    Enabled View - Show hidden devices, and then uninstalled every possible ADB, MTP and smartphone device, hidden or not.
  • Rebooted Windows.
  • Connected the phone again with booted TWRP, Windows then needed a moment to set up MTP again automatically and prompted a success message afterwards.

Et voilà … Now the Fairphone 2 with “Internal Storage” and “Micro SD card” shows up again in Explorer as soon as TWRP is booted and the phone is connected via USB. I tried TWRP 3.2.3-0 and 3.3.1-0.

Turns out I deleted my working #dic:adb and #dic:fastboot commands with this endeavour (they were probably from Minimal ADB and Fastboot), so I did the following …

5 Likes

I’ve just crashed again. I charged my phone - without the sim card in - turned it on… Emails still coming in, amazingly (wi-fi available) - and a Fairphone update. So I checked that - it started downloading… Net time I look, its in TWRP again. So I’m trying this… A zip file came in, a partition seems to be updating. Ah, the ‘No OS…’ Rebooted anyway - as mentioned by others. Hmm Fairphone start screen. All seems fine. Oh… an email came in, a current subject despite the sim card having been out for a week. What the … Do I even need a simcard?? This is so weird. See why TWRP needs clear instructions on the screen?

The SIM card is needed to connect to the mobile network, so you need it for calls and SMS/MMS messages as well as internet via mobile network.

E-mail is relying on internet, doesn’t matter whether internet via mobile network or internet via WiFi.
So as long as you have WiFi, you indeed wouldn’t need a SIM card to get e-mails, or access the internet in general.

I guess you will like the next OS update, as it replaces TWRP with the stock Android recovery, which has a lot less options than TWRP.
(This was announced recently in several TWRP-related bugtracker issues.)

2 Likes

I hope that’s going to be an improvement… A recovery programme that doesn’t tell us how to use it - with a risk that if I pick the wrong option wipes all of my data - is not a recovery.
And I have no idea why it keeps coming up. After the first one I have kept firmly away from the volume buttons - and my FP2 has crashed twice more in 3 weeks. Meanwhile my old Samsung button phone works fine (as long as I remember to charge it every 5-6 days) without crashing.
So… I have a FP2 that does email and even surfs - as long as I have wi-fi - and a Samsung that takes photos and takes calls without crashing - and it doesn’t even cancel calls if the screen touches my ear! Sorted.
I’ll keep an eye out to see if the new OS avoids these TWRP crashes - and if it does I may put my SIM back in and see if it’s a phone or not. Not impressed.


It’s not as if the options in question are named confusingly.
You can’t choose something like “Abnoramalzing Some of the Matrices” * and it would wipe your phone.
You can choose to “wipe” or “format” something called “data”. Surprise: That will wipe or format some data.
You can choose a “factory reset”. Surprise: That will reset the phone to the state it was in leaving the factory. Well … not really, but in this case the name is more intrusive than the function it executes, which is no major harm.

(* Fun splash screen message of Discord, one of many.)


You don’t need to be a computer expert, but you don’t get around taking part of the blame when you’re not knowing what you’re dealing with and something goes wrong.

I am not an expert regarding the details of how a car works. But I have a driving license and thus a basic understanding of what a car is, what harm it can do to me and others, and what is what in the car, and how I theoretically operate all that in a safe manner.

1 Like

I have tried to update my fairphone 2 and it came into TWRP mode.
Then, I have tried to update it manually following forum instructions and it appears “could not flash the modem partition on device XXXXXX”
Anyone could help me?
Thanks

1 Like

Welcome to the community forum.
I moved your post here to avoid duplicate topics.

Worth a try when in TWRP …

A little more detail in between …


Which instructions? The official ones are here …

1 Like

Thanks very much for your responses
After Install -> cache -> install zip file ‘/cache/fp_update_gms-fad0fe00.zip’,
E1004: system partition fails to recover
Updater process ended with ERROR: 7

In this case please follow the official instructions for the manual installation.

You what?? I didn’t intend to become a computer expert when I paid, was it 300 squid? for a telephone. Oh, it also takes photos, and emails, even acts as a GPS and Facebook and even recently surfs the web (not much point - screen too small) !! Wow, I never had a phone do all that before, so I’d better read the instruction manual. THERE ISN’T ONE. I’ve been waiting 2 weeks for Fairphone to reply to a question about the TWRP. In the meantime I have a camera (Olympus) a laptop (Panasonic) and a button phone (Samsung) that all work, none of which have crashed into TWRP - and have instruction manuals. My Fairphone2 remains off until I solve how to stop TWRP crashing my life.

We have given you many tips on how to get out of TWRP, but if you refuse to try them and instead insist on ranting about things none of us here have any control over then we can’t help you anymore.

2 Likes

Sorry to you all. Yes, it was a rant and I was annoyed - and a lot more advice has appeared since I posted this provocative subject. I just paniced when that screen appeared

… Clearly several of the options are scary. Restore or reboot seem safer and maybe Settings could give advice - but I still ended up loosing loads of important data. Often being on the road, miles away from wi-fi with only a phone to hand, when I was suddenly cut off by this mystery app. = Melt down.
Thanks for all of your help. I’m putting my sim card back in to my FP2 - and hope it works.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.