Tried to upgrade TWRP before upgrade to LOS 17.1, now stuck in boot loop! Help!

Hi Hope that anybody can help! I was about to upgrade to LOS 17.1 (from LOS 16) but thought that I would upgrade TWRP first, from 3.3.1-0 to 3.3.1-1 and now I am stuck in boot loop and I cant find a solution for it.

  1. placed twrp img file on sd card
  2. booted in to TWRP
  3. tapped “Install”
  4. located the img file, "
  5. choose the “Recovery” option, and swiped to confirm.
  6. install successful.
    Have tried to reboot to system, have tried power off and then start and LOS splash animation comes up and goes for a couple of minutes and then boots back to TWRP.
    I did not do any backup before TWRP upgrade, thought it was a routine thing.
    And maybe its a easy thing but I dont dare to do anything, if I loose all my data…
    Plz any help much appreciated!

I am not sure anymore, but I think that what you need to do is to reboot into recovery after point 6. Make sure you are on the TWRP version that you just installed.

After you have done so, please try again to boot into system.

Hi @urs_lesse and thanks for reply! But tried our way and no luck! The LOS animation starts and keep on going for about 3 min and then the screen gets black and when I click the start button I am in twrp again…

1 Like

And another very annoying thing is that I can´t access the phones storage, not internal or sd card. My pc gives a notice when I connect the phone with usb cable but its not showing in the explorer. I dont know what to do, and I have read a lot of threads but none with my problem, yet…

can you boot in Download mode (volume down + power) and access the phone via the computer (“adb devices” command from the terminal for example)?

That would boot the phone into Fastboot Mode, where ADB doesn’t work at all.
Fastboot would work there, fastboot devices for checking.

If you still have the install file for the LineageOS build you currently have on the phone, just install it with TWRP again over the existing installation. This doesn’t do anything with Apps or data … helped me a couple of times out of a not booting OS after a TWRP backup restore.

You need to boot into TWRP for your PC to see the phone’s storage.
If this still doesn’t work …

@AnotherElk Thank you for your reply! Is there anyway I could find out which build of LOS i have installed? Because I think I deleted it, and i cant remember when I made the latest update… Or could I just take a chance of some build a some time back?

@AnotherElk So I took a chance and used the first installed lineage I still had on the phone and it worked! Thank you so much!!! Now I have to muster the courage to go ahead and get LOS 17.1 installed :worried::cold_sweat:

1 Like

Maybe you should do a backup now! So that there’s no risk in updating then. :wink:


@Volker Ohh yeah! Amen to that!! :innocent: but could not imagen that updating twrp would get me in a boot loop… will think twice before ever do that again.

1 Like

That’s the part I don’t understand either.
Flashing or installing TWRP doesn’t do anything to the OS.
I flashed different TWRP versions countless times, never had this issue as a result.

Perhaps a coincidence with an OS issue.

Are you quite sure you choosed Recovery? If you did, you now should have version 3.3.1-1 of TWRP. Do you?

Hi and yes I have and I did choose recovery. I first tried to downgrade to 3.3.1-0 but that didn’t work so as I sad earlier I managed to install an older LOS and got the phone back in working order. I have now installed LOS 17.1 (with TWRP) and it went very smooth, so I am all happy and trying to forget the horror of bricking the phone :cold_face:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.