Stuck FastBoot Mode

So i just got my FP4 and I wanted to install lineageOS on it. So i followed the steps but when I got to the point of flashing the recovery ( TWRP ) I got stuck in a bootloop in the fastboot mode.
It’s the only window i can access, when i try to boot normally or go to recovery it eventually just brings me back to the fastboot mode. I can select the power off option and it does work but i can’t go to any other menu.
I have installed lineageOS on other phones before but I’m really stuck.
I’ve tried everything i could find and nothing seems to work, I’ve even tried to go back to stock but after i enter Yes two lines appear and the window closes itself before i can see what’s written.
I can access it with fastboot from my PC and I’ve flashed other recoveries to try and fix it and it seems to flash properly but nothing changes.
I have tried a bunch of things but I might have missed something or done something wrong so I’m willing to retry anything you sugets.

Neither LOS nor TWRP are officially supported (yet), just in case…

I guess your bootloader is unlocked? Did you try to change the active slot?

Get the current active boot slot:
fastboot getvar current-slot

Select the other slot: (either “a” or “b”)
fastboot --set-active=b

Just a few days ago, someone had the same issue with FPOS after a failed atrempt to install e/OS, we could not find the root cause (changing slots was not tested due to missing adb/fastboot on the PC) however another attempt to install e/OS worked, so maybe try e/OS and afterwards LOS again?

For completeness: what other recoveries did you try?

Whatever you do better dont lock the bootloader.

1 Like

Some questions to clarify things:

  • Which LineageOS version are you trying to install and what instructions are you following?
  • What OS are you running fastboot from?
  • Have you tried different USB-cables / -ports?
  • If you can catch it, at which point exactly does the stock installer crash?

Oh and welcome to the community BTW :wave:

1 Like

So I tried to install /e/OS but I get an error here
Writing ‘devcfg_a’ FAILED (remote: ‘Flashing is not allowed for Critical Partitions’)

I was following this guide but I didn’t get to installing LineageOS I got stuck after installing the recovery

I’m doing all this on Windows 10, but I have Arch is there’s stuff you want me to try

I have tried every cable/ports I had and they all stop at the same point

The stock installer windows closes but I used a screen recorder, I left the serial number blank
INFO: Looking for connected devices(s)…
INFO: One Fairphone 4 in fastboot mode found (serial number: --------).

And thanks I’ve been wanting a fairphone for a while and really want this to work

Here You find the community efforts and LOS downloads.

And here reg TWRP

Not sure if you might find some Tipps or help there

1 Like

Ok thanks all, I was finaly able to make it work by booting from recovery instead of flashing, so;
fastboot boot twrp.img
instead of
fastboot flash recovery twrp.img

It all seems to work now


Great everything works now :tada:

If you run into similar problems in the future and need to reinstall stock (or some other ROM), two quick notes:

That error means your critical partitions weren’t unlocked, use fastboot flashing unlock_critical if that happens.
Installers that don’t use recovery to install, like stock, /e/, CalyxOS, need that.

The stock FPOS installer is currently broken on Windows and has been for quite some time. If you need to go back to stock you’ll either have to change a line in the script, or use Linux.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.