Stock fp3(+) (factory reset) boot loop (workarounds in first post)

Haben Sie “Find My Device” / “Finde mein Handy” aktiviert? Sie müssen diese Funktion deaktivieren, bevor Sie Google Play-Dienste deinstallieren können.

1 Like

Tout d’abord, un grand merci pour cette aide précieuse !

Personnellement, je suis encore bloqué : après avoir activé le débogade USB (partie 1), et téléchargé ADB, je n’arrive pas à valider la commande “cd FolderLocation” : le message que je reçois est alors “Le chemin d’accès spécifié est introuvable.”

Quelqu’un aurait-il une explication ?
Merci d’avance,

L’union fait la force…alors que dire de la solidarité !

Mathieu

Quel système d’exploitation utilisez-vous (par exemple, Windows, MacOS, Linux, etc.) ?

Remarque : lorsque vous tapez cd FolderLocation, vous ne devez pas taper FolderLocation mais plutôt le chemin dans lequel votre fichier adb.exe peut être trouvé ; par exemple. cd %UserProfile%\Downloads

Genau soweit bin ich auch gekommen …
Ich kann dir nur empfehlen die Lösung von Yasen_Tomov zu nutzen.

Ich hatte das gleiche Problem und bin nur mit der Lösung (leider nur über adb) zum Erfolg gekommen.

I can confirm that Solution 3 as proposed by @Yasen_Tomov has worked in my case. Thank you for the support.

1 Like

Oui, il faut bouger le dossier en gardant la touche Command appuyee. Sinon ca ne marche pas!

Correction : although in the first days it worked fine I now have the same issue again, therefore it is not the Smart Launcher that causes the problem

So although this is a topic RE FP3 you had/have a similar issue with the FP4

Is there not a topic for the FP4 ??

There is another idea that came to me - maybe its possible to update the google play service from SD Card by recovery boot (if this would work, no adb would be neccessary, just an update file placed on the SD Card via computer. I already asked fairphone to check this). Unfortunately on my phone the SD Card is not recognized in the recovery boot mode (failure message: mount of sdcard failed - despite it’s formatted by the phone and works properly while phone is used normal; the same message comes without sdcard), so I couldn’t test this. To enter the recovery boot menu, long-press both on/off and volume down, the phone restarts with boot menu, then toggle by up/down to recovery mode, press power on/off => the phone restarts again and shows a “no command” picture, then press power and volume up. In the menu that appears now is an option to update from SD Card

No, I haven’t found a topic with/for FP4 that matched my problem. The one closest to it dates from September.

@JP-FP @JurgP I guess you use these two accounts?

Is there any hint that there is a relation between your bootloops and the retracted Google Play Services update? If not, your problem might better be extracted into a separate topic of its own.

3 Likes

Merci : la solution a fonctionné :slight_smile:
C’était émouvant un téléphone qui ne redémarre pas sans arrêt !

Seule question que je me pose encore : puis-je réactiver les mises à jour Google Service ?

Oui - la mise à jour défectueuse n’est plus poussée, donc la réactivation de Google Play Store ne devrait pas entraîner la réinstallation de la version “défectueuse” des services Google Play.

adb shell pm enable com.android.vending

Tous les détails

bonjour,
la solution #3 du post #403 a très bien fonctionnée pour nos 2 FP3.
un grand merci même s’il m’aura fallu passé beaucoup beaucoup de temps sur l’ordinateur pour effectuer toutes les étapes.

1 Like

Hi @urs_lesse . Thanks for making me aware, that I am using 2 accounts (the first one didn’t work first, so I created a second on). I will ask support to merge them (if possible). Yes, I’m quite confident, that it is the same issue - however, I will only reboot on the weekend to see if the actual version 22.44.17 (150400-488410709) has fixed the issue.

1 Like

Update: this version has not solved the problem für my FP4 (arrrrggggghhh - 4th reset an re-installing a lot). I will open a topic in the FP4 section.

2 Likes

Das habe ich gemacht, aber das Deinstallieren der Updates schlägt immer noch fehl.

After doing solution 3 (uninstall com.qualcomm.location) my phone is running now without any futher problems.

The only question now is: Are there some activities requrired to get the phone back to it’s normal work with all previous packages running?

Thank you in advance!

If you’d disabled Google Play Store you’ll need to re-enable it.

adb shell pm enable com.android.vending

Full details

Hello,

Sorry to bother everyone but I’m a bit lost in the thread. My was affected by the problem and I solved it by following @Pilo11’s instructions (downgrade GMS via adb):

adb shell am force-stop com.google.android.gms
adb shell pm clear com.google.android.gms
adb install -d com.google.android.gms_22.02.21_\(150408-428111784\)-220221039_minAPI30\(arm64-v8a\,armeabi-v7a\)\(480dpi\)_apkmirror.com.apk 

However, if I understand correctly, this is not the recommended way (Stock fp3(+) (factory reset) boot loop (workarounds in first post) - #408 by Yasen_Tomov). It seems that most people prefer solution 3 (uninstall Qualcomm Location Services) so I did that:

adb shell pm uninstall -k --user 0 com.qualcomm.location

As recent comments indicate, I also did:

adb shell pm enable com.android.vending

However, I’m not sure of the effects of the previous solution(s).

So my question is: how can I get back to normal after all that (particularly about GMS) ?