Stock fp3(+) (factory reset) boot loop (workarounds in first post)

That you have a fault and blame mentality is the issue, no one is at fault

  • Fairphone made a phone
  • Google sent a faulty update to those who chose to use the play store on the Faiphone
  • Users choose which phone and OS to buy

If you buy the Fairphone from Fairphone rather than say Murena then yes you subject yourself to the Fairphone Android licensed by Google.

It’s Google that insist on the Google Play Store else Fairphone wouldn’t get a licence.

If the buyers don’t read up on this as they are too busy or don’t care, some 99%, then want to blame Fairphone or Google then I am not surprised…

But that sort of mentality can not be helped of comforted. I do recognise how upset people are but what else can the user on this forum say.

Read about the product before you buy. Read about Android and Google if you don’t buy Apple etc.

1 Like

Hi and welcome to the forum.

If you buy a new battery the same may happen again. See if you can find another person with an FP3 and ask them to charge the battery.

You can also look for a #fairphoneangel in you area that may assist

2 Likes

My phone restarts every5-8 sec max

I am not good with the tech but this instruction was pretty easy to follow. It all worked until the last command to install the new software version.
I tried with different iteration of the link from you, @Pilo11 and even copied the whole name of downloaded file and always the same message:

adb: failed to stat com.google.android.gms_22.02.21_(150408-428111784)-220221039_minAPI30(arm64-v8a,armeabi-v7a)(480dpi)_apkmirror.com.apk: No such file or directory

Any suggestions how to solve it?

Hello Yasen_Tomov,

thank you for the detailled explanation.
Sounds good for me.

So I’ll try tomorrow your Solution 3 and uninstall Qualcomm Locatin Services

adb shell
pm uninstall -k --user 0 com.qualcomm.location

Thank you. This solution finally seemed to work for me!!!

1 Like

And please bring this solution to the top of this topic!

Thank you for these clear words!

Hello:

Just to check before I reactivate Play Store updates: when did the issue appear on your side? :innocent:

Thanks in advance for your answer!

the same would happen again eventually, but initially the new battery would have power right? I just need it to work for long enough to try following these instructions or doing a factory reset, then presumably it will charge again?

I know someone with a fairphone but they live on the other end of the country…

1 Like

This solution
adb shell
pm uninstall -k --user 0 com.qualcomm.location

published by Yasen_Tomov works for me!

The only question is now, do I need to reeinstall the package later?

3 Likes

Just to check - when you try to turn it on, do you press and hold the power button for a few seconds? Turning it on needs more than a tap of the button; holding it down for 2-3 seconds seems to do the trick.

A̶l̶s̶o̶,̶ ̶i̶f̶ ̶y̶o̶u̶r̶ ̶p̶h̶o̶n̶e̶’̶s̶ ̶p̶l̶u̶g̶g̶e̶d̶ ̶i̶n̶t̶o̶ ̶t̶h̶e̶ ̶c̶h̶a̶r̶g̶e̶r̶,̶ ̶e̶v̶e̶n̶ ̶i̶f̶ ̶t̶h̶e̶ ̶b̶a̶t̶t̶e̶r̶y̶’̶s̶ ̶f̶l̶a̶t̶,̶ ̶y̶o̶u̶ ̶s̶h̶o̶u̶l̶d̶ ̶s̶t̶i̶l̶l̶ ̶b̶e̶ ̶a̶b̶l̶e̶ ̶t̶o̶ ̶t̶u̶r̶n̶ ̶i̶t̶ ̶o̶n̶ ̶a̶s̶ ̶t̶h̶e̶ ̶p̶o̶w̶e̶r̶ ̶c̶a̶n̶ ̶c̶o̶m̶e̶ ̶t̶h̶r̶o̶u̶g̶h̶ ̶t̶h̶e̶ ̶c̶a̶b̶l̶e̶ ̶(̶s̶o̶m̶e̶t̶i̶m̶e̶s̶ ̶y̶o̶u̶ ̶c̶a̶n̶ ̶r̶e̶m̶o̶v̶e̶ ̶t̶h̶e̶ ̶b̶a̶t̶t̶e̶r̶y̶ ̶a̶n̶d̶ ̶r̶u̶n̶ ̶t̶h̶e̶ ̶p̶h̶o̶n̶e̶ ̶j̶u̶s̶t̶ ̶o̶f̶f̶ ̶t̶h̶e̶ ̶c̶a̶b̶l̶e̶ ̶/̶ ̶t̶h̶a̶t̶ ̶w̶o̶r̶k̶s̶ ̶b̶e̶t̶t̶e̶r̶ ̶a̶s̶ ̶s̶o̶m̶e̶ ̶p̶h̶o̶n̶e̶s̶ ̶w̶i̶l̶l̶ ̶a̶u̶t̶o̶-̶s̶h̶u̶t̶d̶o̶w̶n̶ ̶i̶f̶ ̶o̶n̶ ̶l̶o̶w̶ ̶b̶a̶t̶t̶e̶r̶y̶,̶ ̶e̶v̶e̶n̶ ̶i̶f̶ ̶c̶h̶a̶r̶g̶i̶n̶g̶…̶ ̶I̶ ̶c̶a̶n̶’̶t̶ ̶r̶e̶c̶a̶l̶l̶ ̶t̶h̶e̶ ̶s̶p̶e̶c̶i̶f̶i̶c̶s̶ ̶o̶f̶ ̶h̶o̶w̶ ̶F̶P̶ ̶h̶a̶n̶d̶l̶e̶s̶ ̶t̶h̶i̶s̶.̶)̶ (redacted per yvmuel’s comment)

One other thing to check is your charge cable’s OK - i.e. if you have another USB-C powered device plug that into your charger to check it receives a charge - sometimes a cable gets twisted, which breaks the metal wiring resulting in temporarmental connections.

Hope some of those ideas help.

2 Likes

No when the battery is really completely empty the phone will not start when plugged in.

Also this does not work with the FP3

@Ellen_Lees it seems you are hit by different issues, for the charging issue I think its better to follow up in one of the many topics around this
https://forum.fairphone.com/search?context=topic&context_id=90386&q=FP3%20not%20charging%20order%3Alatest&skip_context=true

4 Likes

Which operating system do you use (e.g. Windows, Mac, Linux, etc)?

  1. When putting the filename you need to provide the full path to that file. If the file’s in the same directory as you’re console session then just the filename is sufficient (as paths are relative). e.g. Say you’re on Windows and the APK file’s in your user account’s download folder you can change your console’s working directory to be that folder by running pushd %userprofile%\downloads (if using cmd) or pushd "$($env:userprofile)\downloads" (if using PowerShell); then reference the file by name; or you can use the absolute path (e.g. adb install -d "com.google.android.gms_22.02.21_(150408-428111784)-220221039_minAPI30(arm64-v8a,armeabi-v7a)(480dpi)_apkmirror.com.apk" (cmd) / .\adb install -d "$($env:userprofile)\downloads\com.google.android.gms_22.02.21_(150408-428111784)-220221039_minAPI30(arm64-v8a,armeabi-v7a)(480dpi)_apkmirror.com.apk" (PowerShell)).

  2. Somtimes character escaping can be an issue. That is; the system needs to know which letters are part of a command vs which are part of a filename, as some characters have a special meaning. On Windows you can resolve this with the above filename by putting the name in double quotes. On other systems you may have to “escape” some of the chararacters (e.g. by putting another character, such as a backslash before them); this can be seen in Pilo11’s original post where he’s escaped the brackets; i.e. adb install -d com.google.android.gms_22.02.21_\(150408-428111784\)-220221039_minAPI30\(arm64-v8a,armeabi-v7a\)\(480dpi\)_apkmirror.com.apk.

Note also: where you can run adb on may follow the same rules (this depends on other factors, like if the path with the adb executable file in is in a special directory)… For simplicity it’s probably simplest to put the downloaded apk file into the same directory as your adb executable and use that folder as your working directory.

Hope that’s some help.

1 Like

@malwes : the last command is to tell adb to install the APK package on your phone.

The com.google.something_apkmirror.com.apk in the command is actually a file path.

For the adb command to work on my Fedora GNU/Linux I needed to execute it in the folder where the apk file was stored, for example I typed cd ~/Downloads/ to move my terminal in the Downloads folder in my home.

I suppose it works the same on Windows. I have no Windows accessible to test but you might try to type something like chdir C:\Users\yourWindowsUserName\Downloads (or maybe just chdir Downloads) if your file is located inside the default Downloads folder for example, and then executing the adb command from here should work.

Hope that helps, you clearly have done the most difficult !

Edit : the previous answer by @JohnLBevan is probably more accurate than mine :sweat_smile:.

1 Like

Haha, thanks - maybe more accurate for Windows, but definitely you’re best for Linux :wink:

1 Like

Thanks both - charging cable is fine, and I’ve tried holding the button down. Looks like the battery is just completely flat, which presumably has happened because of the reboot loop thing, given that it has never had this issue before. I’ll look elsewhere for solutions for charging the battery again!

1 Like

I found some more advice here: Dictionary Entry: Kickstart - hope that helps.

OK when plugged in do you get a red LED?

Jetzt, da ich es endlich geschafft habe, so weit zu kommen, erhalte ich die Nachricht “Deinstallation von Google Play-Dienste fehlgeschlagen” und es fängt wieder von vorne an. Woran kann das liegen?

Solution 3 worked like a charm and was quick to implement. Thanks!

1 Like