Stock fp3(+) (factory reset) boot loop (workarounds in first post)

Hello @Nobody and @PTRK. I have added “Nearby Share” to the drop down menu. But the icon is greyed out. So when opening it, Google Play Services can not be deactivated. When trying to go via the three dots and choose “uninstall updates” I receive a “deinstallation failed” message. Any suggestions? Thanks a lot!

Note: I have also disabled “Find my device” in Security settings (as this was mentioned as potentially blocking the deinstallation of Google Play Services).

Hi @theos, I don’t think waiting helps your phone. In my opinion you need to fix the bootloop yourself or with a fairphone angel nearby. There is no way fairphone can fix the bootloop from the distance…


Thousands of thanks to Pilo11, @marou and @Mulder.
Your procedures saved the data on my FP3 !
I was in the same case as @Mulder.


What is the share Nearby ? Is that “partage de proximité” that I can see on your screen?
I only have:

  • WIFI
  • Bluetooth
  • Ne pas déranger
  • Données mobiles
  • Mode avion
  • Economiseur de données
  • Point d’accès

Is there an other thing to do before to get acces to this Share Nearby ?

Many thanks, I’m still stuck with these problem I can’t fix.


Yes, it is “partage de proximité” ! You can add it following the steps of this comment: Stock fp3(+) (factory reset) boot loop (workarounds in first post) - #377 by Nobody

@theos and @BGR , sorry, I really don’t know. I’ve just shared how to add the shortcut because I had to do it myself and I didn’t see a comment here that specifies how to do.
I hope you can still at least use again your phone, if you have deactivated Google Services (except Google applications like Google Maps), even if it is really boring to have all these warning notifications.


Thank you @Jonibhoni ! That’s also what @KevinC is saying:

But @BW89 says that for him the boot loop started again after getting the new update for Google Play Services via Google Play Store:

So I guess I will not reactivate the Play Store at the moment, as the issue seems not to be fixed for all users.

Yes, I was able to enter Goole Play Service.
I was also able to press the three dots and request to uninstall the updates.
But then I get a message ‘Deinstallation von Google Play-Dienste fehlgeschlagen’. Means that the deinstallation failed. And my Fairphone is still looping.

And both possibilities to deactivete or end the Service are grayed, so I’ve not possibility to do something more …

Sorry, but they were able to crash my phone from the distance - maybe there is a possibility to solve it the same way?

Maybe together with Google?

@theos Do you have an active internet connection through Wi-Fi or mobile data on your FP3? I’m asking because I found that the availability of some of these options in App Info differed on my FP3 here when it was still on airplane mode (i.e. offline). For example, the three dots were not available then.

I have read that you can access the three dots, but maybe online/offline influences the availability of other options, too.

Hey @theos
I was in the exact same situation (Greyed out options, deinstall failed) until 45 minutes ago. I was hoping my phone would update itself without any work by me, but that was not the case.
The reason is that Find my device is activated and needs deactivation. Then, the updates can be deinstalled - this would need to be done in one restart cycle (12 seconds), which is way too short.

Only solution seems to be to use ADB as written in post #181 in this thread.
I found it okay to do, but not straightforward enough for everyone. If you are stuck in the process, write me or the even more skilled people here.


For the moment all options are open. Wi-Fi and mobile data are up and running. I can see arrows showing that the mobile is transferring data.

1 Like

Hello fcpprs,

thank you for support.

For me it would be a good idea if somebody is able to describe, which tool should be used to communicate with my mobile. I’ve tried avb tool downloaded - but it’s not running on my Windows laptop … the window opend but is closed immedatly.

And for the moment there are such a lot of informations here that it would be a good idea if Fairphone will provide a short description together with all steps required to solve the problem.

As I said in one of my previous posts - not every user of a fairphone is an Android developer or a freak …

And it would be great if there will be an official statement what’s the reason for this problem is!!!

While more official tools have been recommended here usually, I recently found myself resorting to Minimal ADB and Fastboot (Windows) once again (for upgrading my FP3+ from /e/OS Android 10 to /e/OS Android 12). Just to make sure: USB debugging needs to be allowed in developer settings on the FP3.

This already exist

I think you can persist in something from Fairphone and wait or just accept the helping hands others offer you here and have it solved quickly. Your decision I guess

1 Like

Sorry, I’ve tryed already all the steps named here. But it is not working!

I really think it’s a bit arrogant of a phone manufacturer to expect their customers to deal with DEBUG tools etc. when the other solutions don’t work!

But maybe that’s how it is with Fairphone …

I’ll try to find out now, how to fix it using adb.

But I think this was my last Fairphone and I’ll stop to recommend it

Okay so I think there is the issue, which a lot of the people you call “freaks” (not very considerate btw) forget to mention or brush over too quickly:
You need to download ADB and then open a Windows Powershell terminal (go to Start and type Windows Powershell).
Then, type the line
cd [The path where your adb.exe is located]
Then, follow the steps in #181. Don’t forget to add a ’ [dot][backslash] ’ before the commands in #181. Took me a second to figure this out too. It is buried in a thread with almost 400 posts now.


Hi Nienkes, I did the workaround last Sunday so am only relating from memory. I think when I uninstalled the updates and reverted to the original Google Services, it automatically enabled again.
I am still operating in that way.

However it appears the issue with Google has now been resolved and you can enable it again and updates are now safe.

I have not dared allow updates yet- my phone tells me 23 updates pending. But other than that it’s worked as normal

Do you use the play store, I don’t, so I did uninstall it with no worries.

This issue wasn’t created by Fairphone but by an update pushed b y Google to those who have the Google Play Store enabled.

All Fairphone have doen is to support the workarounds suggested by other users.

Once the old Google Play Services that created the problem has been deleted from the phone there should be no problem as the updated Google Play Store has been corrected by Google…

Nothing at all to do with Fairphone

Impossible for me to install ADB on the computer managed by my compagny. I don’t have any personal computer to do so. And I am a remote worker.
I tried to take away the updates, but the system told me it failed.
I don’t know how to do and all the answers for the moment are for people who are used to manage technical issues.
And no assistance of Fairphone. Why the other brands are not concerned if it’s not their fault ??

I’m so tired with this.

1 Like