🇩🇪 🇬🇧 Standard Kamera App: Standorte der Fotos ca. 500 m verschoben / photos are shifted

Just done. Hope they can reproduce it.

2 Likes

Stimmt
Mit Gcam passt es. Mit Originalen nicht

1 Like

PXL_20220102_171637096.jpg
xx.841705, yy.796461

IMG_20220102_181405.jpg
xx.837837, yy.784536

Oben Gcam
Unten Original

Ab der zweiten Nachkommastelle geht es auseinander.
Navi APP und Rechnung ergeben eine Abweichung von ca. 1,3 KM

Pythagoras:

distance = sqrt(dx * dx + dy * dy)

mit distance: Entfernung in km
dx = 71.5 * (lon1 - lon2)
dy = 111.3 * (lat1 - lat2)

Die Konstante
111.3 = Abstand zwischen zwei Breitenkreisen in km
71.5 = Abstand zwischen zwei Längenkreisen in km

I’m experiencing the same behavior. I’m getting quite upset with this phone, to be honest. I would gladly just use GCam, but I’m having other problems (namely buggy selfie videos and inability to use wide lens camera), so this is not a proper replacement at the moment. I hope they’ll fix this soon.

Just a wild guess: Are there any settings with respect to privacy? Having the geo location in the pictures also means that personal data is stored, so obfuscating this a little bit could make sense somehow.

That makes no sense. Photo-Apps give the option to save location data, communication apps like WhatsApp or Signal generally do not save those data in their images.

1 Like

Is that something of q FP4? I I check the stored location of a photo with my FP3+ using the standard Google? Foto app. in maps.google.com, the locations is 25 m south of the actual location. However if I change the last digit of the stored location by 0.001 it is 40 m north of the actual location. So the indicated location is OK.

No, it’s something of the original camera app.
All other positioning is correct. Gcam, MagicEarth, OsmAnd, …

1 Like

Fairphone Support:

  • they are working on it (submitted issue to department for further investigation)
  • recommendation: keep your FP4 up to date
    :grinning:
3 Likes

As @KleinerAdmin wrote in this post, it seems that it’s fixed for him after the last update:

Does it actually work for someone else? In my case the location is still messed up.

And what’s even weirder, it usually seems to “snap” to one exact location in my area. No matter where I go around the neighborhood, the location obtained from the stock camera seems to be stuck at one spot. For some photos it jumps to a second one at the other end of the town.

Note that both GCam and Open Camera have absolutely no problem getting the correct location. It’s just a problem of the stock camera app.

That sounds exactly like the behavior of buggy UnifiedNLP providers under microG. Could it be possible, the stock app doesn’t get real GPS information fast enough and just uses wifi / bluetooth location instead? :thinking:

Since I assume you are running vanilla FPOS (without microG), what happens if you disable wifi / bluetooth scanning (or was that already off)?

Hmm, interesting. I tried disabling it. At first it seemed like it couldn’t get any location so I assumed it didn’t use GPS at all. But then I tried once again to reset the app and after I took another photo, it saved the exact same wrong location as previously. I then tried again and it jumped to the second wrong location (at the other end of the town). Now it more or less oscilates between them. Weird. :smiley:

Huh, weird indeed :thinking:
Did you disable Google Location Accuracy as well? (forgot about that)
According to the description that additionally uses mobile networks, maybe you are “jumping” from one cell tower to the other :smirk:

Just tried it. I disabled absolutely everything, even activated airplane mode and resetted the app once more. It still jumps to the same wrong location. I have no idea how it’s possible. :smiley:

1 Like

I also reported this issue a few months ago. Hopefully they will release a fix soon.

2 Likes

It should be useful to give the information
to the support that in some cases the localisation failure of the stock photo app was fixed and in some not.

For me it still works perfect, exact the same position as Google Maps.

I pointed them to this thread. I hope they will figure it out.

This seems to be fixed with the latest update! :slight_smile:

1 Like

Hip hip hooray! Seems to be working fine now, even indoors.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.