Update FP3R.A.099

I just need to reenable them.


Build number after application and reboot: FP4.FP3R.A.099.20220112
Security update still shows December 5, 2021
Play System update doesnt show stuff, but wants to reboot once more immediately. Maybe well have newer stuff then.

p.s. confirmed: after this second reboot triggered by the google play system update (app/sub-app), its state is shown as January 1, 2022. No further updates at the moment when checking security update or google play system update applets.

1 Like

Yeah, Google Play updates are fixed. Other than that, I don’t really see any improvements. I didn’t have any problem with the fingerprint sensor and it seems to me that it works exactly the same. I was hoping they would at least fix the location of photos taken with the stock camera app, but it’s still broken. I’m really curious what’s actually changed.


It would really be nice if the release notes were a bit more detailed.


Roaming was disabled for me as well, but both VoLTE and WiFi calling were still turned on.

also, the whole update experience was very strange, check here for details.

Hi, update(s) once manually started went smooth. Location data of the stock camera app seem to be stored correctly now in my case. First I switched the app permissions off and on again, same for the switch for storing location data.

Anyone else noticing that the OIS options in video mode (stock camera app) are gone after the update?

No luck in my case. I’ve tried everything, even clearing cache and storage of the app (effectively resetting the app to the default state). Location is still shifted by hundreds of meters. GCam works fine.

OIS is a HW feature. Do you mean the “super anti-shake”? In that case yeah, it looks like it’s gone. But it’s now easier to access the full range of the ultra-wide camera using the icon next to “1.0x”. Unfortunately, accessing it disables EIS and it has to be reenabled in settings. Oh my god, this is getting messy. :smiley:


Strange. My stock cameras version is v2.0.019(01101800-01).
Have you tried to reset the app to factory values? I will do further testing tomorrow and report.

I have the same version, that shouldn’t be the problem. Is there any other way to “reset” the app other than clearing its storage and cache?

AFAIK you were able to disable OIS before the update, or am I wrong? Now you don’t know if it is still enabled or not, because the respective icon is gone.

The fingerprint scanner is vastly better for me. Now when it fails it doesn’t fly through all remaining attempts almost instantly. It also seems to be much better at recognising in the first place although I wouldn’t have expected software to influence that.

The camera quality is slightly improved. Now the pictures it takes are similar to third party camera apps. Which is still very different from what you get from Gcam, but I’m fine with that.

OIS (optical image stabilization) is a physical HW feature which is built directly into the lens of the main camera. I doubt you could disable it in software. So it should be permanently on.

What’s missing in this version is the super anti-shake feature, which basically just applied EIS (electronic image stabilization) to the ultra-wide camera. Now it’s impossible to record a stabilized video using the ultra-wide camera.

1 Like

I know that OIS is a hardware feature, but it is the software that controls the tiny motors which are physically moving the camera, so I am pretty sure that this hardware feature can be disabled in the software.


That’s correct, but on most phones it’s just baked into the firmware and it cannot be disabled. I don’t think the previous version of the camera app had such option. The only thing I’m missing is the super anti-shake.

Is there anyone in this thread who hasn’t updated yet? Could you tell us whether there was an OIS toggle?

I wouldn’t like to jump to conclusions, but it seems to me the camera finally started using the lidar for focusing. Before the update, it seemed to me it re-focused a lot in bad light. Now focus seems to be rock-stable (and very bad when I cover the lidar with my finger).


Last option in menu.

Yeah, you’re right, it’s there. I’m blind. But unfortunately, it still doesn’t work. I even tried opening Google Maps on an external display to make sure the location is correct at the moment I take a photo. But the stock camera app still manages to get it wrong. :smiley:

Hi Razem, I performed several tests. The stock apps location data are now exact. I walked along some streets taking a photo every 100 m.

Did you

  • restart your phone?
  • set, reset, toggle all relevant options?
  • update both FP OS and Google Play system update?
  • set location to high accuracy?