Update FP3R.A.099

Strange. My stock cameras version is v2.0.019(01101800-01).
Have you tried to reset the app to factory values? I will do further testing tomorrow and report.

I have the same version, that shouldn’t be the problem. Is there any other way to “reset” the app other than clearing its storage and cache?

AFAIK you were able to disable OIS before the update, or am I wrong? Now you don’t know if it is still enabled or not, because the respective icon is gone.

The fingerprint scanner is vastly better for me. Now when it fails it doesn’t fly through all remaining attempts almost instantly. It also seems to be much better at recognising in the first place although I wouldn’t have expected software to influence that.

The camera quality is slightly improved. Now the pictures it takes are similar to third party camera apps. Which is still very different from what you get from Gcam, but I’m fine with that.

OIS (optical image stabilization) is a physical HW feature which is built directly into the lens of the main camera. I doubt you could disable it in software. So it should be permanently on.

What’s missing in this version is the super anti-shake feature, which basically just applied EIS (electronic image stabilization) to the ultra-wide camera. Now it’s impossible to record a stabilized video using the ultra-wide camera.

1 Like

I know that OIS is a hardware feature, but it is the software that controls the tiny motors which are physically moving the camera, so I am pretty sure that this hardware feature can be disabled in the software.

2 Likes

That’s correct, but on most phones it’s just baked into the firmware and it cannot be disabled. I don’t think the previous version of the camera app had such option. The only thing I’m missing is the super anti-shake.

Is there anyone in this thread who hasn’t updated yet? Could you tell us whether there was an OIS toggle?

I wouldn’t like to jump to conclusions, but it seems to me the camera finally started using the lidar for focusing. Before the update, it seemed to me it re-focused a lot in bad light. Now focus seems to be rock-stable (and very bad when I cover the lidar with my finger).

4 Likes

Last option in menu.

Yeah, you’re right, it’s there. I’m blind. But unfortunately, it still doesn’t work. I even tried opening Google Maps on an external display to make sure the location is correct at the moment I take a photo. But the stock camera app still manages to get it wrong. :smiley:

Hi Razem, I performed several tests. The stock apps location data are now exact. I walked along some streets taking a photo every 100 m.

Did you

  • restart your phone?
  • set, reset, toggle all relevant options?
  • update both FP OS and Google Play system update?
  • set location to high accuracy?

I’m slowly starting to get annoyed by the pace at which the security updates are getting released. The next Android Security Bulletin is just around the corner and we are trailing the current state by almost 2 months now. From a security perspective, that’s not acceptable.

My Nexus 4 has been running Android 11 with the current patches for three weeks now, that phone is almost a decade old (even older than the first Fairphone) and only supported by 2 people in their spare time.
How does this beat a professional development team?

It’s nice they are working on improving the camera, but I’d much rather have a phone that’s up to the current security standards first… :roll_eyes:

6 Likes

Yes, of course.

  • No change after restart.
  • Tried resetting all options multiple times. Still nothing.
  • Security update is 5 December 2021, Google Play system update is 1 January 2022.
  • Google Location Accuracy is turned on.

When I check my location in Google Maps, it’s correct. When I take a photo using GCam, it’s also correct. But when I take a photo using the stock camera app, the location is shifted by hundreds of meters. Not even once did it manage to get the correct location.

And what’s worse, sometimes it doesn’t even store the location at all despite the fact that the option is enabled. The app needs to be killed and opened again.

Very strange, I will do further tests.

Just now confirmed 40 km away from my home. The coordinates are perfect. If you ask support they will suggest a factory reset I assume. :frowning:

It’s possible that they will. But I’m not doing that. :smiley: I already did a factory reset once because of other problems and it didn’t solve almost anything. (Then they replaced the phone and it also didn’t solve anything.) I pretty much doubt it would solve this issue because all other apps have no problem getting the correct location. There must be a bug in the app itself.

I just hope that they will soon enable access to all the camera features through the Camera2 API (wide-lens camera, ToF sensor, 48MP photos, 25MP selfies) so I will be free from this monstrosity of an app.

1 Like

Where can I find the release note for the current update?

Steven

Eventually here: https://support.fairphone.com/hc/en-us/articles/4405858220945-FP4-Fairphone-OS-Release-Notes. But so far nothing.

3 Likes

we need high speed and immediate security updates please

Boletim de segurança do Android — fevereiro de 2022  |  Android Open Source Project

This is a user forum so no influence in this from our end.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.