Software update: FP4.SP21.B.048.20230215

Thanks, that works perfetly (for now)


  1. it moves the volume all the way down,
    2)it does not take a screen shot
    3)even if it did, I don’t want to spend my life waiting, it should be instantaneous.

sounds to me like you’re only holding the volume down button, and not the power + volume down combo. the one second delay it takes is in order to prevent accidental screenshots.


Please keep in mind that showing the seconds could affect battery time since the phone is forced to redraw parts of the screen every second, which likely also prevents the processor to switch to a lower frequency.

I can’t tell you if this really is relevant and makes a difference, it depends on just too many factors. That’s why I just say “Please keep in mind”, so anyone enabling this may remember it if the battery time decreases afterwards.

I definitely held down both, I know what that means.
I tried again. It’s very difficult to do because of the protective case I’m using.
But it does work and there is actually almost no delay. However, as said, it is very difficult and if the buttons are not held exactly at the same time, it fails. I don’t want to take the protective case off of course.
So it is as good as unusable in my case (no pun intended), because in 80% of the cases it fails, and when it fails it either switches the phone off or sets the volume to 0.

But thanks.

1 Like

I don’t think it is relevant: it should happen only when the phone is on.
1Hz is a quite low frequency.
However, what you say may be the reason why the manufacturers don’t display the seconds.

Short update from my side concerning problems with speech recognition:
I had to deactivate the “Android System Intelligence” system app. Afterwards it seems that google engine is again really the default one (as Android SI seems to have been kind of hidden default one).
Now my automate flows work like a charm with other than US English language.

I reported this also to FP support. Hopefully they think about this edge case for the next update.

This is a new Android 12 addition. Google’s Pixel phones use “Google Tensor”, a processor which was initially intended as an accelerator for neural network machine learning (what marketing calls “AI”…).
As a smartphone chip it is rather unremarkable, which is probably the reason Google is injecting heaps of machine learning (“AI”) into Android, to give its processors a competitive edge over the competition…

“Android System Intelligence” is such a solution in search of a problem, sort of super-Clippy which observes 24/7 what you do (collecting all sort of useful marketing knowledge :smiling_imp:), and then takes initiatives, doing for you what it thinks you wanted to do (or rather what Google’s marketing thinks you should want to do)…

Unfortunately there is no “artificial intelligence”, there is only natural stupidity, and this will most certainly end in tears… :roll_eyes:


This data is stored and kept offline, such as quick suggestions for messaging, automatic quick shortcuts, keyboard improvements, adaptive brightness, image processing (until you upload it yourself to the Cloud of course) and many more.

Might be, although Google clearly states that although ASI is local, “Private Compute Services provides a secure bridge to the cloud”. So, apparently ASI does need access to Google’s “cloud” (fluffy name for “servers”), and it does that through PCS (which, having “Private” in its name, is highly suspect!)…
Anyway, whatever it is, Google being Google it is clear they will eventually “monetize” this. :smiling_imp:

Also, going through the features, besides the automatic translation I don’t see a single feature my Samsung Note 2 didn’t already have (in some form) 15 years ago, except of course some features I’d rather pay not to have, like “suggestions” (I rarely if ever do not know what I was about to do, so I don’t need some dumb Clippy bothering me with its silly remarks).
“Android System Intelligence” is another perfect example of “AI” being mostly hollow, meaningless marketing buzzwords…

1 Like

The Quickstep Launcher still causes problems. I’m having a hard time believing that these problems are hard to fix. The minimum display brightness is then turned down via update instead of correcting the error.


The launcher still has the problem that the header is displayed in the wrong color if you have previously scrolled down and started an app and then minimized or closed it. Then the header suddenly appears gray instead of black.

similar problem with light mode too. The header is also displayed in the wrong color here.


Darkmode colors are still wrong. white writing on a light blue background is just not legible.

in the bright mode, the contrast is as it should be.

I don’t think it’s rocket science to just match the colors. Please fix the problem! Please! This is your business card and the first impression you make.

1 Like

I’ve just updated my FP4 to Android 12 FP4.SP21.B.048.20230215 and I’m interested in how you managed to extract the boot.img via recovery. Could you please let me know?

Would it be something like the following?

         adb shell
         dd if=/dev/block/bootdevice/by-name/boot of=/sdcard/boot.img
         adb pull /sdcard/boot.img stock_boot.img

Do I require TWRP installed?

Yes, the commands are fine. I extracted /dev/block/bootdevice/by-name/boot_a and /dev/block/bootdevice/by-name/boot_b just n case. In fastboot mode you can check which is the active slot first to minimize the effort and then boot the TWRP image via fastboot. No need to install the recovery.

1 Like

Thanks @Lars_Hennig , do I need to boot TWRP at all or will adb shell not work without it?

You need to boot something that has root access in order to access the partition with the boot image. You could also use the recovery image from LineageOS and boot it with fastboot.

Thanks for your help I managed to get TWRP installed and my FP4 rooted with Android 12, all working nicely now.


I hope you didn’t actually flash TWRP, otherwise you’ll have to restore the stock recovery (and boot anyway of course) before you’ll be able to install the next OTA.

Keep that in mind if your next update fails.

The latest factory images are already available BTW, no need to mess with TWRP or otherwise dding partitions from a running system.
I mean it’s a great learning experience, but the boot.img is right there for the taking :nerd_face:


Already installed! Everything works great! Thank you!

1 Like

I did flash TWRP, I tried a few times to ‘flash boot twrp.img’ but it would just freeze and I would have to hold down VolDown + Power to reboot. Is there a trick to booting TWRP?

Are suggesting I flash the whole stock image on with the following instructions;

No, you don’t need to flash it.
Just download the factory images, extract the archive and the boot.img you wanted is right there :slightly_smiling_face:

Can’t help you with TWRP, I don’t use it, sorry.
Since you flashed it, you might want to hold on to the factory images you downloaded, because you will have to flash stock recovery before you can update to the next OTA.