Software update: FP4 A.13 MR6 FP4.TP2G.C.0119.20240509

I use Nova Launcher since I got my FP4 a year ago.

Never modified the OS apart from normal updates, also didn’t activate the developer tools till I had to reset the animation speed.

I didn’t install any new software before the error happened either. The only app that updated on the same day was Open Camera, but can’t tell now if that was before or after the issue.

I am wondering if the change may have been made by the FT4 update but then was triggered by something else. I didn’t restart the FP though, and changing the animation speed in dev tools didn’t require a reboot. So could be a wrong direction.

I remember that it happened over night, in the evening it was fine and the next morning it suddenly was slow. I remember that around that time also the Google alarm clock app changed appearance, but don’t think it was exactly the same day. The alarm is the only app that runs over night besides the podcast app AntennaPod, again could be the wrong direction of thought.

Definitely, else it would had happened to everybody.
A potential culprit is the launcher, since almost everybody who has this problem has/had changed the default launcher. :thinking:

When was that? (On mine Open Camera last updated on June 6th.)

:open_mouth: That one hasn’t updated since April 4th. It didn’t really change appearance either, IIRC. What do you mean by “changed appearance”?

But the “evening” thing is probably interesting, because it means there is some automatic housekeeping process which triggers this (as opposed to some installation overwriting the wrong settings).
What does your Google alarm clock look like now? I wonder if its “change” hasn’t something to do with the animation settings’ change (like, same cause triggering both).

Sorry, I couldn’t figure out how to quote, I’ll try without.

With caused by the FT4 update and triggered by something else I wanted to raise the question if this is even connected to the update at all. It seems strange though that FT4 users experience the problem, but it was difficult to find this thread and maybe there are other Android users out there with a similar problem.

The problem happened to me on the morning of 13th June. In my update list in Google Play I see only Open Camera updated on that day. There were 2 updates on the 12th, a local taxi app and RinGo parking. There may have been more, if an app got another update since then I wouldn’t see it.

My Google Clock app got the update on the 2nd April. The appearance happened to the way I deactivate the alarm, previously it was a slider with two directions for deactivate or snooze, then it changed into two buttons for the two functions. I don’t see an option to configure that in the app, also the change happened without me doing anything to the app.

Just select the part of the post you want to quote, and the option will pop up over it.

Well, all we know is that it didn’t happen before that date. But you’re right, correlation is not causation. Could be a coincidence.
As for it being a general Android issue, one internet search should clear that up. :man_shrugging:

Was it? AFAIK it has been 2 buttons for quite a while. But then again April is already some time ago, I might have got used to the new style since (I use it all the time, not only to wake up in the morning, but also to remember things during the day).

1 Like

For me it changed certainly much later than April. Thinking about it more I think it changed around the time I installed the FT4 update which was when I went on holiday end of May, soaybe it needed a reboot to change?

Anyway, I guess the only useful I can contribute that we know for sure is that the animation speed change happened over night.

The problem with Google search was that I only got results on how to change the animation speed rather than ones related to the issue. Only adding Fairphone braught me here.
I now tried again to search in the last month only, that worked a bit better and I got lead here without mentioning Fairphone. So I guess it is safe to say that it is only related to Fairphone.

I also found a Reddit that is related: https://www.reddit.com/r/fairphone/comments/1dfw496/ff4_suddenly_slow/
The person says it happened for them over night as well, they noticed it in the morning of 14th June, so a day later than it happened for me. They also use Nova Launcher.
Another person there said it happened to them twice in 2 days and that they don’t use any custom launcher.
Someone there suggests it could be a Google Carrier Services update again, they don’t give a reason, did that cause issues before? But it did catch my eye before as well as it was updated on my FP4 on the 11th June, so 2 days before I noticed the change.

Unlikely, because that would affect everybody. It has to be something specific to some people, as opposed to all. My animation speed never changed, for instance. :man_shrugging:
Let’s wait for others to chime in.

2 Likes

Same here with the animation speed issue. Happened already two times out of a sudden. But not directly after the upgrade. I did already several reboots in between.

Using Microsoft launcher, phone is not rooted.

me too,
no issues so far
:man_shrugging:

One month after release and still no update available to me …(Swisscom in Switzerland)
Are there other carriers as well so slow?

Here Swisscom too (ok M-Budget but same?)

What is this bad update policy? What’s going on?

Welcome to the Fairphone community.

Did you ask Swisscom already, why they are possibly holding back the update?

Thanks a lot. I had the same annoying behaviour, but didn’t know how to solve it!

Having the same issue with the slow animations. Tried so many things before I found this thread.

Has anybody already contacted support about this?

Hi, i had this issue too.

I had this once after the update, but it did not re-occur after fixing the settings in the dev menu.

Just for the record:
The alarm can show as a slider OR as two buttons.

  • On the Lock Screen (i.e. the phone was locked at the alarm time) it’s a slider.
  • In all other circumstances (Home screen, an app …) it offers two buttons.
2 Likes

Animation speed just changed again for no reason from 0.5 to 2x. Just after unlocking the phone.
Just to mention it as this is no “you have it 2-3 times after the upgrade and then its gone” issue.

Original OS/Launcher?

See my post some messages above :wink: : Microsoft launcher. But looks to me like this is happening at others too.