Software update: FP4 A.13 MR6 FP4.TP2G.C.0119.20240509

Oh thanks a lot for this information!
My phone got very slow after the update BUT not directly after it - some days and restarts later it got slow.
Had never changed this value in the developer settings but the value after the time above was set to 2.
I’m using Lawnchair as Launcher.

1 Like

Huge thumbs up, that was the issue! :+1:

I came to this thread after I noticed a sort of opening vignette effect when unlocking my FP4. This only started after the update. Nova Launcher, animations disabled, dev options all animations off.

Just on a hunch I tapped the power button off while in Dev options then unlocked it open again. Vignette opening and now all the animations are showing 2x scale! Went out of Dev options, back in again, all animations off (?).
Restarted phone and went to check again, same thing, still vignette effect on unlocking.

I’m not happy that a minor update has had an effect on something that is usually untouched even across main android version updates.

Usual link to the ota.zip in case someone needs it :slightly_smiling_face:

1 Like

Yes, I think this arrived with Android 13. Sort of blurry white circle zooming in when you unlock the screen, isn’t it. Oh well, I personally think it’s useless and looks silly, but it doesn’t bother me, I’ve got used to it by now. :man_shrugging:

As about the animation factors changing from 1 to 2, it definitely seems like it affects only people using a different launcher. Probably something not standard in the way that update handles something, and Fairphone devs tested it with Quickstep but not with other launchers. Well, it’s a minor issue since it’s so easy to fix, the only problem is knowing about it.

So, I did change the animations to 0 a couple of times now, but it always resets itself to 2. I use Nova Launcher,
I don’t know when or why it resets, but I think it happens when charging?

1 Like

If you have time to waste, I would go back to the original default launcher, and check if and what this changes.
If it automatically changes factors back to 1, and then automatically goes back to 2 when returning to Nova, it means this version is incompatible with Nova launcher (and you’ll have the joy of being the ball on a “it’s not us, it’s them!” table tennis game…). :laughing:

There is a slight chance though you can set animation to 1, and it will stick when going back to Nova.

1 Like

It will probably not work with the animation settings in the dev options. At least for me it doesn’t. Anyway it could help changing the animation style in Nova settings or switch of animations completely, there.

Same happened to me, did the update a couple of weeks ago but only today the animation factor changed and after some research found that it suddenly was set to 2x in the dev settings. I never changed the dev settings before.

I am using Nova Launcher, but the last update there was on May 20th, not using the beta version.

Very strange, thought even that I had some malware issue but couldn’t find any when scanning with apps. Others describing the same issue calms me down a bit, even though the cause isn’t clear. Thanks for those posting here.

Hi, I had the same problem!! Had no idea why everything was so slow all of a sudden (it really felt as if my phone was unusable) but your comment helped me fix it! Thanks :slight_smile:

It made me reset my phone, but still I cannot use wifi, and I’m sure that mobile won’t be able to be turned on after turning it off once. reboots didn’t help, just with a full reset I was able to at least have data. Bluetooth might be problematic too (no audio).

Edit: I posted a topic here, any help appreciated Can’t turn on Wifi or Mobile Data after update root

I had the same issue a few days after updating my Fairphone 4. All window animations were suddenly slow. I’m using the default launcher.

I followed this tutorial, which solved my problem: https://www.zdnet.com/article/i-changed-this-android-setting-to-instantly-double-my-phone-speed/

All my window animations were set to 2x. After resetting them to default (1x), everything is back to normal.

3 Likes

Yes, that is what fixes the problem.
Anyway, it also seems the none default Launchers like nova set it back to 2x eventually

Yep, noticed this, too. Don’t know why it happens either, as it seems extremely inconsistent.

I had this curious behavior as well. But only after some further reboots. It was still OK the first time the new system started. Then I rebooted the phone once more a few days later and suddenly the animations were slow. I changed it as described above and I’m also using the Nova launcher.