Software Update: 3.A.0129.20210805 (unknown caller and zero brightness bugs)

If I (on /e/, not Fairphone OS) go to Settings - Display - Adaptive brightness, along with the switch to toggle the feature on and off it just says

“Your screen brightness will automatically adjust to your environment and activities. You can move the slider manually to help Adaptive brightness learn your preferences.”

Edit: Screenshot thanks to @amoun’s quick reply below …

I don’t see anything installed resembling Display Health Services, I think this is just implemented in Android as is. The default behaviour might still be tweakable by Fairphone’s software partner, though, but I don’t know.

2 Likes

It seems to to be the same on FOS :slight_smile:

OK :smiley: here’s the screenshot of the Settings > Display option

The top slider bar is only visible once I have tapped on the [Brightness level (64%)] This is the level I set to able to read well in the evening with a 3watt LED 2 metres away. Lower than this is not really much of an option unless it’s pitch black around me.

1 Like

Yes, I just updated the other day (28 aug. and did both the system and the security update) and I notice this too. It randomly goes to “low” but also can go back to “normal auto”. :anguished: I bet it has to do with the new “minimum” - I guess “the history of learned settings” is reset? Things do seem to smooth out while I’m using it more and more now…

Some will call it a feature, but I call the behaviour (what I call the reset) a bug, because when you update the phone, these changes aren’t mentioned, therefore: unexpected behaviour.

4 Likes

Yeah, let’s agree on unexpected behaviour, which nobody wants to have.
I’m afraid the lack of a detailed changelog for the updates or an issue tracker doesn’t help with this.

4 Likes

To me it seems like the sensor restarts all the time. You can set it to 10% all you want, after a few minutes it goes back to 0. Very annoying. Only does this in fairly dark circumstances.

1 Like

10% is very low. I tried 19% and that didn’t work. On 64% ( a random number) it seems fine and I will reduce it ~ slooowly ~ once I’m sure it’s stable. I’ll give it a couple of days.

Only a developer will know the reason why the basic brightness can be so low that the controller can no longer be recognized after a restart?

Hi @fpdream Welcome to the forum.

RE Your comment. The developer who worked on the procedure may well be the most enlightened on the issue but many other people with a decent software ability and time on their hands may be able to understand.

But it may not be that simple even for the developer of the procedure to work it out.

Hopefully it is just a learning issue and will all be fine in a few days.

Thanks for your input.

I look forward to an official answer. For me it’s a software bug.

2 Likes

I’m checking the Ambient light sensor

a) it is reading zero when I can still read without a light
b) the lowest setting I have is ignored and the screen is darker than the piece of paper next to it.

Will try and set the value via the slider, again. Ok I have set it at 41% will see what happens. :woozy_face:

@aboloo I have the same issue with the brightness.

Yeah, I also want to +1 this. I have the same issue since the last update.

When ambient light is low, screen brightness used to reduce, now it immediately goes to lowest setting.
This happens already in a lit room. It makes the screen barely readable.

1 Like

Just to add It seems to occur each morning and each evening. When the ambient light goes beyond a certain level (and inappropriately reads zero) the screen light drops to zero.

Although this has occurred since the latest update it is a clear single issue and am starting a new topic.

1 Like

Got the update Sunday in the US on T-Mobile. Things seem to be working out pretty good!

1 Like

Hi @rae Just to ensure you have read the reports of the problems with the ambient light sensor not working well with the auto brightness feature I have made anew topic to collect user experiences of that as a single issue.

3 Likes

No update available with Sosh in France yet…

1 Like

Hi everyone,

Thanks for flagging and for sharing your experiences here. Our team is currently looking into this and will provide an update as soon as possible. In the meantime though, you are able to turn this feature off by following these steps: Settings > Display > Adaptive brightness > Off

Thanks also to @amoun for creating a new topic. I will share this internally too. :slight_smile:

15 Likes

Since this update, all incoming calls are displayed as “unknown”. I know there has been the same issue about one year ago, I did not have problems with that until now. When I disable 4G the caller’s names are displayed. Anybody experiencing the same issue? (Edit: using Vodafone in Germany)

1 Like

It might be related to VoLTE. Which provider do you use? (Edit: Ah, got it, thanks!)

Yes, I think so. Unfortunately I don’t have (or don’t know of) an option to disable VoLTE, I just have the option to disable 4G, which is not an option for me as 3G is no longer available in Germany.

2 Likes