SIMs not recognized anymore when switching mobile data to SIM 2

I have 2 SIM cards in my FP2 running LineageOS 14.1 from Oct. 4th.
When I try to switch mobile data to SIM 2 both SIMs are unusable/not found by phone. Even after a reboot the SIMs are not detected. When switching back mobile data to SIM 1 everything is fine. It does not matter which of the SIMs (T-Mobile Germany and Vodafone Germany) is in which Slot.

I have opened a bug report at FP LineageOS Bugtracker

The same problem happens here. After changing mobile data from sim 1 (default) to sim 2 the FP2 telefon app is not usable any more. Maybe a reboot helps? After that FP2 does not accept sim pins. It is possible to enter sim pins endless without a count restriction. Restart FP2 with one sim first so the default sim config is restored. Shutdown and put the mobile data sim in slot 1 and the other sim in slot 2.

–> Two sims work only if mobile data is on sim 1.

Lineageos 14.1-20171004-Unofficial-FP2
Baseband 4437.1-FP2-0-07
Provider: Switzerland, Swisscom and Sunrise

1 Like

Same for me.

Switched my SIMs and have only SIM1 on data works as a workaround for me, but a fix would be nice :wink:

Yes, same issue here. Multi Sim settings seem broken on lineage. I don’t think this is a device or Fairport specific bug.


1 Like

Got a question it it is “Stil there in version 20171024?” in Bugtracker. Does anyone have 20171024 in the updates? Me not, 20171016 is latest.

Tried again with 14.1-20171016-Unofficial-FP2: same result, not fixed yet.

Found and updated. Problem remains and got worse, just updated the Bugtracker with:
“Updated to nightly 20171024 and it still happens and it even got worse.
Now when switching mobile data to SIM 2 both SIMs are not found by phone. Even after a reboot the SIMs are not detected. When switching back mobile data to SIM 1 the SIMs are still not found by the phone, now you need to reboot again to get a working phone.”

Yes, I confirm that sucks. I don’t have a fix.


1 Like

Have it since weeks. It didn’t find a way to fix it. Fortunately I don’t need my second sim, because the sim slot 1 is not recognized somehow. Have my main sim in the second slot in which it works without problems. Bit annoying but OK…

This should be fixed in the next “weekly” build.




This bug is fixed with 20171114 update.
I have some other problems with switching mobile data connection from one SIM to the other but I need to do some further tests as I have a very bad mobile connection here and want to exclude this as the problem. I will open another thread if the problems stay when I am in a location with better connection rates.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.