Sdcards started getting corrupted a few weeks ago

Hi all ^ _ ^

I’ve had a FP3 since launch, running LOS 18.1 on it, has been smooth sailing until a few weeks ago (no idea if it coincided with an update) when I was greeted with a „Problems with SD card, tab to fix“ notification.

Made a backup, formtatted the card via the system dialogue, same message a few days later. It says the card is corrupted in settings, seems to be working fine when mounting on a PC.

Some bulletpoints:

  • I’m always using the SD cards as external storage
  • Original SD card was working perfectly for years, was a Sandisk Ultra 64gb
  • New SD card is a 128gb Samsung Evo Plus
  • Tried formatting them with a PC as FAT32 and exFAT, no luck (haven’t tried Ext4 with Linux yet)
  • Haven’t really tried to clean the SD card slot (how would I do that?) but it looks fine

Any ideas what might be the issue/what I could try?

I’ve seen that people have similar problems on the FP4 and it seems to be a software issue, might this be the case here as well?

Have you thoroughly ruled out that the SD card itself is actually broken? Formatting might make it look for a while as if there’s nothing wrong - until the broken cells are used again. I had a similar corruption issue with an SD card a while back.
One tool you can use on Windows to test would be this one: H2testw | heise Download

In general: Don’t expect too much of (micro)SD cards. The question is not if they break but only when


I’ll checkt that out, thanks! I find it worrying though, that this issue persists with different SD cards from different manufacturers. But sure maybe it’s a super unfortunate coincidence …

Well, H2testw did not like my old SD card at all but it ran the test on the new one without problems. I also formatted it to Ext4 which Android cannot read?

Reformatted it with Android again and now (a few days later) it’s corrupted again +__+

Any other ideas? I think I’ll try to format it with another phone but I don’t think it’ll change anything.

Just a general note. I have 2, 4, 8, 16, 32 Gb cards that are 6 to 10 year old and never had a failure. My 64 and 128 are less than a year old so, ??

However the 64 and 128 are used on a Raspberry Pi Client and Server, running the OS and storing all data?? Sandisk Ultra

In very rare cases, Dead on Arrival may happen.

1 Like

Yeah, I thought about that as well I think but that’s highly unlikely at this point. I forgot to mention that I found another SD card in a Raspberry (64gb, I think?) and tried that and it got „corrupted“ as well. I’m pretty sure this is either a software problem or a problem with the SD card slot … +__+

1 Like

In that case I would agree with you

I got a quite similiar problem with my SD card in my FP3.
Every around half a year I get a notice from my phone: “SD card not formatted. Do you want to format it now?” or something like that.
And then no matter what, the phone won´t recognize any data from the SD card until I have formated it and put the data on the card again.

Sorry to hear that. I’ve given up on trying to fix it as I’ve no idea what else to try. Ugh, now that I think about it I want back my offline Wikipedia / Wiktionary etc +__+

Hi @Freigeist and @jfml

I just want to clarity : do you each have the SD card formatted as Portable with the eject icon to the right of it?

Settings > Storage


1 Like

Yes, my card is formated as external.
Right now I´m waiting for the next time the card will be corrupted. By the way: I´m using /e/.

Not exactly related to this, I have the problem with missing writing rights on the card. I can´t change this neither with the Ghost Commander (I have activated the check for the root privilegues in the Ghost Commander settings), nor with the build in file browser. And for a while OSMAND gives me I/O errors when trying to update the maps (saved on the SD).

1 Like

Yeah, I’m trying to use the card(s) as portable storage as well, I’m aware of the fact that extenting the storage with an sd-card can lead to all kinds of problems (though it would be super sexy not having to copy stuff between disks).

1 Like

This was recently an issue on Lineage OS so not sure if e/OS has the same issue and/or is not yet updated?

And the workaround here


I got the latest stable version of /e/ version Q (Android 10). I was waiting for the Android 11 stable, hoping this solves the problem. :sweat_smile:

I´m trying that workaround now. The app is now copying the files to the new folder - which is strange since in the end it´s the same one, just picked manually. It shows me one file (map) after another but always on 0% progress (I hope this is just a little bug in the progress bar.).
I´ll give an update when it´s finished.

I get the updates for the maps now, but strangely for the live update it still gives me an I/O.
I need to try if the GPS does work in OSMAND again (number of visible satelites stays on zero, even if I can see at least on satelite with a GPS check app).

So, this is the status now:

I was able to update all normal maps, but the live update still gives an I/O.
The GPS still seems to be not working, but it did before the last small update on /e/, so this might be related to the OS or to Osmand itself.

There is still the option for reinstalling the Osmand but I need to make a backup of the Osmand files first. This is difficult, since because of the missing writing rights, I can´t just copy the files on the SD card.
I´ll make a backup from SD to my computer tomorrow and try to reinstall Osmand.

But as always:
If you have one problem and are searching for a solution, you´ll stumble at least over three other problems, which you need to fix before you can start fixing the first problem… :face_with_spiral_eyes:

Did you have a look at this topic?


Just so you know Osmand now has a backup option unter Settings, that you should also be able to mail to yourself or share to other apps if I’m not mistaken.

I think it worked for me, but it is a bit weird sometimes (I think I had to manually rename the extension of the exported file so that Osmand could see it again for importing or something?).

1 Like

The advanced privacy was the problem! Thank you for this hint!

1 Like