Lineage 18.1 - finally official

Replying to myself: Is there really no one else using a FP2 with a current LOS 18.1 and Osmand with maps on the SD card? Can anyone confirm if the change that I found could be related to my issue. If it is related, what would be a good way forward to have my maps back in the SD card again?

Replying to myself again. Seems like not only the FP2 is affected and it seems like other people found where to post such things… :roll_eyes:

1 Like

Hey @Martin_Anderseck , sorry for the late reply. I had also some trouble when I moved from Lineage 17.1 to 18.1 with osmand~, as I wanted to prevent to download all the maps again. I set up my FP2 clean from scratch and as soon as 18.1 was running and the device was encrypted, I restored all my apps data with GitHub - NeoApplications/Neo-Backup: backup manager for android (v7.0.0 that time). All went well, but some errors were shown for Osmand~ after starting it for the maps. I tried to manually fix that by setting up a new folder on the SD card (backup up the initial one before manually → copy to PC) and overwrite the content of the new one after re-configure Osmand~ from scratch. But on that way, I somehow lost my favorites (marked places) etc… (maybe if I would have been more patient to 100% understand, where the Osmand~ favorites are save there might have been a solution - anyway)

If i remember correctly I finally restored the data as already explained and configured a new directory after the first start (I think it offers a migrate to new directory option). The maps were lost, but I now download them step by step when I need them.

No issue with using “External storage 2” which is my 128GB A2 SanDisk Extreme SD. :thinking:

PS.: For simple navigation I use this now:
Which I think finds a route quite quickly and is not that feature rich (people tend to say “overloaded”) like Osmand.

Thanks @Smojo for your reply. However in the meantime I found the change in LOS that causes issues not only on FP2 but on many other phones, too. This is not a general thing that comes when changing to LOS 18.1 and where you just have to set something correctly but it is just impossible with that specific change:

Ah, I’m running a build before 20220415 probably this is the reason why I did not face the issue yet.

I found a solution, you could use the manual path sdcard/Android/data/, which is working fine for me after updating to the latest LOS build.

Also see here:

1 Like

Awesome, that did the trick, even though the correct path was sdcard/Android/media/ I had tried the other one (data instead of media) a few times without success, but now I can have maps available again without worrying too much about the memory.

The storage issue should be fixed now.



Quite late to the show, but anyway: two days ago I did a complete backup of everything important from my FP2, wiped it and did a clean install of LOS 18.1 w/ microG.
The battery life has improved a lot (most probably due to the clean install) since then. Now my hope is back that my FP2 will last till FP5 (or at least FP4+) will be on the market.

Thanks a million @chrmhoffmann for maintaining LOS for FP2 over all the years! You really rock!


@chrmhoffmann Is there any chance to get exFAT support for external SDCards integrated for our FP2? I tried to insert an exFAT formatted SDCard and it’s shown as damaged and LOS wants to format (as FAT32 IMHO).

FAT32 has that 4GiB limit, which exFAT doesn’t have… for my large Signal backup this is a show stopper :frowning:.

Best Regards,

There were recently some Commits related to file systems for the external SDCard. I tried to use F2FS which is recognized but has some problems. I already reported this to LineageOS bugtracker: Problems with Android folder (+ subfolders data and obb) on SDCard after recent file system commits (#4881) · Issues · LineageOS / issues / android · GitLab
@chrmhoffmann Could you (and others) take a look or try to use F2FS as SDCard filesystem?


Did you or anybody found a solution to keep root during a LOS update?

No, I never managed to solve this.

1 Like

The display of my FP2 doesn’t turn on when I plug in a cable/charger. The option is enabled. Does anybody else experience this? Is it a known issue or a wrong configuration which I can change somewhere?

Anyone who played around with other FS than FAT on SDCard?


Yep, ext4 here: Use a different format for sd-card as portable storage (ext3, ext4, extfat)

Works for me !

lore ipsum

1 Like

My employer requires me to use my phone for passwordless authentication with the Microsoft Authenticator app in the near future. While MFA has worked with LOS 18.1 on the FP2 so far, my phone fails to setup this last step towards passwordless authentication, namely the “phone sign-in”. In the last step (similar as explained here: Enable and setup passwordless sign-in with Microsoft Authenticator app - Just another Cloud and PowerShell blog) I get an overlay telling me “This feature is not supported on your device” and so the overall step fails. I could imagine it is something similar as with some banking apps which complain about rooted devices (which my phone isn’t).

Does anyone have experiences with a similar setup?

Unfortunately the app is not really verbose, so it’s pretty hard to say what the actual issue is. If it was any (wrong) complaint about root I would expect it to pop up at the very beginning when starting the app. As a last resort before quitting the job in this company ( :wink: ) I’ll try switching to FPOS, but actually I was happy with LOS…

PS: With colleagues I’ve been discussing Android emulator on our computers, but I read that the Authenticator might not like that, either…

Dont understand a lot about MFA so maybe a dumb comment: what about using e.g. Aegis instead of Microsoft Auth App?


Nice idea for everything that works already, but not for the proprietary feature “passwordless authentication”. Therefore I asked for experiences with this specific feature.
Today I learned that a colleague of mine has all this magic running on an unfair phone which is rooted. That makes it even more strange that it doesn’t want to work with my FP2…