Camera does not work after transferring pictures to SD card, nor does downloading picutures

I used FP3 for about half a year and now it told me that the internal storage was full. I tried transferring all the pictures and videos to the SD card manually, as I was unable before to tell the FP3 to store all pictures and videos there in the first place.
The result is that now all pictures and videos are gone (in settings - storage I cannot see them neither in the internal storage nor on the SD card - on both of them theres plenty of room now though). Also I cannot download content (pictures, videos, voice messages) from Whatsapp, and also cannot use the camera (both usual camera as well as screenshots) :frowning: If I try taking screenshots, the FP3 tells me it cannot take a screenshot, due to the full storage.
I have no idea how to get my pics back and to get the phone back into functionality. Anybody any idea what to do?

1 Like

Please clarify how you formatted the SD card.

1 Like

Hi, thanks for the reply. I am not quite sure how I did it, remember only that I searched quite for a while until finding what I thought was the option to transfer data to the SD card manually (may have been in the picture gallery or the settings app, sorry that I don’t know any more).
But the problems of the attached post are exactly the ones i am facing now, so I suppose I accidentally formated the SD card as “internal storage” :frowning:
The only thing thats confusing me right now is that I can still see the SC card in the storage app; next to the internal storage. From the post attached above I read that I should not expect to even see it after having it formated “internal storage”.

Are all the vanished pictures irreversibly lost? Than I understand I can format the SD card back to “External” and hopefully the problems will vanish then; and if that does not help, I need to do a factory data reset from scratch?

I don’t know if this is helpful information, but I have a 64 GB SC card from SanDisk and it never worked storing data there in the first place (I could not set the SC card as the place to store in the camera settings).

If this is what you see you have formatted as internal, there is no eject icon

If you formatted as external/portable you will see the eject symbol

Sometimes there an entry for a missing SD which I’m sure happened after the first time I formatted as internal ~ it doesn’t want to let go of the idea that internal memory had a one time a friend. :slight_smile:


Unfortunately most reports of this problem here I remember suggest the pictures cannot be restored (I am not aware of anyone succeeding) :frowning: However, from the same reports I would expect it “only” takes re-formatting the SD card to “portable storage” (“Mobiler Speicher” in German) to get back full functionaility of the phone.

As far as I know, this is actually not a problem limited to Fairphones, but seems to affect other Android phones since Android 10, too.


Thanks to evrybody for your immediate support and the tips. I accepted the loss of my pictures and try to formate the SD card back to an external storage.


It is too late for your case, unfortunately. But for the future always keep in mind that an SD card or a whole phone can die or get lost/stolen pretty quickly. So you should make sure to have up-to-date backups of your important data.
Depending on your needs and paranoia level there are multiple options:

  • cloud storage (Google, Microsoft, …)
  • regular manual transfer
  • “homegrown” solutions (NextCloud/OwnCloud, Syncthing, …)

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.