Screen behaves strangely

What is up everyone?

Similar issue on my side:
two weeks ago, my screen starts to behave strangely : sometimes, a part of the screen would display some noise (random colored pixels). Switching off the screen and on again, display was OK.
Then it got worse : happening more frequently. Then affecting the whole screen.

Once all the colors were wrong. I took a screen shot (power+volume down). After switching the screen off and on again, I checked in the gallery : the saved image had normal colors.

Of course, I took the screen apart, cleaned it, made sure the screws were tight on the phone. No change.

I ordrered a new screen and I am using it since this morning.
Issues is still present :frowning:

I even tried maintenance menu, checking screen options : OK
I re-calibrated the proximity sensor : no change. (even if the new screen seems to behave a bit differently in terms of luminosity dynamics)

The Accessibility > Touch delay option is set to ‘Short’

So at this point : either my non screen hardware is starting to behave strangely OR this is a software issue (which is my secret hope)

Sevan

I have similar issues with my phone.
It started with weekly / daily random reboots one month ago. The last couple of weeks the screen has been acting strange, just as @Sevan describes.

I moved this to it’s own topic as obviously it has nothing to do with the screen flickering.
It sounds rather similar to the noisy colored screen, but since it (at least in @Sevan’s case) doesn’t seem to be an issue of the screen I thought a new topic was best.


@Sevan when you dis- and reassemble the screen does it look like the contacts align well or could there be a gap somewhere?
What if you carefully try to put pressure on the screen in the area where the contacts are? Does that affect the issue?
I’d guess it’s a hardware issue and if it’s not the screen (though of course there is a remote chance that both of your screens have the same issue) then I’d guess it’s either the main board, the frame (bent?) or the cover ([not] pressing on the wrong[/right] spots).

2 Likes

Thanks @paulakreuzer

when you dis- and reassemble the screen does it look like the contacts align well or could there be a gap somewhere?
They align well

What if you carefully try to put pressure on the screen in the area where the contacts are?
Applying pressure here or all around the screen did not trigger the issue

Does that affect the issue?
Nay

Yesternight, I change one setting : I disabled the automatic adjustment of the screen luminosity. For now, issue has not been reproduced yet, so I will keep this setting and observe the behavior. If not reproduced for a while, I will try to enable it again and see if the issue appears again.

Sevan

Continued:

No luck, the screen flickered this morning and pressing it made the display react, pointing to a bad contact between screen and motherboard.

Looks like I am accumulating several problems together :sweat:

Continued:

To check if it could be linked to the buttons of the new slim cases (which I had to swap to avoid sporadic reboots…), I reverted to the original case. No change, same behavior.

One point I note now:
when the strange pixel issue happens, switching the sceen off and on again with the power button ‘solves’ the display issue.

To be continued

Seems to have something in common with:

Although you were pressing the power button directly instead of the screen, it is definitely

1 Like

Let me clarify a point:

There is two different issue I think : flickering and strange display.
Flickering is the screen blinking while the strange display is more color related (the whole screen or some pixels only).
Only the strange display is ‘solved’ by the power off/on.

1 Like

Hello everybody,

since three weeks I experience a bunch of problems which are related to some of the problems discussed in this thread.

I do not remember any direct pre-problem-action, like dropping the phone etc.- it just came “out of the blue”
First, I had a flickering screen, that at some random point freezed for a short moment. Sometimes I had to press the on/off Button to get it going afterwards.

Then, two new phenomena appeared: vertical stripes and repetitions on the screen, just as in the post of Jean-Baptiste at the start of the post and horizontal flickering and repetitions (a 2cm part of the screen would be visible like a stacked pattern all over the screen).

After that, the screen sometimes went in “noisy coloured mode” as described here: Noisy coloured pixels on my Fairphone 2.
In most cases, just pressing the on/off button would not help, I had to remove the battery and restart the phone to get it working. Sometimes, the “noisy coloured mode” appeared right after restart

After all this occured to happen for 3 days, I disassembled the phone, cleaned the contacts. This did not change anything. I decided to give it a try and ordered a new display (that I would have sold if it would not have solved the issue).

So, the situation with the new display is the following:

  • no noisy coloured mode any more. Some of the freezing looks like a small version of it (parts of the screen have this noisy-colour-mode pixel pattern)
  • screen sometimes does not react shortly after I start using the phone (sometimes it freezes just after i tap in the first number of my unlock-code)
  • flickering, that often leads to freezing apps or home screen (like in the attached photo1 and 2)
  • to turn on the display, I have to press the power button several times. This is weird, because turning it of functions without problems
  • display is slow in turning on (period of time to show code-screen is notably longer than what I am used to)

So, what I think it could be is a connection-problem from motherboard to display, because when there is no flickering, freezing etc, the phone works perfectly fine.

Any suggestions, apart from sending the phone with both displays to FP?

P.S. when I put in the old display, it more or less directly shows the “noisy coloured mode”. This is actually the weird thing: there was a problem with the display, but this apperently wasn’t the full story…

Hey @mmeese,
I moved your post here too as it doesn’t sound like you experience the actual issue being discussed in the screen flickering topic - or if you do it’s the least of your problems.

The issues you describe sound a bit like waterdamage to me. Some droplets that crept inside the phone could have easily been unrecognized for a while and slowly damaged the screen (& more).

I think the best way to move forward is to find another FP2 owner (ideally an #fairphoneangels) near you and exchange modules until you know which ones work and which don’t.

OK - though I am not sure about the water droplet theory, because i clearly recognize the screen issues described in the forum I trust your jugement :slight_smile:
Thank a lot for pointing out the FP angels - some other FP useres to test my parts were sth I hoped to find! I will let you know, what the outcome will be!

hey @paulakreuzer have you any suggestions how to get water out of the telephone?
What I/friends of mine did several time with water/other drinks-damaged phones was to disassemble it as much als possible, remove SD, SIM and battery and then place it in rice (functions as temperature barrier and sucks up the moist) so that it is completely covered. Then the whole thing would go into the oven at lowest heat (below 50°C) for about 5-6hours. After cooling down and reassembling, all of the devices worked perfectly.
I may try that with my FP to check if water inside the phone is the root of my problems - or are there any serious damages this procedure would cause to the phone?
all the best,
max

See #waterwiki .

2 Likes

hey @AnotherElk - thanks for the hint. I will give this a try!

to everybody else who is maybe reading my “rice&oven-method”:
according to the thread Another Elk posted, rice ist not a good idea!

Hello there again,

so this is what I did:

  1. followed the instructions of the waterwiki, left fully disassembled phone above heating for 4 days

  2. treated it with WD-40 contact spray (to be sure that everything is nice&clean when I reassemble it

  3. reassembled it with old display (the one that caused the initial issue and had the “noisy coloured mode”, see Noisy coloured pixels on my Fairphone 2)

Outcome: phone worked well for about 1 day not very intense use, then first screen flickering, got severe quite fast. The flickering could only be stopped by switching on/off the display via the power button - at one point the display just turned off without me doing anything. No reaction when I press the on/off button.

  1. reassembled the phone with the new display.

Outcome: phone worked well for about 1 day not very intense use, then first screen flickering. Like above, the flickering could only be stopped by switching on/off the display via the power button, but sometimes there’s no reaction when I press the on/off button. The only option I have then is to remove the battery and restart the phone as I’m not able to confirm the shutting down order.

So, what do I think is the root cause:
when I’m using the phone, everything apart from the screen is working well, the processor is running, I can use all my apps, the kamera, the headphones, the microphone ect. & so on.
I think, that my issues are based on some loose connection between the motherboard and the display (maybe the connector, which is not a part I should replace in order to not loose warranty).
What I will do is check with some other FP users if my displays are working within their phones, to eliminate the the case that I accidentally received a malfunctioning display.

If the test result will be, that both (or maybe only the new) display are working, then I see no other alternative than sending the phone in (I will be travelling for 5 months anyway and will not take this expensive thing with me :sweat_smile)

Any other suggestions?

Any other

Update:

Did a 2 weeks display swap with another FP user. She had no problem with my two displays, I struggeled with hers - noisy coloured screen.

So the cause of the flickering/noisy colour mode-error is not the display.

I will send it in to have it checked.

1 Like

Hi!
Did you ever find a solution to the problem? Mine has been like yours for months now and is virtually worthless.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

I too have been experiencing the problems described in this post which is now closed but with no resolution shown. Screen behaves strangely
Is there a resolution?