Sailfish OS release5 for Fairphone 2

That’s awesome! I’m dying to try it out :slight_smile:

Two things would interest me: did you build with support for waydroid? And: are all cameras functional?

I haven’t looked into what waydroid needs so that still needs checking. All three cameras work in image mode but video recording is still broken.


I am already full of anticipation!


I really appreciate what you are doing for the community!
Did you manage to overcome the issue with video recording?

I haven’t been able to fix video recording yet. I also found an issue with audio routing during calls which is currently blocking any release. Also mobile data is still not working.


Thanks for the update!


Where can I find the update to for fairphone 2? Index of /images/fp2/ has as latest version.

It seams that @mal did not build a installation image but here Index of /obs/nemo:/testing:/hw:/fairphone:/fp2-sibon you see the latest version (this is since yesterday :wink: ).
So an update could be done from a previous version.


Sorry about the missing installation image. I’ll try to get it built and tested as soon as possible.


Hello @mal, eventuelly also for fp3 and/or fp4 :star_struck:?
many thanks Gabs

I now uploaded the installation image for new Sailfish OS release and made a new topic for it Sailfish OS release6 for Fairphone 2. I hope to get FP3 and FP4 releases also done. I still have issues with the FP4 port.


So not yet a state where adventurous beta testers would be a help?

1 Like

Sorry for the delayed answer, I haven’t had enough time to figure out the blocking issues yet.


I know the question is actually inconveniently placed in this thread, but did the competing FP4 port help solve the call audio-issue?

@mal: I noticed a repo for SFOS popping up last week. Is this ready for use/testing or should I be more patient? :wink:

Thank you for you ongoing work! :heart:

1 Like

Hi, I have been using from devel repos (testing repo has same package versions) on my main device for about 2 weeks without any issues. I just forgot to build new image for it and release it.


I’ll give it a shot and attempt an OTA update tomorrow then. I’ll report back if I run into any issues. Thank you!

Any news regarding SFOS for the FP4?

Otherwise I’ll take my old FP2 out of the drawer and see how far it gets me with SFOS, Android s****s.


The update went well. I had to disable the ‘store’ repository though since zypper ref failes with

Repository 'store' is invalid.
[store|plugin:ssu?repo=store] Valid metadata not found at specified URL
 - Unknown error reading from 'plugin:ssu?repo=store'
 - Store credentials not received. Not connected to D-Bus server

Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'store' because of the above error.
Some of the repositories have not been refreshed because of an error.

I had some issues with the store before though, so this is likely a problem on my end. Any pointers on how to fix that would be appreciated but for now, an up-to-date OS with app updates via Storeman/chum is better than an outdated OS either way. :wink:

Maybe that was some random issue? I haven’t had any issues with store