Regular blank pages when trying to load Discourse forums in Firefox (Android)

Continuing the discussion from Issues with the forum:

If anyone also experiences this issue, it may be a good idea to voice your complain in this bug report, otherwise it will not get on their radar: 1815856 - Regular blank pages when trying to load Discourse forums


That’s version 109. There are three newer versions

Have you tried V112 yet ?

1 Like

I had the issue, but I could almost make it disappear by simply not closing Fennec … haven’t seen the issue for quite a while now.
There were updates in the meantime, I would have to wait for it to happen again to confirm it’s still there in 111.1.0 currently.

Thanks @UPPERCASE for pointing me at this!

I wanted to check the forum on my FP this morning and it only loaded a blank page with FF mobile, too.

Was too lazy to test what could be the reason for this issue (I thought probabaly it was caused by some badly configured adblocker or similar) but the next moment I realized that this was only an issue on my FP3 with Firefox and not on my Windows and Linux systems which also for FF on it.

1 Like

Firefox devs have checked and they can’t reproduce the issue anymore since Firefox 115.2.0. If anyone is able to reproduce it with that version, then please bump this thread or leave a comment in the bug report. Thanks!

1 Like

Well at any rate I can now close FFX and then reopen and refresh the page. Couldn’t do that for months, I’ve been using the “Delete browsing data on Quit” feature, so that’s looking hopeful. I’ll confirm after a few days.

1 Like

Still happens to me on 115.2.0


I’m on 115.2.1 | FP4 FPOS B.079. Haven’t tried yet on other platforms.
Haven’t tested as PWA yet either.

Just did a fresh check.
When I last used the browser I didn’t use Quit, so the tabs I’d left open were still there (by default I’ve set to reopen previous session tabs). One of them was a FP Forum page.
It didn’t reload, got stuck at 25% of the loading progress bar as before.

However, opening a fresh tab I was able to load FP Forum. That was not the case before, so to my mind something has changed, but not enough.

I then closed the app using just the App Switcher, launched it again and now both tabs load. So from my stand point there is definitely an improvement.

[Edit] - I spoke too soon. I’m back to the old problems, had to resort to Quit to be able to load the Forum again …


On a FP2 running/e/ e_FP2-user 11 RQ3A.211001.001 eng.root.20230619.150257 dev-keys

Ffx 115.2.1

Some hiccups but seems to work a lot more often than not. PWA as well.

EDIT: After a couple of hours testing the same problems occur. This may be quite difficult to test and eliminate.

1 Like

is the issue limited to discourse forums for you guys? I see it on several other pages as well. some days it’s better, just to worsen again next day.

I also have it on other websites, but it seems to happen more frequently on Discourse websites and once it has happened on a Discourse site, other sites start to have issues as well. I mostly visit news websites during the day and those rarely trigger the issue, if at all.

Do you have URLs of other websites that trigger the bug? It may help find the common denominator.

1 Like

For me it’s going to be difficult to say without spending inordinate amounts of time, since I’m using “Delete browsing data on Quit” and of course that wipes everything, not just Discourse pages.

Yes, I think we’re all basically seeing the same thing.

I was surprised to read that “Firefox devs have checked and they can’t reproduce the issue any more since Firefox 115.2.0”. Likely they just haven’t tested enough. That’s rather why I suspect this bug may prove difficult to run down. Our posts above witness how slippery this thing is.

I will record it. luckily I didnt have issues on other than discourse pages recently.

Have you changed any settings via about:config?

Does long pressing the refresh button and waiting a few seconds help?

This happened to me on a fresh clean install of Nightly. So no special config is in play.

1 Like

No, it doesn’t. Writing this after 10 restarts of ff.

1 Like

sorry for my late response guys. Now I fully agree with you that discourse is initiating this FF-freeze and that only after that other pages are affected. I didn’t find any other page initiating the freeze issue.

1 Like

Ah, interesting thread. I was already wondering whether this was a known Firefox issue or some Fairphone problem. I also have the problem, that the forum page won’t load regularly. Usually force-stopping Firefox and clearing the cache will help, but just closing (by swiping Firefox away in the recent-apps overview) and reopening it will often re-initiate the problem.

Edit: I’m on Firefox for Android Version 117.0.1 (Build #2015971659) btw.


The Firefox devs have been quiet for some time. If you and the others have the time it may help to leave a message in the bug report. If they see it’s affecting more people, they might prioritize this.


I had the same issues plenty of times in the past, but I don’t use the forum on my phone very often in general.
I tried it out just now and at least this time it worked as expected. FF for Android 117 at the moment.