Re-Enter SIM PIN

I’m having the same issue.

Updated to 1.5.1 when it came out, having the problem since a couple of days. SIM1 is Congstar (Germany), SIM2 is empty.

NOT playing Pokemon, so not (closely) related.

1 Like

to all:
disable the location service and observe.

It’s just a guess but you never know …


Same here, i have created a logcat but don’t know what to look for. In case it is useful for everyone, i attach it here:

I’ve got the same problem. I have to re-enter the PIN for the first SIM Card several times a day, sometimes after some seconds. The second sim card does not have connection anymore when I have to reenter the PIN code the first time after a reboot.

Is there a change to undo the update fo Fairphone OS 1.5.1?

SIM 1: sunrise CH
SIM 2: blau DE

1 Like

Same here, French network, 1.5.1, tried reboot and switch slots but I have to enter the SIM PIN around 10 times per day!

1 Like

Is there a change to undo the update fo Fairphone OS 1.5.1?

I don’t think that it is related to the update. There were enough people who use the old software and still have this problem. Could be a baseband firmware bug.

1 Like

same here. problem started yesterday. seems to occur much more frequently when pokemon go is running, even in the background. though I think I have had one or two instances where it happened without pokemon go running in the background. have tried taking the sim card out and cleaning, had no effect at all.

I’d love to see a solution to this bug! I’m experiencing it too.

I’ve got a Dutch Simyo sim card and a UK pay as you go O2 sim card. Changing the slots didn’t work. Not sure if it started before or after my OS update. I’ve had my fp2 for only a few weeks now.

1 Like

Same problem with congstar from Germany.

Seems to happen more frequently with gps (Pokemon GO), sometimes within a few seconds.

Startet yesterday morning when I woke up - so I didn’t make any changes to my phone over night.

1 Like

Same problem here. Since yesterday no GSM when GPS starts. FPOS 1.5.1


I gave this a shot but then wanted to catch a disconnection with logcat, so I enabled it again.
Guess what? As soon as I re-enabled location services, I lost mobile connection and had to re-enter my SIM. This seems to happen reproducable everytime I disable and re-enable location services!

I got 53k lines of logcat from this, I will take a look into it and come back here if there is anything new.

Meanwhile, could everyone please test this disabling and re-enabling location service thing? I think this might be something.

1 Like

I have the same issue since yesterday. I hope this bug will be fixed by FP soon.

1 Like

Tested - and woah. The error was there. As soon as location based services were re-enabled, I had to reenter my PIN.
I will watch now if this happens with these services disabled.

Note - 2hrs later: no problems at all when location services are disabled.


Same with me, started yesterday as well.
I am still using 1.4.2
I had never installed PokemonGo

Obviously it has to do with some app update, because it started for so many people in the last days.
But I cannot tell, which apps updated yesterday. Is there an updatelog in the phone somewhere to find the culprit?

1 Like

No idea if that’s it and it’s probably too soon to tell but after updating avast (battery saver and mobile security) it’s not happening anymore…
Just make a thorough update of apps.

I have tried it twice, and I can reproduce this bug.

  1. Disable location service
  2. Enable location service
  3. Connection to mobile network is lost instantly

I can also reliably reproduce the loss of the mobile network when I start Google Maps.


me too. google maps and pokemon go both reliably cause the problem

I have found a workaround:

Set “Settings” – “Location” – “Mode” to “Battery saving”.

So my mobile network is not lost when starting Google Maps. Downside: Some apps (like car navigation) will complain, and your phone is not usable for high accuracy location apps (like car navigation) anymore. With “High accuracy” or “Device only”, I lose mobile network when starting Google Maps.

Please note that when you are disabling and re-enabling location service, that setting will be reset to “High accuracy” and you will lose your mobile network again.


Knowing this, it seems like the mobile connection is lost as soon as GPS is starting. This is actually a valid theory and would explain the randomness of the connection losses and affected users. GPS usage is just that random.

Finally, somebody mentioned a GSM update earlier being a possible root of this issue: Both mobile connections and GPS are provided by the same chip (Qualcomm WTR1625L, I assume).

So, yeah, it really seems like this is an issue with the Transceiver, that got patched in our devices.
At least, we know why and where this is happening.
Further confirmations about this behaviour are appreciated, but now it’s time to get the devs investigating.


Can you try and empty the cache for Google Play Services? I had about 1.5 MB cached and when I cleaned it up, a new location request did not disable my SIM card.