Re-Enter SIM PIN

A̶c̶u̶t̶a̶l̶l̶y̶,̶ ̶t̶h̶i̶s̶ ̶s̶o̶l̶v̶e̶d̶ ̶i̶t̶!̶

Everytime something like this happens, I get an urge to burn every trace of every Android system existing.
How can an operating system be like THIS?

Anyway: emptying the Cache of Google Play Services seems to solve the problem for good! (Well, it’s a little soon to say “for good”, but I’m optimistic)

EDIT: Whooops. Took five minutes, got the same issue as before. Solved nothing :disappointed:


That should be the next test: set location to battery saving and observe and tomorrow set it to GPS and wait …

I’ve been having the same issue, getting considerably worse the past couple of days. Had at least 10 promts just this morning. I’m still on 1.4.2.

1 Like

I had 5.29 MB cached, and no, clearing the cache for Google Play services did not solve the problem.

What Baseband version is your phone using? (Settings -> About phone -> Baseband)

I mentioned “GMS” = “Google Mobile Services”. A baseband update does only come when FPOS is updated.

Baseband version is 4275.1-FP2-0-02

Oh, mixed that up. Are you sure baseband updates are only rolled out with OS updates?

Would be easier to explain, why this happens not related to any update, if we all got baseband updates indepentent of OS version and update schedule.
Got some work to do, will take a comparing look on the FP2 of a workmate (running on FOSS).

Which came along with 1.4.2. So far no one who reported this issue reported a lower software version.
Nonetheless, the problem only occurred very recently, for most users in the past days, so it doesn’t seem to be triggered by the baseband update itself.

From what I have seen so far I would suspect an incompatibility or conflict between the latest baseband firmware (since 1.4.2) and another factor. GMS update? A certain app (update)?

Thanks. Ok, as freibadschwimmer mentioned, we are all on the same version since 1.4.2, so nothing of recent interest here.
Google Play Services got updated on 28. July. This about matches with the start of our issues.

As we are on Android, if there are no hardware issues and no OS issues, the problem most certainly has it’s root in some Google services.
Accordingly, a workmate running his FP2 on FOSS without any Google services, should have no issues. Will ask him in a sec.

1 Like

That’s what I suspect, too. I’m currently running on ‘Device only’ and will see if I get these SIM disconnects in the next hours.
As they just started last night and were very frequent when location services were enabled, we might get some more ideas.

Maybe it’s a result of trying to map GPS with other location data.

1 Like

I am running FP Open OS and have none of these issues described above. Network connection is stable whether GPS is enabled or not. So I can confirm this (even not being your workmate). :wink:

1 Like

Difficult to say: the latest FP Open OS (16.06) is still on the older baseband firmware from before the 1.4.2 FP OS.
I still tend to the assumption it is a combination of both, the newer baseband firmware plus something else (likely GMS, since you’re right, it recently got an update and is commonly used).


As it appears that it could be linked to GPS and my bug started at the same time… Since this morning, my phone crash as soon as i enable data and GPS at the same time. And I could see in another topic in bug report section that I’m not alone with this specific bug in this timing. I don’t want to disturb if it is not related, but could it be re-enter pin for some people, and crash for others? (I still have version 1.0)

1 Like


I have been experiencing this bug as well and was wondering if it was somewhat connected with the pokemon go update - the bug started to appear on the same day as I updated the app.
My mobile on Pokémon Go used to crash a lot, even tho i had lowered data to 3G.

it is not linked to Pokemon Go (see Re-Enter SIM PIN)

some people did not install this app and I personally had the latest Pokemon Go version installed without any issue until yesterday

Really linked to Location Service activation for me (and I have always Data connection active)

1 Like
  1. Same with me, started yesterday as well.
  2. I’m using OS 1.5.1 since a few weeks.
  3. I also can reproduce the bug: I have disabled location service for 4 hrs and the phone works fine… When I enable location service the mobile network is lost instantly… also when I start Google Maps…
  4. I don’t have Pokemon Go installed…
1 Like

Same for me. But I have striked off something because I haven’t tried it.

Another observation:

Even when connected via Wi-Fi, when starting Location Service, the SIM PIN is asked.

After last_login mentioned it in an answer I deactivated the location based service. Since then - 7 hours ago - I did not have to re-enter my PIN and I did not get any connection problems anymore. Seems to be a work around to get the phone working again.