Re-Enter SIM PIN

Tested - and woah. The error was there. As soon as location based services were re-enabled, I had to reenter my PIN.
I will watch now if this happens with these services disabled.

Note - 2hrs later: no problems at all when location services are disabled.


Same with me, started yesterday as well.
I am still using 1.4.2
I had never installed PokemonGo

Obviously it has to do with some app update, because it started for so many people in the last days.
But I cannot tell, which apps updated yesterday. Is there an updatelog in the phone somewhere to find the culprit?

1 Like

No idea if that’s it and it’s probably too soon to tell but after updating avast (battery saver and mobile security) it’s not happening anymore…
Just make a thorough update of apps.

I have tried it twice, and I can reproduce this bug.

  1. Disable location service
  2. Enable location service
  3. Connection to mobile network is lost instantly

I can also reliably reproduce the loss of the mobile network when I start Google Maps.


me too. google maps and pokemon go both reliably cause the problem

I have found a workaround:

Set “Settings” – “Location” – “Mode” to “Battery saving”.

So my mobile network is not lost when starting Google Maps. Downside: Some apps (like car navigation) will complain, and your phone is not usable for high accuracy location apps (like car navigation) anymore. With “High accuracy” or “Device only”, I lose mobile network when starting Google Maps.

Please note that when you are disabling and re-enabling location service, that setting will be reset to “High accuracy” and you will lose your mobile network again.


Knowing this, it seems like the mobile connection is lost as soon as GPS is starting. This is actually a valid theory and would explain the randomness of the connection losses and affected users. GPS usage is just that random.

Finally, somebody mentioned a GSM update earlier being a possible root of this issue: Both mobile connections and GPS are provided by the same chip (Qualcomm WTR1625L, I assume).

So, yeah, it really seems like this is an issue with the Transceiver, that got patched in our devices.
At least, we know why and where this is happening.
Further confirmations about this behaviour are appreciated, but now it’s time to get the devs investigating.


Can you try and empty the cache for Google Play Services? I had about 1.5 MB cached and when I cleaned it up, a new location request did not disable my SIM card.


A̶c̶u̶t̶a̶l̶l̶y̶,̶ ̶t̶h̶i̶s̶ ̶s̶o̶l̶v̶e̶d̶ ̶i̶t̶!̶

Everytime something like this happens, I get an urge to burn every trace of every Android system existing.
How can an operating system be like THIS?

Anyway: emptying the Cache of Google Play Services seems to solve the problem for good! (Well, it’s a little soon to say “for good”, but I’m optimistic)

EDIT: Whooops. Took five minutes, got the same issue as before. Solved nothing :disappointed:


That should be the next test: set location to battery saving and observe and tomorrow set it to GPS and wait …

I’ve been having the same issue, getting considerably worse the past couple of days. Had at least 10 promts just this morning. I’m still on 1.4.2.

1 Like

I had 5.29 MB cached, and no, clearing the cache for Google Play services did not solve the problem.

What Baseband version is your phone using? (Settings -> About phone -> Baseband)

I mentioned “GMS” = “Google Mobile Services”. A baseband update does only come when FPOS is updated.

Baseband version is 4275.1-FP2-0-02

Oh, mixed that up. Are you sure baseband updates are only rolled out with OS updates?

Would be easier to explain, why this happens not related to any update, if we all got baseband updates indepentent of OS version and update schedule.
Got some work to do, will take a comparing look on the FP2 of a workmate (running on FOSS).

Which came along with 1.4.2. So far no one who reported this issue reported a lower software version.
Nonetheless, the problem only occurred very recently, for most users in the past days, so it doesn’t seem to be triggered by the baseband update itself.

From what I have seen so far I would suspect an incompatibility or conflict between the latest baseband firmware (since 1.4.2) and another factor. GMS update? A certain app (update)?

Thanks. Ok, as freibadschwimmer mentioned, we are all on the same version since 1.4.2, so nothing of recent interest here.
Google Play Services got updated on 28. July. This about matches with the start of our issues.

As we are on Android, if there are no hardware issues and no OS issues, the problem most certainly has it’s root in some Google services.
Accordingly, a workmate running his FP2 on FOSS without any Google services, should have no issues. Will ask him in a sec.

1 Like

That’s what I suspect, too. I’m currently running on ‘Device only’ and will see if I get these SIM disconnects in the next hours.
As they just started last night and were very frequent when location services were enabled, we might get some more ideas.

Maybe it’s a result of trying to map GPS with other location data.

1 Like

I am running FP Open OS and have none of these issues described above. Network connection is stable whether GPS is enabled or not. So I can confirm this (even not being your workmate). :wink:

1 Like