Re-Enter SIM PIN

Same issue here, German an Luxemburgish SIM cards.
Running 1.5.1., factory reset did not help at all.
I have deactivated my PINs as a workaround. Still hoping there will be a fix soon!

1 Like

Look at my reproduction steps and my workaround.

1 Like

Same here. I updated back and will wait till the next update and hope things will be fixed.
Unfortunately i updated and went on vacation, i could not use my phone as many problems accured, it was unbearable. I had the fp2 from start and accepted the first big troubles. 1.4.2 worked almost stable and i trusted the developers and updated 1.5.1 - after this summer i regret buying a Fairphone it’s sad, the project and idea is awesome, but i rather had donated than fight with a unusable phone the whole summer.
>here the link<

1 Like

What was the Baseband version in OS 1.4.2?

From another topic, this should be 4275.1-FP2-0-02 (the same as reported by those running 1.5.1).
If 1.4.2 and 1.5.1. were never installed it’s likely to be DI.4.0.1-00161-M8974AAAAANAZM-1 (this includes people on Open 16.06 who didn’t go via 1.4.2/1.5.1).
However, I also recall someone reporting this issue who was still on 1.1.7 - I’ll check where that was, as it wasn’t in this topic…

Edit: It was here, but concerned crashes on 1.1.7 that turned into SIM disconnects when they updated to 1.5.1. So it’s not clear whether the underlying cause is the same, or one problem was replaced by another.

1 Like

I had the problem with 1.1.7, but it was worse, I didn’t only had to enter the PIN, the phone rebooted itself completely. And not just occasionally, but everytime i started an app using GPS, in my case Maps and Pokemon. With the 1.5.1 update, the problem is like described by others above.

The location mode -> Battery saving workaround seems to work, thanks!


Same problem here, I hope the next update will correct this.


Thanks for this. I reproduced this once just now and indeed lost the connection. Then I tried again and the connection was not lost. Obviously sometimes it is working (I walked in the woods using the navigation yesterday) but it is really annoying when it does not and I have to enter the SIM PINs again. I hope this can be fixed soon.

I cleared the cache of Google Play Services. This caused me to lose the connection and have to re-enter the SIM PINs.

After entering the PINs, I turned off and then on again the location service. This also caused me to lose the connection and have to re-enter the SIM PINs.

Very annoying. :weary:

1 Like

I’m having this issue too with Spanish providers. The curious thing is that this started to happen to all of us like a couple of days ago

1 Like

Yes, this is why it is most probably linked to a Google service update, not FP OS or a specific application.


I am having this problem also with my 1-month old Fairphone and the simcard I have is also new. The problem began like a week ago with my simcard disconnecting. Good to hear that I am not the only one.
First I checked if the simcard-slot was clean, also tried the second slot and rebooted the phone. But the problem continued.
I jope there will come a solution soon.

Thank You for your reply. Strangely I personally hadn’t this issue with regular 1.4.2 before this summer. The issue happened with my update to 1.5.1, i went back now to 1.4.2 and the issue remained. Im living now with the location settings workaround. I had also some graphical issues that were fixed by going back to 1.4.2, if someone is interested: Here how i went back to 1.4.2.

1 Like

I can also say, that the location mode -> Battery saving workaround seems to work. I have my fairphone in this mode since 20 hrs now and I didn’t have to re-enter the sim-card-code once. Thx!!!

1 Like

No, it is not. I have no Google-App activated and thus nothing is updated.

Hi all,

We are aware of the issue and investigating it. Our first guess is that it might be related to the latest Google Play Services update (which is automatically updated in the background) - seeing the majority of users encountering this issue arose around the same time.

A temporary workaround is to disable the SIM pin code in Settings > Security. Of course, make sure you have a device pin/pattern set up. Once we have a fix ready, make sure to enable the SIM card pincode again :slight_smile:

Temporary workaround #2: Go to Settings > Location > and set it to “Battery saving”.


The Product team


Same problem here. Also pokemon go user.

1 Like

Well I am not sure if this is a cause->effect relationship, but after disabling the pin, the phone now automatically switches the preferred sim card to the other sim once in a while, which makes me pay roaming charges when I dont pay attention before calling someone. I am absolutely not amused. After being so enthusiastic about FP2 , all the errors with the sim cards keep me being frustrated! I urge you to fix this.


Please continue here: