Problems with the flash in default Camera app

Hey all,

I’ve been into troubles when I wanted to activate the flash to take a video with it in the Camera app: it’s impossible, there’s no option for it…

Furthermore, it appears impossible to force it (even with HDR off) by turning it on or off in the photo mode, it’s always automatic… And in Pro mode, with red eye reduction, it activates, but the picture is taken when it’s off…

NB: it works fine in automatic mode with the same app, as well as with Open Camera…

1 Like

Anyone having a similar problem, or is it just me?

For photo I have the flash option, but I can not find it in video mode indeed. But I used Open Camera, and deactivate this app, so I never noticed; I just reinstalled it for testing.

But in the photo mode, if I force it, it is always on, if I force it off, always off. I am not sure to understand your problem.

The red-eye reduction is always like this. The idea is to flash just a few microsecond before the picture, so that the pupil shrink a lot, to avoid the red-eyes, so I guess it is normal.

1 Like

I can’t force it, it doesn’t work, always automatic even if it is set on flash ON (in this case it might not activate) or OFF (it activates)… And of it activates for red-eye-reduction in Pro mode, the picture is taken during the short lapse when it is off between two flashes…

I can confirm some flash problems at my FP3.
There is no option to activate the flash in the video mode at all (or any other setting).

Regarding the photo mode:
I observed the always automatic flash bug with red eye reduction only.
I didn’t observe a wrong flash timing so far…
(I will test another day, as there are too many options for testing this evening)

1 Like

Positive: I observe 120 fps video framerate! :smiley: :movie_camera:
There is confusion about the actual framerate:

By the way, in the FP3 specs it’s said that it can record video in 1080p @ 30fps, but in this video you can see that supposedly it allows to record in 1080p @ 120fps with the rear camera (minute of video: 12:24), even when the youtuber sais that it should be 60fps in the definitive version because of a bug or something like that.
Anyone knows if the final version of the FP3 will be able to record video in 1080p or 720p in higher FPS than 30? It would be really nice
general fp3 discussion: link with picture

As the Sony IMX363 chip and Snapdragon 632 SoC supporting 120 fps I was optimistic,
but got dissapointed by a bug described by this review (video)
(camera app false closes at touch focus)

However the bug is not apparent right now and I get 120 fps! :ok_hand:
(stopwatch and frames counted)


I’ve also succeeded to force or remove the flash with the Pixel camera app and it works fine here, but still not on the main Google camera app…

Anyone having the same problem? Any update on this?

Since I normally shoot without, I wouldn’t have noticed there’s something about the flash.
I have tested my FP3 and observed the following:

  • video
    -flash not selectable and stays turned off
  • photo normal and pro / red eye reduction deactivated
    -flash is controllable (on/off/auto) an works as designed
  • photo normal and pro / red eye reduction activated
    - flash led stays turned off despite selected on and auto mode
    - red eye reduction - flash led stays turned off

To summarise:
Flash works in normal and pro photo mode as expected, if red eye reduction is deactivated and doesn’t work at all in both modes, if red eye reduction is activated.


My FP3 unfortunately does not give me the opportinity to activate the flash, not even when I deactivate the red eys reduction option and restart the system. Would be nice to have a hint how to deal with it.

Since the last 0107 update, the flash button is now greyed, blocked on always automatic, even if red eye reduction is off.

It it normal, @rae?

If I open the native app (I normally use Open Camera), it is not greyed on my FP3 with the last update

And I forgot to add it works.

And there is no flash in Open Camera in video mode but there is the possibility to turn the torch on.

OK :slight_smile:

Just been checking and I had the same as @Antoine. I saw no option under settings to change it, I tried many switches, red eye etc. then I opted to Restore defaults and the option to switch Flash by tapping on the icon now works.

I wonder if it is because I have also tried Open camera and currently use G cam that interfered??

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.