Problems with starting and unlocking the phone FP1(U)

Please enter the information in the Bug Report. The Fairphone team cannot be bothered with reading through the whole thread here.

Hi everyone:

It’s nice to see that I’m not alone experiencing these problems. But sad to see that no clear solution has been found for now!
I experience both parts of the problem: the Google Play Store is very very slow when accessing the “My installed apps” screen. After a while, the screen finally appears but apps’ updates take hours and are clearly not smooth at all… I thought that it was linked with the Play Store but I get 2 Play Store automatic updates recently and it didn’t solve the problem.
I also have the unlocking screen bug. I’m using the scheme option and it’s really better not to make a mistake in entering the scheme if I don’t want to wait minutes to access the phone again.
But the two problems seem not to be linked as I read in previous posts.
I recognize that I have a lot of apps installed but I try to have the minimum useful awaken. Maybe it’s important to say that my phone is secured by Sophos. I wonder if the problem did not start when I switched from Avast to Sophos but nobody seem to make the same connection. Should you wish to get more details on the apps I’ve installed, just let me know and I could give the complete list.
I did not try to make a complete clean install of the OS but maybe I will do this for the 1st birthday of my phone if the problems persist without any hope of solution.

Thank you for the help already provided and thank you in advance for anything you could do on these issues!


1 Like

This is probably your best chance to solve the problem. Afterwards, install apps that a possibly related one by one (like Sophos) to locate the problem.

I finally didn’t have the choice to do a complete clean install because ten days ago my Fairphone was completely stuck at startup screen.
This was a good thing because I’ve discovered that some updates were never made on apps. Moreover, now that I know how I use the phone in the daily life, I’ve adjusted the settings to better meet my requirements. And I’ve only reinstalled the apps that I consider strictly necessary at this time.
The situation is back to normal but I’ll let you know if anything goes wrong.



I was wondering if anything new came up on that problem?

I have the same problem and already did a clean install but after about one and half month, I have got the same problem again (the phone takes several minutes to start up, but starts up normally if it is started by the alarm clock). I had activated the screen unlock by pattern because I needed it since my email account requires it. Now it has come to the point that I will need to reinstall the phone again. It is obviously not a sustainable solution. Is anybody from Fairphone aware of this problem?

Hi there!

I´ve finally had time to read all your comments. I want to thank you for all the feedback. When I first posted this I thought that I would be the only one with these problems.

Unfortunately, after reading all your posts I have mixed feelings because I see that there seems to be no solution for it and even after performing a hard reset on the mobile phone the problem can come back.

I´m going to perform a hard reset myself hopefully within the next 2 weeks and see how it goes. At the moment, I keep having more or less the same problems as I had at the moment of writing the initial post but since I´ve changed the screen unlocking method to ‘slide’ things go a bit smoother. However, there are moments were I cannot type with my keyboard easily as it gets slow and unprecise (which is very annoying).

This makes me think of the problem described here… A hard reset is the only way to fix it. re-installing your apps one by one to try to find out which one could have caused the problems, could help (but no guarantee). Good luck!

I also needed to do a hard reset after my phone became completely unusable. After the hard reset I did not set up my corporate email on my phone and haven’t had any problem since then. So the problem seems to be the screen unlock that I had to turn on as required by my corporate email server. I can live (probably better :yum: ) without having my corporate email on my phone but it is still an annoying bug.

1 Like

Great that it worked for you @Camille_Hamon - could anybody confirm a relation of this bug with a corporate mail account? I am also suspecting the screen unlock functionality obliged by the corporate account with my phone. But I really need this account.
Any new idea how to fix this? Is there a possibility to change the locking requirement of an exchange server to pattern or slide instead of pin?

I think pattern should work, have you tried it? It’s a personal code opposed to the insecure slide unlock.

After months of silence I think it´s time for me to give a little update on my problem.

The thing is that it has solved itself. I did nothing, really and around a month ago it started working as if it was a brand new phone. I only uninstalled a couple of apps, one of them being my bank app, but I don´t think that was the reason for all my troubles.

Anyway, unfortunately my experience is not very helpful since I don´t know how it got fixed, but the point is that I didn´t need to perform a hard reset or anything. Now I use a pattern in order to unlock my phone and even if I make a mistake, after a second or two I get to try again without any problems.

Good luck to those of you that keep experiencing these problems!

1 Like

Maybe it was not the bank app, but it could easily be any other app. Thank you for this comment! :slight_smile:

@MartinKrenn: Could you start you phone in secure mode (press Power button and long press “Power Off”, confirm to start in secure mode), and see if this changes anything? Apps are disabled in this mode, so it should make a difference, according to @andyphone.

I’ll try the next time my phone gets slow again. I just restored the phone (restore userdata) as always when this bug is about to freeze the phone. So it’s a matter of some weeks until I can test your suggestion.
@andyphone: Did you uninstall any apps that required you to use the pin login? (e.g. the banking app or a corporate mail account). To me the bug seems to be linked to this locking security requirements.

Last time my phone did freeze I had about a dozen log files with 20 MB each in directory /data/log_other_mode - my phone kept saying that it stopped services because of too little space (internal memory). As I mentioned several pages above, its the repeating password_failed and password_succeeded messages, that (in my opinion) makes the phone that slow. Therefore I suspect some bug in the screen locking part of the fairphone OS.

1 Like

Hi Martin,

As I mentioned above, the only app I uninstalled recently that could potentially be the troublemaker was my banking account. Luckily, I rarely use it, so I tried getting rid of it. The thing is that I don´t think that removing that app automatically solved the issue. It fixed itself some time later. So the mistery is still there…