English

Problems trying to downgrade to 18.04.1

Torch on does NOT solve the issue here (latest FP open, on a brand new FP2)
Can someone tell me if by installing the 'manual switcher back to 18.09.2 I get back to Android 6?
I have to offer one of my new phones in the coming days, and the reboot-instead-of-shutdown is just a no-go :worried:.
Now, I definitely would prefer to keep FP open anyhow…

Thank you!!

Connected to a charger or USB perhaps?
I occasionally got this with LineageOS 15.1 when connected to USB, but I see no pattern.
Not connected to anything the flashlight workaround worked everytime I tried.

No. You need to install 18.04.1.
Links for this downgrade are given here …


But as long as there’s no fix, the buyer would be affected once he/she upgrades to Android 7.

1 Like

Very interesting; indeed I remember having tried with and without the USB, but I don’t remember exactly what happened.
(coming back hours after to correct this once checked) YES, the trouble came from the USB charging being connected. Without USB connected, the flash trick does allow to switch off!
Thank you!!

Sure, but the fact is, I bought it for him (indeed I now have two new FP2s :wink:) and I do want to prepare everything before giving it (he lives quite afar from my home : I want to be able to get access, update etc. and above all start from an efficient base)
Now, your link to 18.04.1 sounds perfect -I’ll do this as soon as I’m back home :slight_smile:
Thank you very much!
H.

Well, I just downgraded to 18.04.1 (indeed reflashed twice, considering maybe something went wrong the first time) and I get other bugs :frowning:

  • the ‘android app optimization’ process halts midway
  • immadiately after I get two complicated messages, one of them concerning ‘android.process.acore’, which reiterates some 10 times
  • these messages reappear regularly (when launching an app for instance), and are definitely more intrusive than the reboot issue…
  • the updater app refuses to start (‘must belong to the system’ error… is it inherited from the previous and more recent build??
  • when plugged to the computer USB I get an infinite loop of restarts never reaching the blue-bacground Fairphone logo
    … I am now reflashing 18.09.2 just to see…

Did you do a factory reset on the downgrade?

I don’t even know what it is :frowning:
But obviously it’s what I need : I now tried to return to my initial 18.10.0, and the script doesn’t even ask me if I want to erase, and all is crashed…

That shouldn’t be a problem. Do a #dic:factorydatareset and a manual installation of 18.04.1

2 Likes

Thank you!
Now with a 18.04.1 that does switch off on request :wink:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.