Problems connecting FP2 via USB and deleting photos


I’m trying to enable data transfer via USB and USB tethering but even when my FP2 is connected to my laptop via USB and charging, it says “USB not connected”. I’ve tried a few of the solutions previously specified in the forums and I can’t get any of them to work, can anybody help?

Also, can anyone advise if connection to a computer is necessary to delete photos as I have a few junk pictures in my “Camera” folder in “Images” but I can’t find any option to delete them.

Best regards,


Which solutions did you try? Are you sure you’re using a USB data cable? Can you check with another smartphone if the cable works for data connection? Or can you try another cable?
You have to unlock your FP2 when connected to USB and then select data transfer in the according notification which should appear.

You should be able to delete the photos using a file manager.


You don’t have to connect your phone to your computer to remove pictures. You can do it from the gallery app or through the file manager (Settings > Storage >Internal shared storage > Explore).

If you do want to do it through your PC, like Volker said, make sure you’re using a data cable. After connecting the phone, unlock the screen, drag down the notification bar, tap ‘USB charging this device’ and then select ‘Transfer files’. Your FP2 should pop up on your PC in the same way that a USB drive pops up.

If that doesn’t work, or if you can’t select ‘Transfer files’, you’re probably using a cable that’s only capable of charging your phone and not connecting it to a computer.


Thanks Volker, I tried this (USB FP2 connection with a PC is no more recognized), this (USB connection to computer not working nor charging), this (Trouble getting USB data connection), and this (Cannot access FP2 via USB). I think it is a data cable as I think it used to work for that purpose, it is this ( - I don’t have another phone or cable that I can check with though.

I don’t get a notification when connected by USB.

1 Like

Thanks rmf. I followed that path in my phone, but I don’t get an option to delete pictures. Can you explain what I might be missing.

If it is the cable that is at fault (, which I’m pretty sure used to work for USB tethered internet access, can you suggest a better cable?

Looks you’ve really checked and tried a lot! And also the cable looks perfect. Still the cable or bottom module might be defective (now).
You might try to use MyPhoneExplorer (via WiFi) to access your data or transfer something between your FP2 and PC.

And sorry for asking again (that wasn’t mentioned in one of the linked posts and you didn’t mention it in your answer): your phone was unlocked when searching for the notification?

1 Like

Thanks Volker, when you say “unlocked” is that just putting in the password to unlock the screen?

I tried another cable and it appears to work! I now get a pop-up when I connect the USB with the option to transfer files, and if I click that, it brings up an Explorer window on my laptop.

I also now have “USB debugging connected” as I accessed the Developer options following the solutions to no usb connectivity in other posts. Is this a good thing, should I keep it on?


Great to hear it works now! USB debugging shouldn’t be necessary. So I’d recommend to disable it.

I experienced problems like this with old or cheap cables from time to time. E.g. they work if you bend them this way and don’t work if you bend them the other way. So it’s a good idea to try a different cable (preferrably short and good quality) and/or a different USB plug on the PC.

Thanks, though it seems that I have to have it on to allow charging. Is that right, or is there another way?

Thanks, can you recommend any as these don’t seem to last long:

I can’t imagine “USB debugging” is needed for charging. But in case it helps for you, then just leave it on.

You can use any micro USB cable. Try to avoid very cheap, very long or very thin cables. Unfortunately, I can’t recommend a shop in the UK, and it probably wouldn’t make sense for you to order a cable from Germany.

Not quite any USB cable - you’ll need a USB data cable. There are USB charging cables that are only intended for charging and those are incapable of transfering data. It’ll say what kind it is on the packaging.

The cable the OP linked to is suitable, though I can’t vouch for its quality.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.