English

Cannot access FP2 via USB

Tags: #<Tag:0x00007f05dba74300> #<Tag:0x00007f05dba741c0>

I have had a FP2 for some time. It has slowed down of late, probably due to little memory left and apps becoming more demanding with each update. I wanted to dump most of my pictures and videos to the PC to improve performance. I am due an update or two, but I don’t want to update before I copy and erase the files, so that performance doesn’t decrease more (with the last update it did it considerably).

I have been shocked: I cannot access the phone via USB as I used to. I have the developer options activated and I have tried what is suggested here:


and here:

including installing a generic ADB driver on the computer, I have tried 2 computers (one with Windows 10 and one with Windows 7, the latter used to work for transfer) and two different cables (including one that I think it used to work).

The problem is that I never get the message on the status bar to change to transfer. The phone does charge, though.

Any ideas of what to do? I am truly desperate, I have a whole year of photos of my baby that I really want out, so a factory reset is not something I want to do.

How about saving the files to an SD or SDXC card of generous size?

1 Like

Well, that is certainly a possibility I didn’t think of, but it may be very time consuming as many pictures are in different folder (including the crazy Whatsapp storage system) so I would need to be moving them via the phone which may be a bit more complicated. I think I will always wonder if I am missing something. Last but not least, I don’t own one such card.

I don’t understand why the usb doesn´t appear in the notification bar. It makes no sense. I would appreciate any insights on this.

Try different USB configuration pre-set in Settings -> System: Developer settings. Here inside you find the USB configuration in chapter “Networks”. Of course, they must be turned on in the top bar of the app.

To be able to see developer settings in the settings menu choose: Settings -> System: About phone -> tap “Build number” quickly for 8 times or so.

If you incidently have them already activated and pre-setting is set I wouldn’t wonder that the specific dialog does not show up any more.

Just to make sure : I think the phone was unlocked while connected via USB?

I think one important information is missing from your post. You wrote that developer options are enabled, but just to make 100% sure: did you also enable USB debugging?

If yes: IIRC with USB debugging on you won’t get the notification to switch between the different USB modes. And the phone will not show up as mass storage.

If no: there should be a notification to switch between USB modes and if you select MTP there you should be able to access the files as with an ordinary USB stick

What do you want to do: copy files with drag’n’drop using the windows explorer? Or create a backup with the adb command line utility?

Thanks for your interest in helping me. I answer each of your questions:

@Amber: Yes, I had tried the different configurations from Settings-> Developer Options. It doesn’t make a difference as I am not prompted on the status bar and the storage does not appear on Windows.

Even if the specific dialog does not show up, I would still expect something to appear on my computer if I have selected the option MTP, right?

@Volker: Now that you wrote it, I tried both: locked and unlocked. It seems to make no difference.

@Ingo: Good question. I did not have USB debugging enabled when I tried, then enabled it. It made no difference. I have gone further now and I’ve tried disabling the Developer options altogether to no avail. I’ve restarted the phone for each of these (cold restart).

I want to copy files with drag’n’drop.

I agree. That’s even more strange. In my case the computer even shows an (empty) Explorer window only on connecting the phone via cable (only when I select MTP I can see the data folders). So I’d really expect a computer reaction.
You wrote

Are you a 100% sure the one did also work? Maybe both cables are no data cables? Do they work with other phones? Do you have a third one?