Trouble getting USB data connection

I seem to have the same troubles as described here: Problem connecting Fairphone 2 to PC (the part about data connection).

Most of my USB cables actually seem to be only-charge cables.
But I do have two data cables, and they do work for another android phone as data cable.

For this Fairphone2, they don’t even work properly for charging. When I attach the FP2 to a PC, it will show the charging state for about 1-2 seconds (and the charging LED will light up for the same time), and then both the charging indication in the status bar stops and the LED goes out. Neither is there any notification about connection options as with the other android phone.

TL;DR: Enabling USB debugging and disabling it again (while phone was connected to PC) fixed it for me! See also last post.

Anybody else had issues like that before?
As I have another bottom module available, I’ll try my luck with that one, maybe there is some connection issue…

I have exchanged the bottom module, this didn’t change anything.

Still, a data cable neither charges the phone nor allows a connection to a PC…

The same data cable does load the phone when there’s a simple charger at the other end, not a PC.

So my FP2 seems to refuse any USB connection if a data connection is recognized - some security setting maybe I can check?

Nobody else seems to have the same issue?

I wonder whether it’s more likely a hardware or a software issue - and hence whether a reinstall / factory reset could be useful… any hints somebody?

Sorry nobody answered so far.
It sounds to me like a simple issue of quality of the cables. Their data transmission function seems impaired so the phone and computer can’t communicate and find the right charging current.
Try some other cables.

Any recommendations on what cable I should buy?

I would find it very funny actually if it were the cables, because then this particular FP2 has “very high standards” regarding the cables it accepts - the same two cables work for data connections with another android phone, and used to work perfectly fine also with another FP2 (which unfortunately now has become unusable due to the the screen connection not working anymore)…

Of course it’s possible that the cable quality deteriorated somehow, though for both at the same time? And only for the one phone? That’s too much of a coincidence for me to really think of the cable being the culprit…

Some relatively expensive cable from a well-known company will probably do.

Afaik refusing to work well with low quality cables is a defensive mechanism for the phone and it’s battery. Some other phones don’t have this function.

This happens all the time. Usually a little slower with higher quality cables, but even with them.

Just found one more USB data cable, which I bought not a year ago. This one again, perfectly works with another phone; but it shows the same symptoms with the FP2 as described above.
By the way, one of the previous data cables was a Nokia cable (so definitely not a too cheap one). As I said above, all those cables are working for another phone as data cable, and used to work for another FP2 a short while ago.

There’s of course still a chance that it’s the cable - but if you ask me, a very very very very slim one. Or did they somehow change the compatibility circuit in recently shipped FP2 to accept far fewer cables?

I’ll ask around at work tomorrow to get a few more samples :smiley:. Maybe I’ll try and buy a new one, but as charging works with non-data cables, I’ll probably not bother - we’ve got tens of micro USB cables already, and I don’t really often need the data connection, and even in occasions when it would have been neat, there’s always been so far some other way to achieve the goal without the data connection…

Have you tried different computers?
Do you have #fairphoneangels near you? They could help you test if the new bottom module might be faulty too.
You could also try #dic:safemode to make sure it’s not a software issue.

I think so, but not sure, will try that tomorrow.

I have tried with the bottom module from the other FP2 mentioned above, didn’t change anything.

Didn’t know such a thing existed, good to know! Tried it, but unfortunately didn’t change anything (same behavior in safe mode - phone shortly shows charging, but after 1-2 seconds doesn’t charge anymore and also doesn’t show data connection options).

Some more experiments:

Tried it on two additional PCs (so in total one desktop, two laptops).

Only on the newest one (a laptop) it shows the behavior exactly as described above on the two existing USB 3.1 ports (the thing with the phone shortly showing charging and then stopping).

For the USB ports on the other machines - 2x 3.0 on the other laptop, as well as both 2x3.0 and 2x2.0 ports on the desktop, as well as when connected via a USB 2.0 Hub to either the “old” laptop or desktop, it will not show any charging at all with those 3 data cables (not even for a short while). When connecting to the same ports via a non-data cable, the phone will again charge just fine.

Quick experiments with a data cable from a colleague (on yet another desktop PC, probably with USB 3.0 or 3.1 port) also showed no success - it wouldn’t even charge with that one when connected to a charger, so I suppose this is a “really bad” one, even though with my colleague’s Android phone the cable again works fine for data connections…

Next steps:

  • Buy the most expensive data cable I can find (?)
  • Software reset (?)
  • Live without USB data connections (most probably)

Do you have USB Debugging enabled in the developer settings perhaps? I found that my phone would disconnect from the computer in that mode unless I change even more developer settings to override the USB mode.

(If you did not enable the developer option in your settings, please ignore this.)

1 Like

Thanks for the pointer!

USB debugging was disabled.
I also disabled the developer options altogether, that didn’t change anything yet.
But when I enabled USB developer options & USB debugging again (while the phone was connected), the phone suddenly recognized the USB data connection! And after deactivating USB debugging, the data connection stayed on… so seems it was some kind of software hitch!

TL;DR: Activate/Deactivate USB debugging mode for fixing this issue!


Somehow this doesn’t stick.

Currently, I have to repeat the USB debugging on/off procedure each time I connect the phone via data cable for it to charge/connect.

Just to make sure: You do not get an “ has stopped” error message, do you?

Nope, no such messages. The only “…has stopped” message I can remember on this phone is for the Music app (which for some reason doesn’t work at all, I have thus deactivated it) - other music apps (currently using Vanilla Music) work just fine.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

Since completely re-installing of Fairphone Open OS (including upgrading to 19.08.1), the bug is gone. So it was a software issue, but fixed either by the upgrade, or by the full re-installation.

For the re-installation, I did not only do a factory-reset, but a full wipe of the system partition; I followed the instructions here: 🇬🇧 🇩🇪 ✏ Installing the Fairphone 2 from scratch in case of failure / Komplette Neuinstallation des Fairphone 2 im Fehlerfall.
My main goal was to get rid again of the OpenGApps I had needed before but not anymore; as a nice side-effect, now this bug is gone, and also another where the Music app would always crash. What wonders re-installations can do :wink:

1 Like

And the problem is back; the reinstallation doesn’t seem to have fully fixed it.
I have now seen it three times again although occasionally it also just seems to work. Haven’t figured out the pattern yet. It could be that the phone “remembers” something about this until the next restart/ warm reboot…