USB connection to computer not working nor charging

I have had a fairphone 2 for almost two years with no problem.
Recently I couldn’t connect to a computer like usual.
I tried different computers (with windows 8 and 10), different ports, different cables. It doesn’t charge and doesn’t offer the file transfer (the phone is not visible from the computer).
The phone charges normally through the plug, so my port should be fine.
I’m suspecting a software issue.
I updated not so long ago to the OS 19.08.1.
Any idea?
thanks a lot

Hi Althalis,

so you tried different things, thats good so far.
But it seems there is a problem with your plug. To proof it you need another one with a FP2.
Then switch the bottom module and you will see, if your phone will act as usual.

In that case it is very likely your bottom module has a broken solder joint, what is easily repairable by someone with soldering skills. I. e . a repair shop for mobile phones.


Sounds like your only data cable is broken and you only tried other charging cables. Charging cables won’t work with a computer, only with a wall socket.

PS: Or the other cables are data cables, but the “data part” is broken.

1 Like


Have you changed the USB configuration in developer options from charging to MIDI, or alternative? that worked for me…


Hi ElKrasso, I was very close to switch the modules with another fairphone but Liam solved my problem. That’s good to know anyway that I can troubleshoot that way too.

1 Like

Hi Paula, you are assuming I didn’t try with cables that were working before but I did. I used all kinds of cables and it always worked in the past. Good to keep in mind of course that the type of cable might be a problem.

Hi Liam, thanks!! that worked! I don’t know why it was stuck because of that but I can transfer now.

1 Like

Great, I had the same thought process :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.