English

Poll + general discussion: who got Android 10 Update on their FP3 & first impressions

The immovable date thing is so weird. I am on Nova now and I don’t like it but better than that!

Not being able to remove, or even move the date bar is annoying indeed. The name of the day haven’t even got a capital letter, and the shadowing of the text looks wierd. Hope it gets fixed on the next update!

Except for a few security improvements, there is technically nothing extraordinary about the operating system in android 10. The main new features are the user interface, especially the dark theme, and a few (IMHO) gimmicks in a few apps like a new date bar on the top of the screen with a small wheather icone. How can we erase this bar ?
We can’t get rid of the google search bar and we can’t get rid of the top date bar either. Unless installing another launcher.
What’s the next good idea from google for reducing the freely usable space on the home screen ? I saw other comments about this topic in this forum. But if somebody has a solution, without installing another launcher, She/He will get my undying gratitude.
All in all, nothing will change in my life with Android 10.

2 Likes

If you don’t like the launcher, installing a different launcher is the Android solution. That’s why it’s so easy to install a different one, and that’s why tons of different launchers are available.

With Android 9, even uninstalling com.google.android.googlequicksearchbox, which is way more intrusive than just installing something else, left an empty defunct box in the stock launcher … Home customization.

4 Likes

EDIT
This issue is fixed. Thanks to the operators!

I wanted to try to install the update manually following these instructions. But each time I click the “Windows 10” link at the bottom of the page, a “Page not found” site will open and say:

“oops You’re not authorized to access this page”

Wtf? I’m definitely logged in to my personal FP account, having access to all my personal data. So why can’t I open this page?

Thank you so much! It was quite frustrating because I really want to get dark mode.
I’m using Bouygues (french provider) and the update wouldn’t show up. Other Bouygues users told me that they got the update so I tried your trick. I took my wife’s SIM card. She uses SFR (other french provider) and the update showed up.
Thanks again.

Except for a few security improvements, there is technically nothing extraordinary about the operating system in android 10.

Well, if you have been trying in vain for weeks and months to connect your phone to your car audio system in order to be able to phone while keeping your hands on the steering wheel, and now at last there is a solution for this - I would call it a technical improvement.

2 Likes

Is it really related to Android 10 and not the car itself though? I connected my FP3 with Android 9 over bluetooth on 5 different cars from 5 different constructors and it always worked.

@Sideness It is. Although this issue will only appear with certain car audio systems (e.g. Ford, Toyota), the cause is on FP’s side as they have committed in another thread. And it is reported to be fixed in this update.

1 Like

Only issue I have is the location of the clock on the top bar.

No space between network operator and time plus said operator being three leads to it looking very odd :yum:

2 Likes

There’s a strong difference of the behavior of Google Translate’s tap-to-translate feature in Android 9 and 10, and this is going to keep me from upgrading for now. On Android 9, there’s a bubble that appears suggesting the translation just after one copies some text. On Android 10, one has a persistent notification that one needs to use to manually make the bubble appear or disappear; it sucks.

Okay that’s great news then :slight_smile:

This topic was started by the same user. So I’m a little bit puzzled now - is it safe to install the update manually or is the fastboot update file really corrupted? Any experience?

@HMZ: The manual install package with checksum (33eead130c19ff33505b1f917518ca00082e907ec7d745cd8742e3766bdc560b) seems corrupt, see my earlier post:

Thanks @_tmp, an can confirm this with a freshly downloaded zip file. I wonder why this file is still online…

Maybe @rae can help to get the manual installation file removed quickly before more people try to flash it?

1 Like

That was either very quick or a coincidence (thanks anyway!) but there is a new image (edit: removed link again, flashing that seems to cause issues with the SIM slots) on the manual installation page with checksum 05d29f80848dc9... and testing looks good:

$ unzip -t FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage-repack.zip 
Archive:  FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage-repack.zip
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/   OK
    testing: __MACOSX/._FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/NON-HLOS.bin   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/partition.txt   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/FP3_flashall.bin   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/AdbWinUsbApi.dll   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/km4.mbn   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/macos/   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/sbl1.mbn   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/boot.img   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/vbmeta.img   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/config.bin   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/cmnlib64_30.mbn   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/partition.xml   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/linux-x86/   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/rpm.mbn   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/mke2fs.exe   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/cmnlib_30.mbn   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/FP3_flashall   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/splash.img   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/system.img   OK
    testing: __MACOSX/FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/._system.img   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/adspso.bin   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/FP3_flashall_cleanfrp.bin   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/adb.exe   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/AdbWinApi.dll   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/lksecapp.mbn   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/emmc_appsboot.mbn   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/dtbo.img   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/fastboot.exe   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/devcfg.mbn   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/vendor.img   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/tz.mbn   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/FP3_flashall_cleanfrp   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/product.img   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/frp.bin   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/userdata.img   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/mdtp.img   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/FP3_flashall.exe   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/macos/mke2fs   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/macos/adb   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/macos/fastboot   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/linux-x86/mke2fs   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/linux-x86/adb   OK
    testing: FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage/linux-x86/fastboot   OK
No errors detected in compressed data of FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage-repack.zip.

(Note: I have not tried to flash it)

Edit: Please don’t flash FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage-repack.zip with the checksum mentioned above.

2 Likes

O.k., it has been replaced (amazing reaction!), and unzip -t won’t complain anymore. I’ll try to do the manual update later today.

You can get rid of the operator’s name until this bug is fixed (or even for good, of course): Settings > Display > Advanced > Network name: off

3 Likes

O.k., manual update worked so far - but now the phone doesn’t recognize my SIM card any more.