Play Pokemon go

Salut Steph !
J’ai testé hier avec la version 0.37 en ayant désactivé le root et le jeu n’arrivait pas à se lancer : il se bloquait au chargement, mais sans message d’erreur. Je vais tester encore…

(english) I tried yesterday with version 0.37, having deactivated root in the settings, the game was stuck during the loading screen, but no error message. I’ll try again soon…

Salut Oli.sax !
Est ce que tu as désactivé le root avant d’installer ou juste avant de lancer le jeu ? ou les 2 ?

(english) Thanks.
Have you deactivate root before installation or just before start the game ? or both ?

Unrooting/using Magisk isn’t engough since microG doesn’t support SafetyNet:

So sadly you need the official GApps (maybe the nano version of is enough) for 0.37. :frowning:

1 Like

Ok thank you @Chrisb for pointing that out ! This explain why I wasn’t able to log-in.

I just tested installing the RootCloak Xposed module to hide the root binary (link, or link2 for a similar procedure with the app Hide My Root) and was stuck at the same place in the loading screen…

1 Like

Can someone answer me this question (since i am a mobile phone/android noob :P)? When the alpha will get officially released does it ‘unroot’ the phone? I am just wondering if my phone was rooted from the start or because i installed the alpha version (macadamia).

Hi all,

Pokemon Go is not able to login with error message authentication failed and try again. Also Pokemon Go prints out that no GPS signal is available.

I have installed the latest FP Open image plus …

  • microG Services Core
  • microG Services Framework Proxy
  • microG UnifiedNlp (no GAPPS)
  • microG Store (FakeStore release)
  • MozillaNlpBackend
  • Xposed Framework v86
  • Xposed Installer w/ module FakeGapps

Does anyone have an idea why this app is not working?


Update that to the absolute latest:
Self-Check the device launching microG Settings. All options should be checked.

If that doesn’t work, then it’s some imcompatibility with the P-GO app itself.
Also, I read somewhere they’ll ban users with rooted phones.

There’s an updated Pokemon GO thread already on the forum:

With the latest Pokemon update it doesn’t work on modified OSes any more.

Maybe you can find a solution here:

Thank you all. That’s no good news. I did run the microG device Self-Check. All options are checked. So I assume It’s right: The new version of Pokemon Go is not working with modified OS anymore.

Meanwhile, I thought about to install the OS with Google again to avoid such issues. On the other hand I don’t feel good with that idea, because I don’t want to give google too much data.

What about just don’t add the google account data to the phone? Everything should be fine, since I can still use raccoon to get the 6 apps from PlayStore I am working with and transfer them to my phone with USB.
My open source apps from F-Froid are running on a “google” OS as well. Nothing need to be changed on this end.

What do you think about this? Isn’t microG just an kind of trimmed open source Google framework?

Yes, you can try that. Just not using a Google Account will not be enough though as GAPPS still communicate to the server. You could disable most Google Apps or even try to delete them. That would be Method 3 in this Wiki.

Microg is a FLOSS project that has the goal to substitute many Google Services (all except for anti services like AdMafia or whatever it’s called) and integrate them into the Android System in a way that lets Android and installed Apps believe that it’s Google. (Same Package names …).

@all: I tried Magisk on a fresh Open OS and it didn’t work. Even though I installed the recommended Superuser the Magisk manager kept saying “root not implemented correctly - Android Pay won’t work” (so Pokemon won’t either).

Next I’ll try FP OS, flash Magisk, flash Root, uninstall all GAPPS with Titanium Backup and see if it works then. (Maybe the problem with Open OS is that a different root method is already implemented)

1 Like

Since the official FP OS is Android 4.2 you won’t be able to play Pokémon Go. It needs 4.4.2 and this is only possible with the macadamia alpha release or something like cynagenmod afaik.

@uwedd was talking about FP2 OS, which is Android 5.1 (s/he came from FP2 Open OS)

As far as Open OS is rooted, Pokemon GO won’t work. You can try to unroot it (flashing FP2 GMS OS’s boot.img, maybe?) and then applying Magisk stuff. Complex one, it may not work after all.

Annoying SafetyNet and bad decission from Niantic… “one does harm, and another bears the blame”.


I’ll try to get refund from Niantic, since the in-game buy can ot be used anymore.

This makes sense.

FP Open out of the box is not rooted. At least FastGPS isn’t working on my phone, which tells me it is not rooted.


It is. Just a switch in the developer settings. The su binary is preinstalled, so I guess SafetyNet detects it anyway.

I installed the pico version of opengapps, but sadly pokemon go 0.37 still blocks at the same place in the loading screen…

It looks like marvin (the author of microG) will implement SafetyNet in the near future:
Issue on GitHub
So we hopefully won’t need OpenGApps (but some workaround for the root detection…).


@Chrisb @oli.sax: OpenGapps was never needed, that’s what microg was for. The current situation is only caused by niantic blocking rooted and modified systems.

That’s great news! @larma is the best! :smiley: (And not just because he makes it possible for us to play pokemon!)

For now my workaround is: Play pokemon on an old iPad without GPS or a SIM. I use my FP’s wifi hotspot and can still only play near wifis so I don’t get the “GPS not available” error. I figure if I use an iPad with a fake Apple ID for nothing else than Pokemon neither niantic nor apple will gather much relevant data from me.

1 Like


Does anyone has tested pokemon go v0.39.1 with FP2 open OS16.06.0 (or higher) ??
Because now, Niantic has blocked the connection with v0.35 for all !!


I’m trying to ! :slight_smile:
There is a new version of microG implementing SafetyNet (cfr Chrisb link) !

I’m still trying to figure out what are the exact prerequisites, mar-v-in is speaking of

  • “Update microG Services Core to 0.2.4-20”
  • “Install microG DroidGuard Helper from the f-droid repository”
  • a specific root app (“supersu does not work. You have to be using topjohnwu’s magisk and with phh’s superuser”)
  • a specific version of Xposed (“systemless xposed, also by topjohnwu”)
  • i’m not sure if Magisk is mandatory, or RootCloak can be used instead…

This is quite a lot of new information for me, but i’ll try to test all that :wink: