Play Pokemon go

I followed the steps and I almost got it working. Only thing is the location my phone finds is very coarse. When I’m walking around my avatar doesn’t follow me but it moves around one specific spot 100-300 m from where I actually am. When I’ve moved far away enough my avatar jumps to a different spot (also not my real location) and shows the same behavior. It’s not related to the app itself, apps that use location like OsmAnd~ and satstat behave the same way. Does anyone know what the cause of this could be?

I have my location set on high accuracy, but I’m sure it only uses wifi and/or cellular networks because when I tell my phone to use gps only it doesn’t find a location at all. Is there a way to get the gps working or do I have to find a solution using wifi and/or cell networks?

afaik the app is still quite buggy. A lot of my friends with different phones (Samsung Galaxy, iPhone etc) encounter similar problems. I would wait for the next few updates, when the app becomes more stable. :slight_smile: I hope it’s not a problem from the Fairphone OS at least.

Hi folks !

I never had to install Xposed by now : can anyone tell me where I can find a newbie guide to install Xposed ?


Check the gpsguide for some ideas (ignore everything about EPO and A-GPS if you use an FP2).[quote=“aljoscha, post:43, topic:19779”]
afaik the app is still quite buggy.

For me it works quite well. The only issues I have come from the server being overwhelmed.[quote=“antzen, post:44, topic:19779”]
can anyone tell me where I can find a newbie guide to install Xposed ?

I followed this guide:

The downloads weren’t working for me so I got them from here (the SDK22 ones):

Thanks! I solved it by standing still outside for a minute.

The same thing happens to me and to a friend (also with a FP2) as well: the phone just reboots while playing (and only while playing Pokemon Go).
The battery drain and heating I expected, but this is very annoying. Sometimes you can’t play for 5 minutes without a reboot and sometimes it can last for > 30 minutes…
I also have the “non-responsive screen” issue. Sometimes on the app level, then I have to restart it; sometimes on the phone level, then I have to lock/unlock it and that brings the “touch” functionality back (most often)

The reboots are most likely caused by the heat, so if it happens - or even better: before it happens - turn off the phone, disassemble it and/or hold it against a cold surface to cool it down before you boot it up again. Then it should work well for a longer time again.

I have that too when I have the app’s battery saver enabled. If you point the phone down the screen goes dark and if you flip it upwards again the usual screen appears and the touch input should work again - but it doesn’t always. So I turned off battery saver and now I don’t have these issues anymore.

Now with the newest version 0.31.0 pokemon go crashes if I activate location. :confused:

Edit: uptate to newest microg 0.2.4-3-g47a61d6 seems to fix this


Thanks so much for the edit, I was so upset about the latest update!

Now it’s time for me, a complete novice in anything to do with software, to try and install microg… :sweat_smile:

I read somewhere that pg only picks up GPS signal if your WiFi is turned on, which works for me.

Hello guys :slight_smile: I’m a novice Ex-Newbie :stuck_out_tongue_winking_eye: (well, i’m still a newbie)
I installed Open OS, i installed microG and some of his Backend and used Xposed to spoof the signatures (and was surprised not to have destroyed my new Fairphone^^).


But now, i would need one more last thing :slight_smile:
In this topic, @Roboe talked about a Backend (he did ?) - TravelerNlpBackend - that i would like to add (to play from my room, instead of going out at night with myjama :wink: ).

But there i have a problem ! Sources are on Github (cool :slight_smile: ) and i don’t know what to do with the sources… i think that i have to build/compile with Android Studio, and i tried… but i blocked when i saw the ‘Build APK’ window…

So please, could a nice personn explain me what to do with those sources ((s)he would by the way learn me a great thing to add to my newbie skills :wink: )

PS: I love Fairphone and Open-Source, gosh you inspired me to keep on learning programming :sunny:

I have installed microG 0.2.4-3g47a61d6 and I’m already logged to the game, I get the following scenarii :

1 - Wi-fi only without location = PG works - no GPS signal
If location activated, PG crashes.

2 - Wi-fi only + location = PG crashes

3 - Mobile network only without location = PG works - no GPS signal
If location activated = PG crashes

4 - Mobile network with location = PG works - no GPS signal

5 - Mobile network + Wi-fi without location = PG works - no GPS signal
If location is activated = PG crashes

6 - Mobile network + Wi-fi with location = PG crashes

So for me there is three cases :
A - (1/2/5/6) PG crashes when Location and Wi-fi are activated : the problem can be solved if I ask Mozzilla Backend not to use Wi-fi, in this case PG works and GPS signal is not found.

B - (3) if location is activated when PG is launched, it crashes.
Therefore always activate location before to launch the PG.

C - (4) location is activated when PG is launched, PG works but GPS signal is not found.

In conclusion : activating location in-game makes PG crashes.
I still don’t know why GPS signal is not found :confused:

Hi @antzen :slight_smile:
For the crash I can’t help you :frowning: For the GPS signal, i can :wink:

When you open microG Settings, and click on Setup > Self-Check, you need all boxes to be checked, even the ones about signature spoofing. Do you have this ?

Today when I opened up Pokémon Go, it forced me to get an update. So I got the latest APK, which has loaded once, but keeps on crashing. I don’t really feel the desire to get my setup working just to play the game I was already getting somewhat tired playing. @antzen I guess we are having similar issues at the moment. At least I improved my app compatibility using microG and location services.

Concerning crashes there’s nothing to do except launching location before to launch PG.
It seems that if you use LocalWifiNlpBackend (F-droid) you can play PG with Wi-fi. I tried it at home but not with a public Wi-fi.

And yes, all the boxes are checked … which is why I don’t understand why I don’t get the GPS signal …

Now I’m fed up with trying to configure my FP2 … :angry:

Try other backends may’be, GSMKocationNlpBackend worked for me, and he doesn’t need network connectivity.
I have FakeGapps (Xposed module) on my phone too, and FasterGPS, i don’t know if it is useful or not…
Good luck

Hey, I answered you on the GitHub issue.

Great you figured how to install microG and stuff on your own, keep that spirit! It’s needed if you want to be a developer someday, :wink:

PD: indeed, I coded that UnifiedNlp backend.

1 Like

I updated pg to 0.31.0 recently and now it crashes whenever it gets my location. If I switch location on, it crashes, if I switch location off, it works, and if I set it ‘device only’ it works until it finds enough satellites. The only error message is ‘Unfortunately, pokemon go has stopped’. The old version worked fine (and still does except for it being old). I have fp open os with xposed and microg.

Any suggestion would be helpful

Which version of microg do you have?

1 Like