Play Pokemon go

That escalated quickly, young traveler :slight_smile: Wandering around a lot these days?

Well, not so much. I had the backend working (a bit rudimentarily, I admit) since last Tuesday or so. Game itself bored me (although I love first Pokémon games), so I’ve not dedicated it any actual walk, just a few coding hours, :wink:

I skipped that earlier! HAHAHA, :joy:

1 Like

It doesn’t properly ‘works’ on fp2. It ‘launches’ very well, yes :slight_smile:
But, as many have already reported, it crashes after a few minutes of play :frowning: (1.5.1 ; “go-game” crashes, usw)

@paulakreuzer, how exactly did you follow the instructions provided by MaR-V-iN in the xda-developers-forum? I got stuck at the point “Open systems settings -> Apps -> Gear icon -> App permissions”. Where did you find this gear icon on the FP2?
Thanks in advance!!
And @larma, you really rock!!! Thanks a lot for your work!

1 Like

This is for Android 6.0+ so you have to skip this, but you need to install Needle (or xposed framework) for signature spoofing :wink:


Previously you could find the guide on how to install microg here and some links on the forum still redirect here.
But the guide has moved there.
(To make Pokemon Go work you’ll have to go thorough the whole “Level 5” guide. For many other apps just doing Level 5/Step 5 will be enough.)


Thanks a lot for the hint!
Now all the marks are checked and Pokemon Go works fine for me! :slight_smile:
@paulakreuzer I took your suggestion and am now contributing to openwlanmap and mozilla stumbler, thanks for telling us! :blush:

But now I have another problem. I switched from the Google-FPOS to Fairphone OSOS yesterday and installed xposed framework via TWRP (which I didn’t know that it was already on the phone; thanks a lot for that, FP-Team!!!) and now I have 2 issues: firstly, my screen won’t turn off automatically anymore and secondly I cannot install any apps anymore for the “install” button in the access-window isn’t reacting anymore.
First I solved the problem by restoring a nandroid backup I did before installing xposed-framework, but after installing it again and also the fakegapps module I wanted to install an app called “BatteryPercentEnabler” and again the install button didn’t work anymore. So either this app or the Xposed Module FakeGapps was the trigger for my problem.
Does anyone know one or both of this problems?

Some hints would be great, otherwise I will restore the backup again and try again to find out whats causing this issues…

Thanks guys and have a great day!

PS: when downloading, I had to choose between x86, arm or arm64 or something. I took arm, that is correct for FP2, right?
Then, when I wanted to flash it with TWRP, there was a box checked “check signature” or something similar. Then, the flashing process was aborted because of failing to verify the signature. When I unchecked the box, the installation was successful…
Could my problems described above be related to this?

The install button not working occurrs while OpenWLANMap is running. You have to open the app, tap the menu button and “quit”. Closing alone won’t be enough.
This is some strange Android security feature that disallows installing apps while some apps are running - it’s the same with apps like lux, that put a layer of color over the display.

hahaaaa, great!! it so easy :smiley:
Thanks again man!!
OpenWlanMap was also responsible for the screen not turning off. there is a setting where you can decide if the screen should turn of or not while collecting data. And it was set on “display on” by default :rolling_eyes:
Now everything is alright again, I have OSOS, Xposed Framework and Pokemon Go working like a charm! :blush:

This really is a great forum!!

1 Like

Same problem here. it keeps rebooting. Also after a while (once the screen has turned off) and bringing it back to live, the screen is non-responsive, so you have to close the app and start it again. Very annoying. Does this happen to you too?

I followed the steps and I almost got it working. Only thing is the location my phone finds is very coarse. When I’m walking around my avatar doesn’t follow me but it moves around one specific spot 100-300 m from where I actually am. When I’ve moved far away enough my avatar jumps to a different spot (also not my real location) and shows the same behavior. It’s not related to the app itself, apps that use location like OsmAnd~ and satstat behave the same way. Does anyone know what the cause of this could be?

I have my location set on high accuracy, but I’m sure it only uses wifi and/or cellular networks because when I tell my phone to use gps only it doesn’t find a location at all. Is there a way to get the gps working or do I have to find a solution using wifi and/or cell networks?

afaik the app is still quite buggy. A lot of my friends with different phones (Samsung Galaxy, iPhone etc) encounter similar problems. I would wait for the next few updates, when the app becomes more stable. :slight_smile: I hope it’s not a problem from the Fairphone OS at least.

Hi folks !

I never had to install Xposed by now : can anyone tell me where I can find a newbie guide to install Xposed ?


Check the gpsguide for some ideas (ignore everything about EPO and A-GPS if you use an FP2).[quote=“aljoscha, post:43, topic:19779”]
afaik the app is still quite buggy.

For me it works quite well. The only issues I have come from the server being overwhelmed.[quote=“antzen, post:44, topic:19779”]
can anyone tell me where I can find a newbie guide to install Xposed ?

I followed this guide:

The downloads weren’t working for me so I got them from here (the SDK22 ones):

Thanks! I solved it by standing still outside for a minute.

The same thing happens to me and to a friend (also with a FP2) as well: the phone just reboots while playing (and only while playing Pokemon Go).
The battery drain and heating I expected, but this is very annoying. Sometimes you can’t play for 5 minutes without a reboot and sometimes it can last for > 30 minutes…
I also have the “non-responsive screen” issue. Sometimes on the app level, then I have to restart it; sometimes on the phone level, then I have to lock/unlock it and that brings the “touch” functionality back (most often)

The reboots are most likely caused by the heat, so if it happens - or even better: before it happens - turn off the phone, disassemble it and/or hold it against a cold surface to cool it down before you boot it up again. Then it should work well for a longer time again.

I have that too when I have the app’s battery saver enabled. If you point the phone down the screen goes dark and if you flip it upwards again the usual screen appears and the touch input should work again - but it doesn’t always. So I turned off battery saver and now I don’t have these issues anymore.

Now with the newest version 0.31.0 pokemon go crashes if I activate location. :confused:

Edit: uptate to newest microg 0.2.4-3-g47a61d6 seems to fix this


Thanks so much for the edit, I was so upset about the latest update!

Now it’s time for me, a complete novice in anything to do with software, to try and install microg… :sweat_smile: